Squeezebox Touch and Roon with Ethernet

Roon Core Machine

Macbook Pro

Networking Gear & Setup Details

Sky Router

Connected Audio Devices

Squuezebox touch > Chord Mojo > Arcam Amp

Number of Tracks in Library

Description of Issue

I am having audio dropouts (or just plain not playing tracks) and I can’t figure out why. I’m certain it has only started happening recently. I’m not overly technical, I just want it to work as before!
I have the squeezebox touch connected to router. I assumed the issue was because i didn’t have a wired connection between my core (MacBook pro) and the router. So I’ve connected an ethernet cable to the router and still happening.
So basically the core is connected to the router with ethernet and the squeezebox touch is connected with ethernet from router.
The thing i’ve noticed is if i switch off wifi on my MacBook then the roon loses the squeezebox in audio outputs, despite there being an ethernet connection. I don’t know what i’m doing wrong with the connections. I’m pretty sure that i tried the ethernet cable between MacBook and SB and that didn’t work. Why does squeezebox disappear in roon if i turn off wifi on MacBook when it’s all worked now?

I’m not familiar with macos but it sounds like the squeezebox is only being seen over WiFi still.
Not sure if this is a setting you need to look at in the squeezebox or Mac or both but I would check them to be sure.

I actually had it working now without wifi, but still getting dropouts. I actually think the issue is something to do with Qobuz and Roon and i’m getting the same thing happen with Bluesound speaker. Probably will try disabling qobuz and re-enabling it.

Ok
One thing to try that might help.
Sign out of Qobuz.
Reboot the Mac and the squeezebox.
Sign back into Qobuz.

Thank you. Will try this.

Didn’t work unfortunately. Definitely an issue with Roon/Qobuz as Roon works fine through BluOS. I will
Start a different thread. Thanks for the help.