Stack Audio Link - Uncertified Roon Ready

Core Machine (Operating system/System info/Roon build number)
NUC running ROCK.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/)
Stack Audio Link into Chord Qutest

Description Of Issue
On both the Roon Partners page and on Stack Audio’s website it shows the Link as Certified Roon Ready yet I have a message under Settings/Audio that the Link is Uncertified.

The link has up to date software version 2.072 and I am running the latest Roon release.

Please advise.

Is it the Link 2 or just the Link?
They released an updated version recently that perhaps has not been passed yet?

It’s the original Link with the updated software.

Sounds like a bug then…

I have a Link with version 2.070 which is for me the latest version available in update from the link and this version is “Roon Ready”.

I have a LinkII with with software version 2.070 and it appears as “Stack Audio Link” and apparently is certified. I’d write Stack and also flag @support here. Sounds like some sort of bug to me.

It maybe that the devices list cache in Roon needs refreshing, try rebooting ROCK

If it is certified and that’s does not work Roon’s @support can force a cache update on next reboot.

Thanks for your response, tried rebooting both Rock and the Link to no avail.

Hi @SWC,

The Stack Audio Link II is a certified Roon Ready device, so it looks like is causing Roon to not properly show this.

Would you kindly try the following:

  1. Stop RoonServer from the Web UI.
  2. In Finder or File Explorer, navigate to your database location.
  3. Open the folder named “Cache” inside your Roon folder.
  4. Delete the file named “” and “” if you have that file as well.

After this restart RoonServer from the Web UI and let us know if there is any change. Thanks!

Hello all,

The LINK’s latest software has recently been certified as Roon Ready.

At this point in time we are unsure as to why the 2.072 version has triggered this but we are working to have this rectified as soon as possible.

Apologies for any uncertainty this may have caused.

Many thanks.


Hello all,

After further investigation, we have been informed that the device is certified by the name that is submitted to Roon. As we have changed the display name of the Link platform in our latest software update, we have triggered this response on Roon.

We apologise for the the uncertainty, this issue will be fixed shortly and we would like to reiterate that the Link II is still a certified Roon Ready device!

Many thanks.



Hi Dylan,
I am having a similar issue trying to connect Roon Nucleus to my new SA Link 2… It is connected to network switch by ethernet and PS Audio DAC/preamp (Stellar Gain Cell DAC) by USB but is not visible as an audio zone in Roon… I tried the steps you laid out above, but the Link is still not found. Do you have any other advice?? Thanks

Hi Roy,
Which software version are you running on the Link?

version 2.073. I was chatting with Theo earlier today. He is also looking into it…

Ok. If not already done so power everything down and then bring back up. Also check the Link and make sure you have only 2 blue leds lit. If you have 3 you may have accidentally pressed the USB detox which may result in Roon not recognising the Link in audio settings. Hope this helps.

Thanks, Steve. I’ve tried it, and only 2 leds currently. Hopefully, Roon support or Theo will have some ideas.

Hi @Roy_Kelly,

Would you kindly use the directions found here and send us over a set of logs using a shared Dropbox link? Thanks!

1 Like

Here you are, Dylan. Hopefully, this helps.

As discussed via email. It should work perfectly with your Stella DAC. We are going to try it on another Stella DAC as a process of elimination. I am contacting PS audio to see if they can offer any further assistance.

1 Like

Hi Dylan, just following up. Any findings?