Static, glitches, and pops with Bluesound

Roon Core Machine

Roon Core on a NUC

Networking Gear & Setup Details

Ubiquiti Dream Machine Pro →
Ubiquiti 24-port switch (in a closet ) →
Ubiquiti Light 16-port switch.
All the components that I mention connect by ethernet.

Connected Audio Devices

Marantz surround-sound receiver → Parasound Hint Halo → speakers.
Bluesound Node 2i → Halo 6.

Number of Tracks in Library

Description of Issue

When I play through the Marantz, the Marantz connects to the Halo 6 in the latter’s bypass mode.

When I use Roon to play my music and bypass the Node 2i, I have Roon stream the music (both Qobuz and files saved locally to my NAS) to the Marantz, which outputs the music without any problem.

I also use Roon to output from my NUC (the one running the Roon Core) directly to the Marantz (even in surround sound) without problem.

But, whenever I use the Node 2i, connecting to the Parasound Halo Hint 6, using digital coax, I hear pops, glitches, and static.

When the Marantz connects to the Parasound using bypass, he Parasound isn’t using its DAC, etc. The same is true when the NUC outputs directly to the Marantz (a setup I use mostly to play surround sound).

In the room with the Marantz, the NUC, etc., I used to have a regular Node 2, which died, and then I replaced it with the present Node 2i.

The only other change I made was to move the NUC from my main switch (the one in the closet with the Ubiquiti 24 port connected to the Ubiquiti Dream Machine Pro) to the 16-port Ubiquiti Lite switch, to which the Node 2i is connected, in the same room as the Parasound, the Marantz, the Node 2i, and the speakers.

So it may be that the move of the NUC introduced the problems, but I do not hear those problems when streaming directly from the NUC to the Martinez or directly from the Marantz.

I just tried moving the NUC back to the main closet (with the 24-port Ubiquiti switch and the Dream Machine Pro), but it doesn’t seem to have stopped the static, etc.

May help?


Thank you. That did work… so far. I appreciate your help.

I don’t understand why it worked, though. I thought that Roon maintained its own library, independent of BluOS. After all, I rarely reindex with BluOS, yet Roon keeps my library up to date. I guess I shouldn’t ask questions.

Thanks again.

1 Like

Andrew I never added any music to my BlueOS library as it worked with everything I already had and I added a Chromecast audio to it to furnish it with all the streaming capabilities needed.
Roon picks up 95% of the music playback so why bother

No idea - just picked it up from another thread as I use a NAD. Mine is indexed off a qnap and Roon is stored on a Mac mini. If one goes down I still have t’other.

1 Like

That’s why the fix doesn’t make sense to me, though so far it has worked. If Roon’s library is independent of BluOS’s, why would removing, adding back, and reindexing the latter make a difference? And will the problem crop up again down the line? Thanks again for the tip.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.