Streaming Issue: Stream Stops Playing at Digitiki.com with "Uh Oh, Something Went Wrong" Message (ref#379EF8)

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

I started having an issue streaming quiet village radio at digitiki.com several weeks ago. I can start playing but the stream stops in under 20 minutes, usually under 10. It stops playing and says uh oh, something went wrong. Make sure your roon server is connected to the network.

Describe your network setup

Orbi wifi 6 mesh network. My roon rock is attached via ethernet cable.

Hi @Steven_Mize,

Thanks for writing in!

Based on your screenshots, it looks like you’re using an iPhone as your remote devices to control Roon, do you also see this issue when using other remote devices?

Is your ROCK connected to your primary router? Or, one of your mesh nodes? I’d connected your ROCK directly to your primary router and see if your issue persists. :+1:

Thanks for the reply. It doesn’t seem to make any difference which device I use to control Roon. Rock is connected via ethernet to the router.
I have also tried playing other live radio without experiencing this issue so I contacted the owner of quiet village radio and he hasn’t heard of streaming problems from anyone.
One of the messages I receive is something to the effect of the address of the station may have changed so I also wondered if there is a better stream available.

Hi @Steven_Mize,

Before anything else, I’d update all your Roon devices to the latest release, 1432.

Have you added the stream link directly from the website itself? Or perhaps TuneIn or Radio.net?

I generally keep everything up to date.
I also tried adding the radio station manually from radio.net and tunein but got a message saying roon could not find a station at this address.

Hey @Steven_Mize,

Your MacBook pro running Roon as a remote is still on build 1413 - give that an update and see how things go. :+1:

I updated the macbook but still have the same issue.
I’ve tried running the stream through a couple of different endpoints - a Ropieee XL and a Wiim Pro. They both failed using with roon. The Wiim Pro has some apps installed so I tried listening on Tunein radio and that seemed to work mostly ok. I would occasionally get a dropout but the stream would start back up without my intervention. On roon, it stops and requires me manually hitting the play button.

Hi @Steven_Mize,

This does point more towards network based issues versus anything else. Could you reproduce and share a fresh date, time, and if possible, name of track that was attempting to play when the streaming issue starts?

Thank you!

I just tried it and it failed at 4:56pm today. The stream lasted about 10 minutes which is typical.

The song was Chiu, Chiu by Augie Colon. I attached a screenshot of the incident

Hi @Steven_Mize,

Thanks for sharing the timestamp! We were able to review a fresh diagnostic report around the time you’ve shared, and see errors in relation to network buffering, dropouts, and the server stopping playback.

Perhaps reviewing your router settings, and seeing if there’s any option to allocate additional network bandwidth to your ROCK may be helpful in this case. What specific router model are you currently using?

It’s an Orbi RBR850 wifi 6 system

Thanks @Steven_Mize,

First, here are the steps to access your router settings:

To view the WAN settings:

  1. Launch a web browser from a computer or mobile device that is connected to your
    Orbi network.
  2. Enter orbilogin.com.
    A login window opens.
  3. Enter the admin user name and password.
    The user name is admin. The password is the one that you specified the first time
    that you logged in. The user name and password are case-sensitive.
    The BASIC Home page displays.
  4. Select ADVANCED > Setup > WAN Setup
    The WAN Setup page displays.

A few things to check:

  1. Can you confirm IGMP Proxying is enabled?
  2. What NAT Filtering options do you have? You could potentially test out lowering the filter just a bit to see if playback smoothens out.

Outside of that, assigning additional network priority to your ROCK would likely be helpful as well.

Let me know!

The box for “Disable IGMP proxying” is checked. Should it be unchecked? MTU size is set to 1500 bytes.
Under NAT filtering the box for Disable SIP ALG is checked. There aren’t any other options. Also, the box for secured is checked and open is left blank.

I googled the part regarding network priority but nothing came up. do you know the section where I can do that?

Hey @Steven_Mize,

Yes, go ahead and uncheck it and see if your issue persists afterward.

You can leave that checked, it won’t touch Roon in this case.

This is within the NAT filtering box? It may be worth temporarily disabling this setting as well, just to test and see if you’re still experiencing the issue.

Let me know the results! :pray:

I made the two changes but unfortunately still have the issue.

Update - I spent some time with netgear support and they suggested a couple of changes. the first change was connecting my roon rock directly to the router. They also made a change of adding roon rock to the default dmz server.
Since making those changes, my radio station has been playing for over an hour. Keeping fingers crossed.

Connecting/exposing a ROCK machine directly and unfiltered to the internet is probably not the smartest move. That is not what it was designed for.

Remark: In my experience, this is a move to cut down on support time and/or avoid to tell the customer that it is not possible to do what the customer wants in a secure way with the product he owns. If later on, maybe months later, when people may run into trouble (hacked machines/accounts, crypto-locked data) they’ve already forgotten about the support ticket and changes made in the past. If they remember and approach the company about it, they usually simply get told that the customer wanted the issue fixed (blame the customer) and/or the company isn’t responsible for security (breaches) at the customers location (TOS).

Please take the warning in that document seriously!

Thanks - I will disable that setting and see if the other changes are what fixed the issue.