Stuck in : Your device is configuring don't reboot

Hey Everyone,

AlloBoss (1.2) running in RPI3B+ (bought from Allo folks).
I have configured it (downloaded the Roopie os, flashed the card etc , configured Wifi (using the dongle they sell on their website)… the first settings (change output to hat, rename, set-up internet worked flawlessly, commit to changes, the device did it and rebooted itself.
Starting from the point on, any other changes (change timezone, upgrade to Roopie XL, set-up sharepoint…) once i click on commit to changes, it stays on that screen forever (even changing the LED settings, resulted in the same issue).
When force rebooted (unplug and replug power) device has already made changes and works flawlessly; i said, okay this is an always on device ill live with that i wont update it, moved it to my listening room, plugged it, working .

2 months later (today) , it disappeared form roon, tried the traditional unplug and replug, not working again, so i decided ill give the Micro sd another reflash maybe it will resolve the issues.

Same story again, first initial setup is good, changed name, enabled Wireless, device rebooted normally, other changes => the device stays on the "your device is being configured…).

Before i make all changes and put it back to listening room, could the above be a Micro SD issue ? or i got a bad RPI3 board ? Have you guys encountered the same problem ?


In short: NO

I’ve got a Pi 3 Model B Plus Rev 1.3 with touchscreen and HiFiBerry DAC HAT and a Pi 4 Model B Rev 1.1 with touchscreen and USB-DAC, both running Ropieee Beta set for daily reboot/update, having no such issues.
Sometimes, like just yesterday afternoon, there’s an update available while I’m at it, and manually updating goes smoothly.
Just once in one and a half years of use, there was an update that bricked the Pi 3, necessitating a reflash.

I sympathize with your troubles and hope Harry @spockfish may be able to help fix your issue…

The only problem I had with a pi was a dodgy SD card, replaced it , reflashed worked fine again. We are prone to power cuts which I am sure doesn’t help . I even bought a pi4 unnecessarily, but …

You only need an 8gb SD card, hardly bank breaking to try

Few remarks:

Did you use the last image?
And take into account that upgrading to XL can take a long time in the configure step as it needs to download quite some stuff.


Hi @spockfish,

Yes indeed the latest version.
I agree woth you about upgrading to XL taking time, but even minor changes (change the LED status) will send the device to that state.

Hey Mike,

I’m happy to try another Card, just wanna make sure this behavior is not coming from the board itself.

Will wait for more answers, maybe other users experienced the same issue

Thanks for your feedback.

Can you send me feedback?