Stuck on White Screen with Roon Logo

Roon Core Machine

Intel(R) Core™ i7-8750H CPU @ 2.20GHz 2.21 GHz RAM 16 GB
Windows 10 Home Single Language

Networking Gear & Setup Details

Routers ASUS RT-AX82U , Internet Speed 1,000 / 700 Mb

Connected Audio Devices

Cambridge CXN-V2

Number of Tracks in Library

About 500 tracks

Description of Issue

I haven’t used roon for about 1-2 weeks. When I came back to use it again I found a new update. after update i can’t use it, it’s stuck on white screen. I tried turn off the firewall and window defender. still not working I deleted the program and reinstalled the program still doesn’t work.

Windows may have done some updates. Go to the pc or graphics card manufacturers website and get the latest graphics driver from there, not windows update.

I have updated my graphics card to the latest version. The problem of the program not working is still the same.

I turned off all firewalls and antivirus,window defender the program still doesn’t work.

The Roon Support team prefer one topic per customer’s issue… so they are able to track it and focus on each individual problem. Hence I split out your topic.

I’ve moved your posts to a new topic to the Support category of the forum, where it will be seen, and responded to, by a member of the Support team.

Hi there @Wiboon_Limsiriporn,

There are a couple of things that could fix the problem.

First is to eliminate databases as a potential cause. Try this for me. As long as you’ve been taking backups, no data loss should be involved. At the end of the process, restore your latest one:

  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

I have also seen this happen after delaying Windows updates. Please do ensure all Windows updates are installed. You might also visit Microsoft’s .NET page to ensure you’re up to date there as well.

Please let us know!


I followed your instructions. I still can’t use it The screen freezes as before.

I tried deleting Folder_old all out Installed again, it doesn’t work.

Hi @Wiboon_Limsiriporn and thank you for getting back to me.

Did you happen to investigate the Windows and .NET update angles too? Roon is dependent on many features included in Windows. With a fresh folder reload like you’ve done, Roon should be starting and only some other influence could cause this.

Some other possibilities are the Windows and router firewalls. You might try adding exceptions for Roon.exe and RAATServer.exe too. They’re located here:


Another possibility is device drivers. The most relevant is your video driver. Be sure they’re up to date via the manufacturer.

The last possibility is networking. I can see you’ve reloaded Roon many times and communicated with our account servers but no detail beyond that. I will send a request to your core for diagnostics and see if it comes back to me the next time you start Roon. Perhaps that can shed some light too.

Let me know how it goes, please. A fresh install of Roon with no database tells me something isn’t right with Windows or networking and I’m confident that one if not all of these suggestions will be of help!


1 Like

Hi Wes
I followed your instructions. I updated my graphics card driver and windows to the latest version. I turned off all antivirus firewalls, I deleted the program and reinstalled it still doesn’t work as usual, the program freezes to a white screen.
Note: I tried upgrading Win 10 -11 and everything is the same.


Hey @Wiboon_Limsiriporn,

Ben with the support team here, I see that you’re running the all in one version of Roon. I’d be curious, as a test, to see if running the headless version of Roon - Roon Server, would result in the same issue.

Do you have a mobile device or tablet or something that you could use as a remote to control and navigate around Roon, while you continue to host the core on your Windows machine? If so, this would be a good thing to test out.

Here is more info on Roon Server:

I tried roon remote. At first it connects (while laptop Freeze on white screen) I add my music and Tidal My phone home page doesn’t have any albums showing. I tried the remote off and on again, it unable to connect to my laptop.

The problem appears to be that your phone is losing wifi connectivity. Look at your screenshots…

Roon 2227

I tried re-checking the wifi several times, still the same.

I’ve just noticed, looking at the screenshots of your laptop, that it also seems to be losing internet connectivity.

Roon 2228

I don’t think this is a Roon problem - something seems to be wrong with your network.

You also have a screenshot showing that Windows AV protection and Firewall is off. Are you using a third-party product on your laptop?

I can see that it’s not connected but I tried it but I didn’t take a screenshot. I’ve tried both the internet at my home and my office and it’s the same.

Hey @Wiboon_Limsiriporn,

When you tested this, was your core device hardwired directly to the router?

To confirm, did you test out running Roon Server instead of the Roon all-in-one install?


I use a lan cable to connect.
I installed RoonSever and connected it to my mobile, it can login but the screen on my mobile also freezes.

I have a question, am I unable to use it, is it just me? If yes, I would try Clean install Window completely again.

Once again: why have you got the Windows AV and Firewall protection switched off?

That last screenshot of your phone in front of your laptop seems to show that your Roon Remote is communicating with your Roon Server Core, but that the Core is simply unable to communicate with Roon’s Cloud services to retrieve the Home page content…