Stuttering after 1.3 (203 build) update

After 203 update grouped up Roon enpoints stutter. As in play smooth, but as if two signals would be overlaping creating some weird echo effect.

I have mixed environment of 2 RPi’s Hifiberry+ on ethernet and 3 Hifiberries AMP+ on WiFi.
It does not matter if endpoint is on WiFi or Ethernet. Ungrouped it plays well, as soon as two of any kind are grouped the error is there.

Roon Core is on dedicated Windows 10 machine, RPi’s are running Hifiberry Roon Ready images.
Can I rollback somehow to build 200?

Have you tried a Core restart just in case?

Similar problem - sounds (for those old enough to remember) like having an echoplex unit.

I’ve rebooted everything and problem still there - playing singly is fine but combinations of endpoints (I have RPi, Bluesound, Meridian Explorer 2) cause the ‘echo’ effect.

Might be one for @brian

@support @brian

Effect (echo) seems to vary.

Haven’t got time today to check all combinations (6 endpoints means 64 combinations) but, so far, have noticed that:
(a) there is a longer pause (from what I remember in build 200) when you add an endpoint to the group before playing restarts
(b) sometimes the echo stays
© sometimes the echo goes away after a few seconds

Tried “double restart”, also restarted all endpoints. Problem persists.

Same for me - rebooted everything (Core, RPi, Bluesound) - but doesn’t affect all endpoints. Core running on Mac Mini.

RPi - adding one Bluesound speaker - delay of about 10 seconds before starts playing, then stutter for about 15 seconds then plays OK.

Bluesound - adding second Bluesound speaker - same delay, same stutter, then plays OK on one speaker but not the other.

Rpi - adding Bluesound Node 2 - delay, stutter on both, doesn’t go away.

Rpi - add Meridian Explorer 2 (on Macbook Pro) - short delay, no stutter.

Rpi with Meridian Explorer 2 - add Bluesound speaker - no stutter!

Think I’ll wait for reply from @brian or @support now before thinking about trying 60+ combinations of endpoints!


So with this latest update I am having issues. It is very specific. If I just play 1 zone, no problems. When I add a second zone, that 2nd zone stutters to start and then has clicky audio. IT IS ALWAYS THAT 2nd ZONE ADDED…It does not matter which type of zone the 2nd one is, the 2nd one added has the problem. The initial first zone plays fine.

The 2 zones in question are 1: My main windows PC outputting audio via ASIO to Peachtree DAC/Amp. 2. RaspberryPI with Hifiberry Digi+ Pro.

Again BOTH of these zones exhibit the behavior when added second to the playing audio.

I have restarted the PC the core and audio is on, and rebooted the Raspberry Pi.

Edit: Both zones I mention above have DSP DISABLED, and fixed audio out.

Hi @Kenneth_Price ----- Thank you for the report and sorry for the troubles here. I’d like to test this behavior on our end here, but before I do, may I kindly ask you to please verify the following for me:

  1. Are the zones being grouped together OR are the being played independently?

  2. Can you please provide screenshots of your audio settings for both zones.

  3. Are you noticing this behavior with any type of content in your collection or are you finding that this issue is more pronounced based on the codec and bit/sample rate of the media?


  1. Grouped together. When independent and playing, even at the same time, it does NOT happen.
  2. Attaching screen shots. Let me know if you need anything else.
  3. It happens with any bit rate or codec.

The initial repeating stutter happens to that 2nd zone at the start of every new song and clicking continues throughout.

1 Like

Hi @Kenneth_Price ---- Thank you for the follow up and taking the time to answer my questions. I am adding this to my queue and will follow up to share my findings once testing has completed.


Hi everyone ---- Thank you very much for your feedback and continued input, my apologies for the troubles here. I am going to be discussing this issue with my team today and will be trying to replicate this behavior on our end. I will touch base once with our findings after testing has completed. We appreciate your patience.



Thank you @Eric for such a quick reply. Much apreciated.
You kinda skipped this question at the start of thread…

If you kindly provide a link to older 1.3 (b200) of the Roon Core, reinstall would fix the problem in the meantime I think.

Hey guys,

We can reproduce this problem, and we think we’ve got a fix. Testing now, and hoping to release shortly.

Stand by guys!


am seeing same on my setup. good you found the fix. waiting patiently for fix…

1 Like

I noticed that a new version got pushed…problem gone! Man that is fast. Thanks!

1 Like


+1 Brilliant - great response from Roon team (as always!)!

1 Like

Reporting problem gone.
I am seriously impressed with speed of this fix and am buying lifetime ASAP.
Wait… have it already. :slight_smile:

But still, seriously… impressive response time.

Thank you all. I was having the same issue, terrible stuttering when using multi-zone with group option. Build 204 fixed the problem.

Sorry I forgot to update the thread guys :blush: glad everyone is fixed! :tada:

1 Like