Stuttering Gaming on Remote PC when NOT Core

Roon Core Machine

Ubuntu 22.04.1
Intel Core i5 8th Gen
16 GB Memory
NVMe Disk

Roon Remote (Primary/Gaming PC)

Windows 10 21H2
AMD Ryzen 9 5950X
GeForce RTX 3080
64 GB Memory
NVMe Disk
All drivers up to date

Networking Gear & Setup Details

Core and Gaming PC are both on wired LAN, same switch.
Firewall open on both sides for Roon and RAATServer

Connected Audio Devices

Remote PC: Schiit Modi 2 USB DAC, Optical SPDIF

Number of Tracks in Library

18K tracks, 1.5K albums

Description of Issue

I’ve been wanting to get my Roon Core off my primary computer for a long time, and the introduction of Roon 2.0 and ARC made me finally do it. Everything’s working well, except now I’m getting poor performance in games when I’m listening to music. The audio stream is perfect, but I get these frequent micro-stutters in gameplay. I’ve noticed it seems okay when listening to 44.1 kHz content, and bad when listening to 96 kHz content.

This morning I moved the Core back to my primary/gaming computer and the problem has gone completely away. This leads me to believe it is something with the Roon Advanced Audio Transport.

Are there things I can troubleshoot or tweak, or ways to diagnose what’s happening with RAAT?

Are you running Roon (with GUI) on the Windows PC? If so, install Roon Bridge as well, and shut Roon down when gaming; Bridge will give you audio output.

Hi Martin, thanks for the reply.

Yes, it was Roon with GUI on the Windows PC. Good idea on trying Bridge. I did a full uninstall of Roon GUI and then installed Roon Bridge. Then I tried things without even installing Roon GUI. I started playback from my iOS device and the gameplay stutters started immediately. I guess it’s definitely something with RAAT and maybe some kind of interrupt/conflict for CPU with the audio engine of the game?

How is the PC connected to your network? And what is the bit depth and sample rate of the mysic?

Everything is wired Ethernet and on the same network switch. 16/44.1 content actually does not seem to cause any stuttering, or at least it’s much better. Other formats do.

Is the Gaming PC endpoint set to exclusive mode?
(In Roon device settings)
If it is, turn exclusive mode off

You also might want to experiment with which output you are using on the PC.
For example on my gaming rig with Roon Bridge I have 5 output options.
I haven’t listened on my gaming rig in a while but recall one output working better than others.
But I can’t recall which one. Sorry.

1 Like

Hey Jeff, yeah, I did play with all that stuff, various devices and settings. I tried different ways of connecting the DAC (USB, Optical), different devices in Roon, and then different device settings in Windows. Also tweaked a bunch of advanced device setup options in Roon. Nothing seemed to work.

I’m guessing it has something to with the time synchronization operations that RAAT uses when the Core is remote. The game I’m playing, Path of Exile, is known for its audio engine being a major drag on performance, so maybe it’s just really sensitive to whatever is happening. Some people playing on less powerful PCs even completely disable audio in the game config files to improve performance, but that’s no fun.

I moved the Core back to the gaming PC and installed Roon Server, so now at least I don’t have to worry about keeping the main app open all the time for my other devices. I was primarily interested in moving the Core for security reasons, having to open a port for ARC, but it’s not that big of a deal. This computer is plenty powerful enough to do the job, and honestly the main GUI app feels significantly more responsive in this setup as well. No harm done. Maybe I’ll attempt it again in the future if something changes with RAAT.

I doubt this is the cause of the problem. The DAC controls the clock, and RAAT, unlike core or controller, requires very little CPU. Others successfully use their gaming rigs to run Roon.

Given everything you’ve tried it does seem this particular game is the culprit.
Have you tried using DSP settings to downsample everything to 16/44 as that resolution seemed to work ok?

Ah, you know, I wanted to do that and was looking in device settings for it, but I totally forgot about DSPs. Maybe if work is slow tomorrow I’ll try that. I’m much less concerned about high-res audio when I’m gaming, so I’d be perfectly fine with doing this. Thanks for the suggestion. I’ll follow up once I try it out.

Hi @Sheb,

Thank you for the report and thank you to the other users who have helped out so far.

Please let us know if you experienced better performance with the downsampling in place, although the team is standing by to investigate logs from the backend regardless to determine if the cause of the interference is within Roon’s and its protocols or further down the audio chain.

We’ll keep an eye out for your response.

Hi Connor,

To be honest, things got hectic for me and I stopped fiddling with it. I’m perfectly happy with how I’ve got it set up now, which is running the Roon Server app and Core on my primary gaming PC. It solved this particular issue and I feel like the Roon app is a touch more responsive in this configuration as well. Like I said, this game (Path of Exile) is known for being a CPU hog and for its audio engine being a significant factor in performance, so I doubt many other people would be running into this issue.

I decommissioned the other Core box I was using, but if you’re looking for a fun game to play and want to see if you can reproduce it, Path of Exile is actually free to play! :slight_smile: (If you really like it you’ll probably wind up spending $20-$30 on stash tabs.) Sorry I couldn’t help see this through all the way. Maybe I’ll give it a try sometime in the future if I feel like revisiting it, but I’m good for now. Thanks to everyone for their replies!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.