Success installing Rock on my new NUC10i7FNH!

@Mark_Sturge – thanks for that suggestion – I wouldn’t have thought of that. I did download the latest version (from the site pointed to in the Roon ROCK instructions) at the time of setting up the NUC, but I see that there is a newer one available there now. Definitely something to try. (Playing my local music to physically connected as well as remote endpoints has been fine, though – could an ffmpeg problem differentially affect local streaming vs internet streaming? Genuinely wondering – I have little understanding of what role the codec plays…)

I followed these instructions on a NUC10i3FNH!, and they worked like a charm. it took me less time to install ROCK than it took me to open the case and install memory and storage. I am currently re-scanning my library as I chose to not restore the backup, as I had reasons to suspect the integrity of it. Will take a few days, but so far all is correct in the world.

The FFmpeg CODEC on Roon ROCK simply decodes the digital audio stream coming from your audio source, whether it’s local (internal hard drive) or streaming (local NAS, Qobuz, or Tidal). The CODEC has to have the support built-in for the audio format being played. If your version of FFmpeg is up-to-date and you’re still having issues with streaming content from Qobuz, then the root of your problem is likely something else, and I don’t want to make any assumptions of what it might be. I hope Roon Support is able to help you out. It could very well be a network problem as they suggest. Are you able to access the web interface of you Roon ROCK?

I just gotten hold of NUC10i7FNH with 16GB ram and 250GB SSD M.2 Nvme Lexar.
I was NOT able to install as it keep reporting “Read Only Drive”
After install, I cannot create Codecs directory in DATA.
There seem to be unknown issue or that the Lexar M.2 SSD NVME is not compatible?
I tried to install Ubuntu and it has same issue…
I had enabled Legacy BIOS and disabled UEFI.

However, when I format using Fat32, it works well…
Any pointers will be great.

Looks like Lexar m610 M.2 NVMe is not compatible with NUC10i7… :frowning:

Hello @Mark_Sturge and @Everest – many thanks for the information about ffmpeg in your post and link. Based on that, I’m guessing it’s not an ffmpeg issue, as local music gets played fine. Seems like it couldn’t hurt to try the update though – aiming for that this weekend. Thanks again!

(I am following up with support, thanks for the suggestion, so hopefully this will get resolved. And accessing the ROCK web interface works fine, so the NUC definitely has an internet connection – in fact, it can play local music to remote endpoints as well… problems are only with streamed-over-internet music from Qobuz – I don’t have any experience with Tidal. Actually, come to think of it, it could be worth a trial subscription to Tidal as part of trying to narrow things down…).

Another thanks Steve as my NUC kept going to the Ethernet port rather than the SSD with the default Bios settings. Am sure you saved me a lot of time. Now I can move on to loading the codecs. Cheers Dave

Is this really true? I have been running ROON on my downstairs iMac for 3 years and frequently revisit the idea of changing to a NUC or Nucleus. I connect to my upstairs audio system via Ethernet so no noisy computer issues for me.

Do you really find the streaming services to be snappier? Many here say there is no difference what so ever

I was running Roon core on Mac mini 2014 Late i5 with 8Gb ram. Now the NUC10i7 has double ram and instead of a Fusion drive it has a ssd, but it’s 5 years later! And yes Qobuz is snappier, unfortunately my internet is still the same as 9 years ago when I moved to this place. Surely, fiber line, hopefully coming neoxt year might further improve Qobuz reception. Currently, I’m not subscribing for a hires plan as I’m afraid to end up with drop-outs I don’t have on a Hi-Fi lossless 16bit/44.1k plan.

Hi! I am running ROCK on a NUC10i7FNH did you get your wifi to work with it?

Thank you

Bummer. I am just looking to “control” the ROCK from my iPad using WiFi on both devices. The ROCK will be directly connected to the DAC at the stereo.

Like others here I have now installed ROCK but couldn’t have done it without your input…thanks

Spoke too soon, I can’t see the NUC on my Roon remote and the Roon web UI is returning as could not connect to server. How do I I get to do the coded changes that seem to be the next step? Any ideas?

Thanks, Dave. So glad I could help. We’re a community, and it’s great that we all help and support each other.


I had lots of frustration attempting to install ROCK on a NUC10i3FNK1, nothing I did seemed to work. Like one of the other posters the USB drive would flash and then the NUC (apparently) hung requiring a power cycle. The unit would boot fine from other USBs, Linux, windows, Acronis etc. So this was maddening. I was about ready to give up when a read a post of someone with identical behaviors, he solved his issue by changing his HDMI cable. This got me to thinking… the monitor i was using was plugged into the USB-C port and plugged a different monitor into the NUC’s HDMI port. Instant success. I assume that all those times when it appeared that nothing was happening their was an issue with the video being displayed on my monitor. Switching to HDMI cleared this up.

Hopefully someone else can benefit from this information.



This is an old thread, but I thought I’d ask how you find the Akasa fanless case. In particular, does it provide adequate cooling for the NUC running Roon? Have you tried running a desktop OS on it? I’m thinking of buying one for a spare desktop PC (an Ubuntu 22.04, soon to be released). I’d love to have a completely silent PC on my desk, but worry about adequate cooling. Thanks!

Hey, Nick. I purchased the case on Amazon here:

It was an easy install if you watch their videos on YouTube. It has worked without a problem since I built it; I have had to do nothing but listen to music. I use ethernet from it to my music server, so I’m unsure how USB would work from a NUC. It runs cool when I’ve touched it, and I get all the Roon updates automatically.

Hope that helps. Let me know if you have any other questions.


Hi Steve,
Thank you so much for the quick reply! I am relived to hear about your experience. I guess it’s time to take the plunge. The case looks beautiful, too.
I’ll report on my experience after I’ve had a chance to install it.

Look forward to hearing back. BTW, I did use a good thermal paste during the install. You’ll want good coverage there.

Good luck!