Success installing Rock on my new NUC10i7FNH!

I recently purchased a NUC10i7fnh NUC on Amazon, along with 32gb of Samsung memory and a 250gb Samsung EVO M.2 Drive. I also purchased an Akasa fanless case (love it!). After taking the motherboard out of the NUC and installing it into the Akasa along with the memory and M.2 drive, I updated the BIOS and made all the required changes in Roon’s instructions. I then placed the ROCK image USB Flash drive into the case and rebooted looking forward to an easy install…

Each time I booted and held down F10 (per instructions) I’d be taken right back to the BIOS and not a choice of boot drives as the instructions state. After fiddling with the BIOS more,I checked UNFI (Legacy still also selected), the next boot did get me to the choice of install drives, but only the Flash drive was shown. Selecting that did nothing at all.

I then went to this site and searched for a solution, but found that many folks here have had the same issue. After many hours of trying different settings, I did get Rock to install onto my M.2 drive and I’m listening to my new Rock Core as I type this. Happy me!

Because so many folks seem to have the same problem, I thought I’d let you know what BIOS settings worked for my NUC10i7FNH. Hopefully, this will help others to have a better experience.

Advanced Tab:
Check on “Storage” and go into that section.
Activate the M.2 Port if you have one of those drives.

Power Tab:
Select “Secondary Power” at the bottom of the list. The first selection should be “Sleep Type Support.” Click the dropdown box and select “Legacy S3 Standby.”

Boot Tab:
Select the “Boot Priority” option and go into that section.
Uncheck UEFI
Select “Legacy Boot.”
Disable ‘Fast Boot.”
Enable “Boot USB Drive First.”
Disable “Network Boot.”
Go back to the main “Boot” Tab.
Select “Secure Boot” and go into that section.
Click the down arrow on the first dropdown and disable “Secure Boot.” I think this is the choice that made it all happen for me.

Place your Rock image Flash drive into a slot, take out all other USB storage drives from USB ports, and hit F10 to save your BIOS settings and reboot. While rebooting, hold down the F10 key. Now the “Install from” prompt should show with both the USB Flash and your internal M2 drives showing. Choose the Flash drive and hopefully, all will go well.

Good luck!

Steve

32 Likes

Welcome to the ROCK club! Glad you got the BIOS part sorted out, it can be a bit fiddly, and I’m sure your tips will help someone down the road.

1 Like

Ha, I have the exact same NUC and went through this same loop of stupidity last week. I was about to write it up for others so I’m glad you beat me to it.

The Roon doco could definitely do with a refresh for the new generation of NUCs. Some screen shots wouldn’t go astray either.

The install itself was far faster than messing with the BIOS to get it to do what I wanted in the end.

I agree. Figuring out the BIOS quagmire took hours. I was ready to take it to a local computer repair guy I know, but figured it out just before that. I love Roon, but they should really update those instructions. It would be such an easy process if they would.

It’s a question of limited resources and competing priorities, I’m afraid. See here:

Tell you what, if you could post some screenshots here, then I could take your revised instructions (thanks for documenting them) and work them up into the strawman for updating the KB article…

2 Likes

I would post screenshots, but can’t figure out how. My NUC is a dedicated Rock core, so no Windows apps. Is there a way to do this?

I’ll give that a try this afternoon. Will let you know.

Just take some pics with your phone. Thanks for sharing.

1 Like

Da, can’t believe I didn’t think of that.

1 Like

I cant see how to edit my original post, so here are pictures of each BIOS screen and the correct settings.

12 Likes

Thanks for the detailed instructions @Stephen_Mills, it saved me a fair bit of time.

ROCK installed on a NUC10i3FNH. Samsung 970 EVO Plus 250GB NVMe SSD, 8GB Crucial memory and an external Samsung 1TB SSD for music.

1500 albums including TIDAL, so far it seems to be fast enough for my use case.

Thanks for getting this information out to everyone! I, too, ran into these “gaps” in the ROCK instructions.

@Stephen_Mills – Thanks for writing this up. I just went through this last week (exact same model NUC10i7FNH) and wish I had seen your post first!

One question (I guess also for anyone else who has a NUC10): have you found Qobuz streaming (if you use it) to be working OK from your NUC10…?

I’ve been having problems with Qobuz on the NUC10, but not with playing local music, and have been trying to troubleshoot. So I’m curious how others are doing with NUC10+ROCK+Qobuz

(When I uninstalled ROCK and installed Windows 10, Qobuz worked fine, but from what Support has explained to me, it is likely still network issues that Linux is more prone to than Windows.)

Thanks in advance for any info –

Thanks a lot for the detail instruction. My Nuc 10i7 will come this week. I will also add 2x8G ddr4 2666 ram and 500G m2 ssd(wd sn750).

I will try to install the rock then post it for all.

Thanx a lot, Steve! You’ve saved my day! Without your advice I couldn’t modify BIOS and install ROCK. Thank you!!!
BTW, shal I leave BIOS settings like you described or return them to default?

I’m so glad it helped, Mikhail. I left my bios alone after install and everything is working fine.

Steve

1 Like

All fine with Qobuz on my side. It is snappier on my NUC10i7 with ROCK installed than it was on MacOS.

Thanks for the info! That’s good to know as I try to troubleshoot…

I had the exact same issues. It was a journey hunting for the menus to make the changes Roon suggested, and sheer guesswork disabling the Security setting. I think it would serve Roon’s subscribers if Roon re-wrote their documentation for each generation NUC. At the very least, they can clean up their documentation and clarify things like “Do I leave UEFI checked or not?”. When they tell you to “Use Legacy, not UEFI”, it isn’t clear enough that UEFI should be unchecked (It should be, but there are too many posts with users asking about this). A simple re-wording would clarify many of their BISO instructions.

Regardless, I’m going to re-post your excellent instructions in my FB Roon Users group. Perhaps I’ll even add screenshots at some point.

Thanks again for taking the time to post this. Excellent!

2 Likes

FFmpeg CODEC up-to-date?