Successful Roon 2.0 install on 2011 Mac Mini

Officially, 2011 Mac Mini’s support MacOS High Sierra at most, which won’t run Roon 2.0.

I just wanted to mention here for reference that yesterday I used Dosdude’s Catalina Patcher to upgrade to Catalina, and afterwards was able to upgrade to 2.0 which runs without any trouble. :ok_hand:

5 Likes

2.0 is working fine on my 2012 10.17. Who needs a $2000 streamer? :grinning:

2 Likes

Hi Sander,

we were both busy at the same time I guess. Dosdude’s Catalina Patcher made also my Macbook Air from 2011 work with Roon 2.0.

Do you also encounter problems with the wake up functionality? After waking up Roon doesn’t display audio devices.

1 Like

Ah, no I haven’t noticed. I use the mini as a server for some other things so it never sleeps. :slightly_smiling_face:

Dear all!

I have an Mac-Mini 2011 core i7 with High-Sierra and ROON 1.8 (finally) worked very well.
The recommendation is 10.15 upwards.
Does anyone have experience on what is the behaviour with High Sierra? Does it allow to install ROON 2.0?
There seems to be the OpenCore Legacy Patcher from Dortiana to Monterey and the Doscudes Catalina-Patcher. Any redommendation or warnings from some of you?

Regards
Felix

I had no issues using OCLP to install Monterey on 3 Macs. All were of 2012 vintage: an i7 Mac Mini, an i5 Macbook Pro and an i7 Macbook Pro. No issues whatsoever on any of them once the post install patches were applied. The 2011 Mini is listed as supported but there’s a note about GPU acceleration issues. The process is very straightforward and certainly worth trying.

Thank you, so Catalina should work too.

If I recall correctly, Roon auto-updated to 2.0 and afterward just wouldn’t start anymore. I’m sorry I can’t remember any error messages or anything.

I only have used with Catalina Patcher, that was a pretty smooth experience. I had to disable SIP before install, which involves booting into recovery mode and using the console. Instructions are clear enough. :slight_smile: