Sudden disappearance of Tidal Albums from Library

I was adding an album to my library from Tidal this morning, when all of a sudden the album count started reducing. All the Tidal albums that I have added in the past 2 months have now disappeared from my library, and I cannot get them back.

Those previous to this time are still in the library, and the missing ones are still marked as favourites in Tidal. All my Tidal playlists are still present and correct.

Any thoughts?


Hello @thompo,

This is sounds pretty strange, have you tried to restart Roon?



Yes, I’ve tried restarting Roon several times. I have also tried logging out of Tidal within the Roon app, and then back in again, all to no avail.


Hi @vova,

This has now resolved itself. I tried adding another Tidal album to my library, and after Roonserver froze a few times, the album was eventually added, followed by my album count going up and all the missing albums being restored.

Not sure what the issue was, but happy to provide logs if required.


Hey @thompo,

I’m glad you are up and running. Yes, checking logs is a great idea. I’ll PM you shortly with the instruction how to provide them.


I just had the same issue this morning. Had about 2K Tidal albums disappear from my library. At that point there were still Tidal albums remaining in the library, but I didn’t check to see how many. There were albums remaining that had been added in the last several weeks.

A restart of the iPad remote didn’t fix the issue.

A rescan of my Tidal account in Roon didn’t fix the issue.

A restart of RoonServer (Mac) didn’t fix the issue. (As an aside, it would really be nice to be able to relaunch RoonServer from a remote or at the very least from the menu bar pull-down.)

Adding a new album as suggested above DID result in the missing albums being re-added to the library. However, I’m currently getting the spinning wheel of death indicating that of 47792 tracks, 47792 added, 47791 identified.

Weird and frustrating. Any ideas on how I should proceed?


Wait for our next release :expressionless:

We found the bug here, and it’s resolved for our 1.2 release, which is currently in testing. Still a little ways to go, but help is on the way.

Sorry for the trouble @Bob_Worley!

So great to hear as it’s now happening to me.