Sudden loss of audio - random

Audio just suddenly stops mid track but control on iPad shows it is still playing. Have to quit Roon core and restart to get audio again. Occurs randomly on different tracks, not repeatable. I am feeding Roon output to a Meridian audio system via ID40.

Setup is Roon core (1.3 build 276) on “lounge” MacMini (2.8 GB intel i5 processor, 8GB RAM, 500 GB Flash storage, OS 10.13.2).

Storage on “office” MacMini (2.6 GB intel i5 processor, 8 GB RAM, 1.12 TB Fusion drive, OS 10.13.2). Have about 6000 tracks, mostly classical some HiRes. no MP3s.

Ethernet LAN with 16 way netgear switch in lounge and 8 way netgear switch in office.

Control over wifi from a new iPad pro.

Has been working fine until recently, Sooloos still works fine over same network. Did get a few crashes initially with “Roon quit unexpectedly” messages but updating the Mac OS seems to have stopped that…perhaps it stopped the messages but not the crashes?

Any ideas.


Thank you for sharing your observations and feedback with us @Andrew_McMurdo, the insight is appreciated!

Moving forward, to help aide in our understanding of this behavior you are experiencing may I very kindly ask you for the following:

  • I know you had mentioned that this had been working until recently. Besides the OS update have there been any other changes to the setup?

  • These sudden stops in playback, you experience this behavior with all of your various endpoints correct? By chance, have you tried reproducing this issue with a device mounted directly to the MacMini hosting your core?

  • I see that your content is being stored on a separate MacMini (“office”), during your troubleshooting of this behavior have you tried loading some media on to the MacMini hosting your core (i.e “lounge”) to confirm if you still get these random stops in playback?


Thanks for picking this up Eric.
It will take me a few days to work through your suggestions but meanwhile I have made the following observations.

  1. Can also restore audio by switching Meridian 861.8/ID40 on/off

2.Display shows progress bar and active icon to left of track still working which I assume (?) indicates the data stream is getting from storage to Roon core.

  1. Apart from software updates my system has remained the same since I started with Roon about a year ago. Added an iPad pro for remote control recently but have checked problem still there if control direct via the core Macmini.

  2. Haven’t used any other endpoints apart from ID40 but will try HDMI from Macmini to HD621 to 861.8

5 Will also try Sooloos to ID40 again

6 Will try running from storage in core MacMini

1 Like

Thanks for touching base with me @Andrew_McMurdo, very appreciated!

I will be on the look out for your feedback!

Hi Eric,
After running the following tests the problem seems to have resolved itself…no idea how or what the cause of the problem was.

  1. from remote storage to ID40 audio stops mid track 2-3 times over a 2 hour period. This has been occurring over a 1-2 month period. Swapping the ethernet cable to the ID40 did not resolve it.
  2. from local storage on core MacMini to ID40 no problems
  3. from remote storage to HDMI output to HD621no problems
  4. Sooloos to ID40 over same network, no problems

This suggested problem was between Roon output and ID40 and as I had swapped the ethernet switch recently …
5. swapped 16 way Netgear switch for old 8 way switch, no problems over 4 hours.

Ah! The netgear switch was the culprit. However…

  1. swapped back to 16 way Netgear switch to check and has now been running for over 6 hours without problem.

I guess we leave it at that and hope it does not recur. I have noticed that after rebooting Roon takes a long time to find the ID40 whereas other outputs are there immediately.Is that normal?
Many thanks

Thank you for touching base with me @Andrew_McMurdo, I am pleased to hear your testing has yielded a positive result :thumbsup::clap: Well done!

In regard to the ID40 taking long time to appear. Do you have a rough estimate as to how long after the application is launched that the unit pops up?