Suddenly problem with Tidal streaming

Had many problems streaming hardwired Tidal Roon server via WiFi to a Raspberry Pi endpoint.
Bought a Nuc server running ROCK connected directly to my Benchmark front end and despite being told to connect hardwired and not use wifi, have had great success using wifi connection. Until lately. Now on weekends Tidal tracks on Roon stop working. Nothing has changed at home. No new devices. Nothing has moved. So decided to connect Nuc to router via E-net cable. Still having issues with Tidal. Tidal app seems to work fine to my iPhone, so doesn’t seem to be an issue with Tidal,
What’s up? This configuration has worked so well for so long.

Hi @John_Russell3,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Does the same behavior occur if you play to a different endpoint besides the Pi?

Is there any change if you do use an Ethernet connection instead of WiFi?

Thank you for the quick response.
I am using a DSL connection through a Netgear AC1900 router. Been using wifi connection to Nuc Roon Rock connected via usb to Benchmark DAC 2. Been using for a long time with no issues. Lately started having issues with current configuration. No change in other network usage. Nuc has been connected using WiFi. Tried connecting Nuc to router with a e-net connection with the same problem.
No other new network devices.

Hi @John_Russell3,

So just to verify:

  • USB Zone works fine
  • Problem exists even when connected via Ethernet

Moving forward, let’s focus in on this particular device:

  • If you play local content (not TIDAL) to the Pi do you experience and issues?
  • Can you share a screenshot of Device Setup for this Zone?
  • Try rebooting the Core machine and the Pi — Do you continue having issues after the reboots?

Nuc Core connected via USB to Benchmark DAC works fine with local stored music. Does not work reliably lately when using Tidal. This is my only connected device.
Problem exists even when connected via Ethernet
I am no longer using an end port device (Pi)
I have rebooted the Nuc Core multiple times and also the router (a DSL Netgear Nighthawk AC1900).
There are no other devices on the network that are streaming data when the problem occurs.
The play time bar at the bottom of the screen just bounces back and forth.
I have been using this setup for probably a year without issues. Nothing has changed regrading configuration or added network devices. I have been able to stream Tidal directly to my phone using the Tidal App. I have not tested this extensively so I’m not ready to say this works positively.

Hi @John_Russell3,

In the past we’ve seen that using Google DNS can help improve TIDAL performance — Can you give this a try and let us know if this helps?

I switched my router settings to Primary DNS and Secondary DNS to
I left Internet IP Address set to "Get dynamically from ISP.
Is this correct?
Are there any changes I need to make on my Roon Rock?
Since this problem mainly shows up on weekend evenings I will monitor for awhile.

Hi @John_Russell3,

If you’ve made the changes on the router there isn’t anything you’ll need to do specifically on ROCK. You can also set DNS specifically on the ROCK device via the Web UI.

Still not able to reliably stream Tidal over Roon. Internet speed tests at 40MPS.
Again, the set up worked perfectly for over a year. Nothing has changed hardware wise or physical location.

Hi @John_Russell3,

You mentioned before that things seemed to be working okay — How long were things working before the issue returned?

Have you tried setting Google DNS on the ROCK Web UI?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.