Surface Pro 3 w/ 4GB Ram, 128GB freezes on playback

Hi. I actually went out and bought this little machine yesterday just to play Roon. Set it up as a remote, it found the DAC it was hooked up to and played for a while. But several times all playback stops in the middle of a track, and all Roon controls freeze up - the screen is there but I can’t interact with it at all. Restarting the Surface Pro 3 worked last time, haven’t tried it this time.

I should say that this was a refurbished machine - supposed to be good as new but I don’t really know.

Hope you can help - thanks.

What OS is the surface running and what processor? It is refurbished and you have just started using it, had you run windows update before using it? Have a look at task manager and see what is using resources before you run roon and then whilst it is running to see what the impact is. Then come back with that lot and we cab go from there.

OS is 8.1 Pro. Processor is I5. I didn’t run updates before using it. Roon is the only program I have on it, except for the apps it came with. CPU is at 0% not running Roon, and 1% while it’s running. If any more info would help, let me know, and thanks.

I think it may not a problem with the Surface Pro 3 but with the core or the remote connection. I brought my desktop home from the office, set it up as a remote, and it played a few songs and froze. Wifi connectivity is excellent in the house, so I doubt that is the problem.

Sorry to hear you’re having some freezes on your new Surface. I’m going to follow up via PM so we can get some more info from you, and get a sense of what’s happening here.

Appreciate your patience @JChrisG!

What DAC are you using? I have a Surface Pro, works fine to control my Meridian devices, but I plugged in a Geek Out DAC which uses an ASIO driver. I understand Roon doesn’t support ASIO yet. I got similar behavior: it played briefly, then hung the Roon app.

Try removing the DAC and setting it up for System Output to see if that works better.

Thanks. I am trying to figure out where to enter the id you sent me.
" From the sidebar go to Support, then click the ‘I’ve already talked to support’ tab."

Not sure what is the sidebar or where to find it

The sidebar is the black column on the left of the screen, showing navigation and settings/support. Click on the ‘hamburger button’ (three horizontal stripes on the top left of the screen) to make it appear.

Thanks! Momentary attack of mindlessness. I have been thinking that I don’t really need the Surface Pro 3 to run as a remote, if that is the problem. Does it have enough specs to serve as the core player? And how would you switch it to be the core player? Uninstall and re-install?

I am using the DAC section of a Cambridge Audio Azur 851c. I believe it uses the WASAPI protocol, you can download the ASIO driver but I have not done so. I’ll try the system output approach while the guys at Roon are figuring things out.

@JChrisG we have a theory about your issue, and have a fix in the pipeline for our next release, currently with QA and slated for release early next week.

Once you’ve updated to the new build (> Build 3), go into Audio Settings and set your Surface Pro output to Event Driven Mode.

We think that should address this instability, but of course let us know if the issues persist and we’ll take another look.


Thanks Mike! Will do. In the meantime I have determined that the CA851c defaults to USB 1 and the Surface Pro 3 runs USB 3. So I downloaded the 2.0 driver from Cambridge Audio and am running the Windows 7 compatibility patch. So far so good, and if this was the problem, it’s a wonder it ever ran at all. When it did work I got a lossy audio yellow light but now it is a nice purple lossless light.

Well, damn! That didn’t fix it even though it worked better while it was working! Do you think maybe it is a problem with machine, or something to do with usb 3? The thing is, I could always take it back for a refund or exchange but I hate to keep it too long if I am going to do that.

I decided to fire up my wife’s laptop and run that as a remote. I didn’t hook it up to my hifi, just played through the laptop speakers. Same thing - it played a while and stopped. I have also tried just playing music through the Surface Pro 3 speakers, not hooked up to anything, with the same result. But as far as I can tell, the core machine will run forever!

Any ideas?

Hey I’m still hoping Event Driven Mode will help you out here. Keep an eye out for our next release, coming soon!