Synology DS218 Roon NAS cannot map the path

Here are some suggestions which maybe help:

  • I think the right path is \\music or smb:// Do not mention the volume1 map.
  • Probably Roon does not understand usernames with a space in it.
  • Has the user “Synology Home” permissions to read the folder “music”?
  • Look in the DiskStation Log Center en search for a connection log. Probably get a clearer message of the error.

Can you try and enable guest access on the share? At least momentarily.
And then drop the username/password…
I seem to remember something about localized/special characters in password being an issue?..
And thanks for the screen shot, lots easier to see then.
By the way, are you sure Volume1 is the name of the share? That looks like an internal name on the Synology OS…

yes i also tried to connect without entering username and password. It was one of the varieties. the same result without success

  • I think the right path is \\music or smb:// Do not mention the volume1 map
  • I tried without change
  • Probably Roon does not understand usernames with a space in it.
  • Has the user “Synology Home” permissions to read the folder “music”?
  • yes folder Music is “system default shared folder”
  • Look in the DiskStation Log Center en search for a connection log. Probably get a clearer message of the error.
  • DiskStation protocol center - so I probably won’t be able to do this anymore …

Volume 1 may have an internal name. But Audirvana, for example, mapped the path with Volume1, so I tried it with this as well

Can you try and enable guest access on the share?
So I probably won’t try this …
Friends, my son, who is much more proficient in IT than I am, will visit me tomorrow. I will inform you later. I’m starting to lose my invention and taste :frowning: I thought it would be a simple matter. As I mentioned above. I use Audirvana to play music from my MacBook Pro. She joined Synology without any problems. I use the MiND2 app from Simaudio Moon Also, the mapping of Synology was done without my intervention when everything was looking for itself and I just confirmed the connection.This is important for me as a regular user, simplicity without much intervention.And that at the moment I can not say about the app ROON …
So I’ll come back to it tomorrow and maybe God will and he will.
Nice evening

1 Like

Can share with us what the friend of your son has figured out. I am curious and we all can possibly learn from it.

I know with Windoze it wont let me connect without the “WorkGroup” field filled in, do fruity OS products have such a thing or not ?

so we couldn’t solve anything and I’ll tell the truth that I’m in the end. The local music library mapped smoothly. I can stream music from it in CD quality in HiRes quality, MQA, DSD just works as it should.
But mapping the way to a Synology DS218 NAS just doesn’t work. I tried almost all variants of how to write a trip to NAS. through the exact path description, by entering the IP address, for Mac, for Windows. NOTHING. Can anyone help me on this forum.
Thank you in advance

Yes, I entered it too. Without success.

is it possible that Roal Trial does not allow to connect a NAS server?

It is always the same Roon. Already seen:

Do you probably use special characters in your password?

Permanently? This could then be a reason Roon can’t connect to it again. If it’s already mapped, then you should be able to add it as a local drive.

721 / 5000

Výsledky prekladov

I don’t know how to recognize if it’s mapped “permanently” I tried the following: I entered the path smb: // into an Internet browser (Safari, Google Chrome) and when I confirm, do you want to allow me to open the Finder on this page? " after permission, he immediately got to the music ensembles. If I disconnected the NAS server in the Finder and repeated the procedure (entered the path smb: // into the internet browser, it prompted me to enter the username and password. After entering it, it immediately connected to the music files again. The 1st path entered is correct 2. The username is correct 3. The password is correct How can I find out if a NAS is mapped permanently? How do I specify the path to a permanently mapped NAS?

I was able to solve this for my DS218+ just now - With the right sharing configuration on the Synology side, it all lines up and works very quickly.

To minimize (or maybe maximize) confusion, I’ll try to explain step by step and/or setting by setting. I did this all in one go, so I don’t know which of these are unnecessary, but it definitely works, so…

  • I set up a Nucleus+
  • I’m using DSM 7.0.1-42218 Update 3 (might be these notes are useful for anyone on this Synology DSM)
  • I ported to the DS218+ web interface (by entering the IP into my laptop’s web browser, but I also have it linked/mapped in my PC network panel, which can be linked through via File Explorer)
  • I opened the DS218+ Control Panel - In it I set parameters in three areas:

- File Services: Under SMB tab, enable SMB service. Under advanced settings, set Maximum SMB Protocol to SMB3, and the Minimum SMB Protocol to SMB2. SMB Range is SMB2, SMB2 and Large MTU, SMB3. Check the three: Enable Opportunistic Locking, Enable SMB2 lease, Enable SMB durable handles. Save settings.

- User&Group: I created a new user named, “Roon” I only set the following parameters for that user’s tabs:
- Info: I named the user (Roon), used an email different than the ones I use for admin roles and set the password to one that uses only letters and numbers (but made it very long)
- User Groups: Set it to users only
- Permissions: I gave read/write permissions to two folders in the NAS - The one with my lossless ALAC files and the one with my MP3s. Those are the only two folders this user can access.
- Applications: I set it to allow for all. Save settings

- Shared Folder: Select the folders with the music in them and click edit. Go to the Permissions tab and set the user named Roon to Read/Write. Save settings

Once this is all set, I exited out of the Synology Control Panel and dashboard and pulled up the Roon Labs app to add a new path and entered into the Roon Labs setup the following:

“\\[name of your DS218+]\[folder name]\[folder name]” Note: paste your details over everything between back slashes and only paste the characters between the quotes. As the dialog prompt indicates, two backslashes begin the string, and a single backslash separates the server name, directory and subdirectory.

Name of new roon dedicated DS218+ user profile I created above (in my case, Roon)

That password from above that uses only letters and numbers


Once you hit enter, it should be off to the races. It found my music, devices and outputs immediately. To prove it out, I then added the second folder, and it worked again. Hopefully this works for you too. The issue here is not the Roon, but the NAS with its tons of configuration options for many kinds of use cases, and only one very specific and fiddly path (so far) for this unique use case.

1 Like

This topic was automatically closed after 2 days. New replies are no longer allowed.