Synology DS218 Roon NAS cannot map the path

I’m a complete newcomer to music streaming. I have a Trial version and I’m trying to map my Synology DS218 NAS.

  1. I have Roon v1.8 installed on my MacBook Pro. Mapping the internal drive to your MacBook (where the music is stored) went smoothly.
    2.NAS Synology DS218 Roon cannot map the path. I have tried all the methods described here in the forum:
    A) smb: // DiskStation / Music
    B) smb: //
    C) yes, SMB service is enabled on the NAS
    D) The NAS server is mapped for another app. for example. Audirvana, streaming app MiND 2 from Simaudio MOON. On both apps, after entering the path, the NAS server is immediately mapped
  2. While using Core, I use my MacBook Pro
    Thank you in advance for your help

so no one from Roon Labs is able to respond in 6 hours? Then I will probably continue to use Audirvana without stress and well …

Sorry for your troubles! However, it’s monday, busiest day of the week for the support crew. Cut them a little slack, please! :slight_smile:

Please try this:

Username, Passwd and workgroup ONLY if necessary.

Please read with understanding. I wrote point B) smb: // writes: There was an Unexpepected error: Invalid Network Path. And besides, your journey is for Windows.

Yes, did see that. and i am asking for you to try without the “smb:”-notation. And also to use backslashes, not forward slashes and definently no blanks.
But by all means, feel free to continue using your prefered playback solution. :slight_smile:
And, no… I was adding a network path to my Linux based NAS from my Linux based ROCK Core, on my iPad. So, not much Windows there…

Without success.
Variants I used:

  1. \ \ Volume1 \ Music (Volume1 / Music / this is exactly the path indicated on the NAS in the application)
  2. \ \ Music
  3. \ Synology_DS218 \ Music


In the earlier examples it was the first IP, in the last example it was the later IP. Did you change IP addresses?

I used the address [] as your example
my address is still []

so you actually tried smb:// and it didn’t work.

The variants you tried but did not work, were you using smb ? In the examples provided it does not appear so.

yes my IP address on NAS is smb: //
I tried:
all variants with smb slash //
A) smb: // Synology_DS218 / Music /
B) smb: //
all variants without smb with backslash \
A) \ Synology_DS218 \ Music
B) \ \ Music \

Neither variant was successful


Unfortunately without success.
I tried:

  1. smb: //
  2. smb: // Synology_DS218 / Volume1
    so I don’t know what else I need to be able to connect to my Synology DS218 NAS to the Music shared folder via Roon. Roon mapped to my shared Music folder on my MacBook immediately. My Audirvana app, MiND2 from Simaudio Moon, seamlessly connects to the NAS and plays music.

Make sure your NAS accepts SMBv2 connections too.

I have set:
Maximum SMB protocol: SMB3
Minimum SMB protocol: SMB2

Shouldn’t that be

I’ve tried this before. But just in case I entered it again: smb: //
Same result “Could not cennect to share: Unauthorized”

Synology shares are by default always written in lowercases only. In the posts I see that you are trying to connect to Volume1 and Music. This should be volume2 and music.

Result in the attachment, again without success.

I really don’t understand. To connect a NAS to Roon applications, I need a doctorate in nuclear physics …

I’ve never used a username or password to connect to a NAS. Have you tried the variants without that information