Synology & Roon Arc - Can't get it to work

Roon Core Machine

Synology DS918+_

Networking Gear & Setup Details

Sky hub (wifi disabled)
Asus rt-ax58u (Wifi 6)

Connected Audio Devices

Custom PC player, Wifi
Samsung S22 Ultra, 5g

Number of Tracks in Library


Description of Issue

I’m having problems in getting Roon Arc to work outside of the house. I’ve set port 55000 TCP on the synology firewall and also set port forwarding on the Asus RT-AX58U for the same but I still cannot connect outside of the local network. The router also has UPnp enabled but thats not helped either.

The router is connected directly to the core machine via ethernet and the Synology is running Roon 2.0

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

@Jason_McQueen, please complete the template in full, and provide the name of your ISP, router make and model, and all connected devices.

Likewise, please share the message displayed in Settings > Roon ARC, and obfuscate the last two segments of your external IP address.

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“doaction request return statuscode: UnknownError”}

You have a Sky router and and ASUS Wi-Fi router. Consequently, you appear to have multiple NAT. Whilst you’ve set up port forwarding in the ASUS, you also need to do the same with the Sky router.

Already done that and no joy.

Other services (e.g. Plex and Plex Amp) are connecting without issue.

And the port in Settings > Roon ARC is definitely 55000?

Is your ISP modem configured in router mode or in bridge mode. If possible (let your ISP) configure it to bridge mode.

Are you sure that the ARC port is indeed open from internet. Please check with this link. Fill in your ARC port number (probably 55000?) and click the button “User Specified Custom Port Probe”.

You can also try to temporarily disable the Firewall on your DS918+ as well as on your router(s) and test if ARC is working in this situation. If so then you know that one of the Firewalls is the problem.

Unfortunately, bridge mode isn’t possible with Sky broadband (they’re my current ISP.) But it should work if port forwarding is correctly set up.

I’ve uploaded shots of all my settings.

I am not familiar with the Sky Hub nor with the Asus router but at first sight I don’t notice anything wrong. Nevertheless a few questions:

  • Is it not neccessary to enable a firewall rule in the Asus router?

  • What happens when you (just for testing) disable all the firewalls (Sky Hub, Asus router, NAS) temporarily?

  • Did you tested if port 55000 is indeed open (see my previous post).

Sorry - forgot to do the test. It doesnt look like it is

I note that the services and firewall rules use a range; I’d keep these limited to 55000 and the LAN IP of your core.

Also, it’d be helpful if you confirmed the subnets used, e.g. etc. There’s no need to obfuscate this information, only your external IP.

I’m on a mobile, so I can’t see the images clearly, but make sure protocol is TCP.

Thanks sharing the result from ShieldsUp. This makes clear that port 55000 is not open.

If I were you then I should first do a test with all the firewalls disabled. If ARC is then working you know that the portforwarding rules are correct and that you have to check the firewall rules.

1 Like

I just tried turning the firewalls off from the Synology, Asus Router and Sky router and the shieldsup still failed. So I guess there is an issue with the port forwarding somewhere.

I have looked to the IP addresses you are using in het Firewall and Portforwarding rules. It seems to me that you are making a mistake.

You have a setup with two routers one behind the other and two DHCP servers (NAT after NAT). That means that in the Sky router you have to define the portforwarding to the IP address which the Asus router has gotten from Sky’s router DHCP server. I am not sure but based on the pictures you provide I think this IP address is

Next, in the Asus router you have to do the portforwarding to the IP address which the NAS (with the Roon Core on it) has gotten from the Asus’ router DHCP server. I think this IP address is

In your case the DHCP address ranges you are using in the Sky and in the Asus router are confusing because you are using the same ranges: probably That does not promote clarity and comprehensibility. The two DHCP servers create each a subnet that has nothing to do with each other.
I suggest that you use two different DHCP address ranges, for instance in the Sky router and in the Asus router. If you do this, you will of course have to adjust the IP addresses I mentioned above.

Furthermore, it is best to define in the Sky box a fixed IP address for the Asus router. Similarly, in the Asus router, a fixed IP address must be defined for the NAS. This prevents the routers from possibly handing out other IP addresses, so that the portforwarding rules are no longer valid.

I hope that above I was clear with my descirptions with this terrible technical stuff. :smiley:

I concur. I also think it is a good idea to use different subnets on each router as it’s easier to understand how things are setup.

Internet → Sky router → (default subnet for Sky router) → Asus router →

The only device attached to the Sky router should be the Asus router, e.g., on the WAN port since the Sky router is on Wi-Fi should be disabled.

Port 55000 should forward to, i.e., the Asus router.

The Asus router should be accessible from your laptop on, for example,

Setup an address reservation for the core, e.g., and forward 55000 to this address.

Thats pretty much how I’ve got it setup.

The only thing connected to the sky router is the asus router

Wifi has been disabled on sky router

Synology (core) is connected to the asus

Sky subnet is 192.168.0.xx

Asus is 192.168.50.xx

Asus router shows as on sky router

So all I need to do then is forward 55000 on the sky router to the asus router. I’ll have to have a look at how to do that within the sky options as its not clear on first look.

Easier than I thought - outbound service mapped to the Asus router IP.


Its working!!! I can now access it from my phone if I turn off the wifi and use 5g.

Thanks for the help. It was more hassle than I thought it should be but its sorted now


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.