Synology Set Up for Roon

(Mr Fix It ) #21

If the mini also has Ssd then definitely

#22

My Mini didn’t have an SSD, so I’m running the OS off an external SSD in a desktop Seagate Thunderbolt adapter.

(Derek Suggate) #23

My mini (mid 2011) doesn’t have a SSD but my NAS does…feelings on which would be the better route?

#24

@crieke can speak to this more accurately than I can, but I would guess the NAS. If both options had SSDs, I would choose whichever model had a more powerful processor (Mini) and more memory (Mini).

(Derek Suggate) #25

Thanks Michael…I’ll talk to him about it

(Derek Suggate) #26

OK, so my Roon ready server is now here and installed…I have the Roon Remote App worhing on my iPad…The RoonServer package (thanks Christopher) is running on my Synology NAS (Volume 2) on it’s dedicated SSD.

The only problem I am having now, which seems like it may be a common one, is finding the correct Network path for the music files existing on my NAS (Volume 1). I have managed to enter something which I believ to be right and the remote is recognising it (I thnk)…however, I am getting a red message “Key has expired”

Can someone please tell me what I am doing wrong?

(Christopher Rieke) #27

Could you post a screenshot of your settings?
I have never seen that message before…

If your synology acts as the server and your music files are on the same device (different volume does not matter) they need to be added as a local folder.
Please read the instructions on the download page how to do that.

(Derek Suggate) #28

Hi Christopher

I have tried changing things and now have the message "Retrying with upper case share name.mount error (6): No such device or address. Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I don’t now how to take a screen shot on an iPad!

(Christopher Rieke) #29

I guess it is because you are trying to add a network path where a local folder path is needed. I added a note to my previous post before you answered. Please check that… :wink:

(Derek Suggate) #30

The music fies are stored on the Synology but they are accessed (or will be) via a separate Totaldac server. This server is being seen by the remote ok as the networked audio device.

The address I have used is smb://NAS/volume1/Suggs Music
if that helps.

Do I still need a local folder rather than anetworked one?

(Derek Suggate) #31

Sorry if all this seems dumb…I am a complete newcomer to this stuff

(Derek Suggate) #32

I have found how to acess the Local Folder path and can see why that is the way to go, but still cannot create the correct path format

(Derek Suggate) #33

/Volume 1/Suggs Music which is how it’s configured onthe NAS is now bringing up the message “The drive containing this media is not available or the folder has been deleted”

Any help on where I go from there please

(Christopher Rieke) #34

Did you also press the extra “add local folder” button before entering the path?

Regarding your path:
There is no space in volume 1 and it should be spelled “Volume1” (without the doublequote).

(Derek Suggate) #35

Yes, I had found my way to the correct “button”…so had used that in my attempts.

The result is the same with or without the space.

(Derek Suggate) #36

Eureka!

I have now tried the volume in lower case and it’s happening! Got there at last and it’s scanning now as I type

Thanks for your help Christopher…now to start using it (hopefully)

(Christopher Rieke) #37

Whoops, you are right. It should have been lowercase. I mixed this up with the path for OSX, where Volume is spelled with an uppercase “V”. :slight_smile:

Happy listening then!

(Derek Suggate) #38

Well, the app seems to be working, but there is no movement on the “time” bar at the bottom of the page and hence no sound is being output. The little blue bars to the left of the track list are moving ok, but nothing is actually playing.

Any ideas please?

#39

I’m not sure if it was mentioned above in the thread, but Synology DiskStation DS1815+ and DS1515+ models (and perhaps others) only allow for full SATAIII speeds on the first two drive bays. If you’re going to use an SSD for your Roon package install, or think you might, I would highly recommend starting your storage volume on the second drive bay.

@crieke, do you agree with that setup recommendation?

(Christopher Rieke) #40

Hi @Michael_Merline
I could only test this with my devices here and it is hard to find information about it on the web.
My Synology DS1511+ has only 3 Gbps on every bay. The QNAP TVS-471 has 6 Gbps on every bay.

But it can easily be checked over ssh by running

dmesg | grep -i sata | grep 'link up'