Synology SPK-Package: Development

I have similar problem with 412+, Roon finds my favorite Tidal albums but not the music on NAS. Tried both with NAS hostname and IP address.

If your music is also hosted on your Synology, you have to add these folders as a local folder. A smb share will not work anymore:

The local path on a Synology device looks like this:
Note that the X has to be replaced by the volume number on which your music share is stored.
If you only have one volume installed it is most likely volume1. Check your share settings to be sure about it.
If your music files are stored in a folder “flac” within the music share and the music share is on volume1, it would be



Thanks. Now Roon is scanning the music folder.

Would it be possible to have also a “restart” option in addition to start and stop in the Synology Package Center dialog?

Silly me… of course it is a local folder! Thanks for your advice!


I have my 1815+ playing DSD no problem. No dropouts.

Hi Christopher, seems that I’m the only that isn’t able to manage Roon running on my original DS 716+. Installed the latest v. 1.0-b1. Roon is being installed and running, the Roon remote recognizes the DS but fails constantly to connect.
I tried to activate /deactiveate ‘Audio Station’ and ‘Mediaserver’ with no changes to the behavior. Do you or any other user has an advice for me to make it running? Probably the log file I added below provides an answer on the problem Would be great if someone could help with his advice.

Cool! I’ll have to check mine when I get home to see how busy the processor gets doing the same thing.
I’m going to give it a try on a little Intel Compute Stick I have with me to see how that works - pretty sure it’s going to “struggle”.
I’m with Christopher, though, in wanting a Diskstation with at least an I3, but yikes! what a price.


First, thank you so very much for all your hard work. The package is amazing and a welcome addition.

I am having an issue with scanning:

Intel Atom D2700, 2.13 GHz
DSM 6.0.1-7393 Update 1

I have tried multiple folder combinations:

smb://IPADRESS/music (Connected, Watching for files in real time)
smb://volume1/music (Unknown error)

No matter what I’ve tried, I cannot get Roon to scan the local files. All TIDAL albums are accounted for.

Is the Atom processor version of the NAS the issue or is there something else that I am not doing correctly?

Thanks in advance for your (or other community members’) help.


This issue has been addressed several times within this thread. When the music library exists on the same Synology unit as RoonServer, do not use smb to connect to the music folder. The music folder location is not a network share in this case, but in fact local storage as far as the nas itself is concerned.

Please try using /volume1/music instead of smb://volume1/music

My apologies, I should have been more specific.

I have tried that, and this is what I get back:

Hi David,
From the screenshot, it looks like you’re still using the add network path option in Roon, try using the add local folder option (just down that page a little).

Thanks, Carl. Dumb mistake.

This is what I get now:

inted out.

The folder is fully permissioned and can be reached by Roon running on a Mac, by Finder on all machines, etc.

Can you check in the dsm if your music folder is actually located on volume 1?

Check this post in this thread for instructions.

It is about finding out on which volume the “RoonServer” share is located. But you can also check in the DSM (like in the screenshot) on which volume your music share is located.


Thanks for the help. Here are some screenshots:

Thanks again for your help.

Your shared music folder has an uppercase “M” at the beginning. :wink:

so your local folder is NOT:

It should be:

Head hung in shame.

Thanks Christopher.

1 Like


1 Like

The Synology SPK is ready. Please uninstall the previous development releases and install the release version.

1 Like