Synology SPK-Package: Development

I appear to have a problem with the install - hope you can help. I have a Diskstation DSM 2413+ INTEL Atom D2400, running DSM 6 Update 3.

The package states a successful install, but looking at the RoonServer logs it appears to be restarting over and over again, this is the end of the log file:

The RAATServer logs state:

04/24 16:12:06 Info: Starting RAATServer v1.2 (build 123) stable on linuxx64
04/24 16:12:06 Warn: [RAATServer] detected no ALSA support

Hope you can point me in the right direction, let me know if I can provide additional information. thanks in advance.

Roon Developers:

Clearly you can see there is a lot of interest in a Roon package for the Synology NAS.

Do you have any comments about the effort thus far. What are your suggestions for improving the package?

As there is no ALSA Support detected by Roon. It won’t be able to play sounds. Currently I just tried to get the Music Management software installed on the Synology (without the option to play something directly on the device).

Despite of this warning, is your RoonServer running and can you connect to it?

Out of curiosity I looked at the check-alsa binary and found out that a library file ( is missing. I could find it on my device and it has been installed with the “Python” or “AudioStation” package. After linking it to the Appliance folder, the alsa-test passed.

I just connected a ESI Dr.DAC to my Synology and could play music from my library to that device.

Despite of this warning, is your RoonServer running and can you connect to it?

I cannot connect to the Server, and don’t see it on any Roon Control (iPad, Windows PC). In the folder
/@appstore/RoonServer/Roon_Database/RoonServer/Logs - is the following:

Which just keep cycling, with the same output, as per my previous post, in each log file.

UPDATE: just noticed in the processes RoonServer is always running. But RoonAppliance.exe shows in the list then disappears, then a few seconds later appears again etc, Could this be what is failing to load?

@krjtx - Did you do a clean install on your NAS or did you import a Roon database as well?

Just trying to find what might be different on your system.

Mine has worked with both a clean install ( no database import and with a database import )


Do you mean SSD in this configuration has near zero impact so ?

I’m going to buy an SSD and stick in my ds1515+ to see what it does for performance. Any ideas if I should use Synology’s SSD cache feature or just make a new volume of it?

Short update:
I have builtin a check if AudioStation is installed on the system. If so a missing library is linked to the Roon Appliance folder from the AudioStation package. This should fix the ALSA compatibility check and you are able to play music directly from your NAS (if a USB Audio device is connected). I tried it yesterday and it works.
So if you want to use this feature you need AudioStation installed. I am still unsure if I could put that library into my package (need to get some info about license and if the library is the same file on all x64 models).

I am unsure about @krjtx issue. It seems the Mono framework is not acting correctly. If anyone else is experiencing this please let me know to find out what might be the cause of this.

You can specify any folder for import now as long as it contains a “RoonServer” and “RAATServer” folder.

I have tried both ways to perform the install.

@remi_alberge - Yes, even though the RoonServer and database are on a SSD volume, using the search function in Roon has a delay of a few seconds ( 4-5) before returning results.

@Lundmark - I recommend making a new volume on the SSD and install RoonServer on it, that will yield better performance for Roon than using the cache feature

I see. But I just read you comment about searches that still take a long time. Maybe SSD is unnecessary then?

@Lundmark - Well I have not tried it without using the SSD volume. When I had RoonServer running on either MacOS or Windows I always had it on a SSD drive.

I am going from guidance in this post.

I can’t get it to work with iTunes. It intermittently says it can’t find the XML, and no albums show up. Any ideas?

I just tested it on a native debian install. Same issue there. So I guess it has nothing to do with the synology/spk file…

Oh interesting. So it seems to be a Linux issue then?

I’m runinng RoonServer on Atom D330 with 3GB RAM and Intel 320 Series SSD on Ubuntu14.04 inside docker container and Roon is very usable except the search function which took 5-10 seconds to start showing results.

RoonAppliance is occupying about 620MB or RAM and there is still about 600MB RAM free and 500MB of cache in RAM. Tried to disable swap completely but no change (swap was anyways barely used when enabled).

Library is located on NFS NAS connected via GLAN and storing about 75k mostly flac tracks / 7000 albums.

Roon is connected also to my Tidal HIFI account

Quick question: If I were to install this spk on my Synology and import a Roon database that I copied over to a share on that Synology, can I remove that folder after the installation? Or does this folder become the actual location of the db?

It will copy the database to your installation volume.
I’d still recommend to keep the original at the moment as the spk is still in a testing phase… :slight_smile:

I have installed the pck on my Synology 713+ containing 2x500GB SSD and can’t notice any lag of significance, but I have a small music library onboard.