Synology + TEAC AI-101DA not working / no sound


I have a Synology 716+ NAS which is a 64-bit system so Roon runs smoothly on it. I have a TEAC AI-101DA DAC connected to the NAS through USB and it works fine with the built-in Audio Station. Roon finds the DAC but when I try to play anything, it simply does not start: it hangs at 0:00 and does not play any sound and then it simply stops the playback task and then the DAC disappears from Roon. Then even DSM will not see it until a restart of the NAS.

My DAC works fine with Roon under macOS, so it might be an issue with the DSM package. Can you please let me know, what logs should I look for or if you have any issues like this reported already?



I just tried it here with my Synology DS716+. I could only test it with a Rotel PreAmp, but had no issues using it.
Are there any special settings for your TEAC DAC? Or are there any other software components installed on your Synology that might lock the access to your DAC?
Maybe you could post a picture of the Roon Signal flow (when the DAC is still present).

One more idea: What is your setting for that device’s volume control in Roon?

Hello Christopher!

There is no special settings on the TEAC DAC. When I try it with my Mac everything fine, but when it is connected to the DS716+ simply does not start the music. When I try it, the Audio Station is turned off, so nothing is using the DAC.

The roon server finds the TEAC DAC, but its not working. Here are some settings about roon/DAC:

Thank you for the help.

Does it make any difference if you set Volume control to “DSP Volume” or “Fixed Volume”?

Nothing :frowning:

Any log for that? That we could use?


I have suddenly developed a similar problem. 1815+ with Audiophillo usb to spdif converter. Was working fine, suddenly started disappearing when play pressed. Reappears after a few seconds.

I tried my Meridian Explorer 2 and this is doing exactly the same thing.

I am presuming its an issue with the latest software version

Any ideas anyone?

Let’s flag this for @support.

Yep, here is the set-up

Audiophillieo2 firm:1.35 and Meridian Explorer 2 connected to usb on NAS.


Audiophilleo and Explorer appear OK (icon next to volume control.

Controlled from a PC over wired Gb ethernet.

Press play on any track and bottom info window goes blank and displays “select an audio zone”.

After a few seconds the device re-appears.

This was all working fine (a few weeks ago, haven’t used it for a while)

Both devices work fine when connected to PC.

log files here


Hi @BE718 ---- Thank you for the follow up and the feedback. I wanted to touch base with you to see if in your troubleshooting of this issue if you have tried running your Roon core (temporarily of course), on a different device. If so was, the experience the same or different?

Furthermore, I would like to grab a set of RAATServer logs from you for evaluation by our tech team. Can you zip up a copy of your RAATServer logs and provide me with a download link via PM?

Lastly, we have contacted our developers asking for some feedback on this behavior you are experiencing and we believe that we have found the cause of this issue as @mike highlights here.


v209 appears to have solved the problem :slight_smile:

@Fodor_Gergely: Did RoonServer build 209 solve this issue for you as well?

Hello crieke!

Is there a new spk version?

No, just perform a regular update of RoonServer:

When you are in settings, click “About” in the upper right corner and it will check for an update of RoonServer.

Still not wokring, same, no sound, nothing changed.

The Audio Station is working fine, but the Roon is not.

Hi @Fodor_Gergely ----- Thank you for the feedback and my apologies continued troubles here. I did a bit of research on the TEAC DAC and it seems to have issue working in a LINUX environment as you can see based on the reports by other TEAC users:

Taken from Ubuntu Launchpad:
Can’t plug in USB audio device “TEAC AI-101 Audio”

Taken from Rune Audio:
TEAC AI-101DA USB working?

Even the TEAC website does not cite Linux under the device’s spec:

Which makes this even more baffling as you have confirmed that it functions fine with Audio Station. While we can’t make any promises here, I would like to grab a set of logs from you and will discuss with my team. Can you zip up a copy of your logs and send them over to me via a dropbox download link in PM?


1 Like

I’m not sure if this is helpful or related, but I also have been having some issues with a Synology-based Roon core and a(n albeit not directly connected) USB DAC. Yesterday I tried, unsuccessfully, incorporating a Meridian Explorer 2 into my system - first via a Pine64 running DietPi, then via a MacBook Pro. My Roon core, a Synology916+ (Roon/Roon database on external SSD) has worked fine with RPi + IQAudio DAC pro, and with the main system, Roon bridge on a Mac->Metric Halo Lio-8. I could see the Explorer 2 in both confirgurations, but was unable to play anything to it. Locally stored files gave the “an audio file is loading slowly” error, while TIDAL gave the “connectivity…” error.

I switched core to the Mac (running just RoonServer), and had no problems playing to the Explorer 2 via either configuration.

I’m happy to (try to) upload logs if that would be helpful. I’m pretty sure everything Roon was up-to-date, and Synology was on DSM 6.1-15047 update 2.

Hi @bartman,
the error message is quite common in combination with network settings.
Could you verify, there is no firewall activated on the Synology that might block the audio stream and also can you tell the MTU settings of the network interface of the Synology? You can check the MTU settings in the network settings section (Interface tab -> Last value of “Network status”):

Explore Maureen Cheung