System Output Not Showing Up in Roon Core [fixed]

My Roon Core suddenly stopped recognizing my System Output. My system is as follows:

Dell XPS PC/Windows 8.1/64 bit running Roon Core (Roon 1.3). I am running a USB DAC (Peachtree Nova 65SE). The system works fine for sound for other software (JRiver Media Center 20). All other endpoints (zones) work fine (the Apple TV’s and a microRendu run through an Oppo BDP-105D). I have tried rebooting everything. When I clicked on refresh devices connected to my PC it just stuck on thinking icon (for over an hour). I use the Roon COre PC for work so now I can’t use Roon as part of my daily routine…very much a bummer!!

I appreciate your help.

Jim L

Hi @tarolane ---- Thank you for the report and my apologies for the troubles here. To help me better evaluate this behavior you’re reporting to us, may I kindly ask you to please provide me with the following information:

  1. Since noticing this issue can you think of any changes that have occurred recently in your setup? Software updates? Driver/firmware updates? New applications? New gear?

  2. In your troubleshooting of this issue have you tried testing with another USB DAC temporarily to see if it has the same issue? Have you tried swapping out the current USB cable? Have you tried using another USB port?

  3. Can you provide me with the exact specs of the DELL XPS hosting your core?


I have not added any new apps or gear except maybe a Windows update. Everything was working when I shut down on Monday and then upon returning from out of town it was not working. The only other DAC that I have is my Oppo which would be a major pain to move to my office. The DAC is working with other applications (JRiver). I have not tried changing USB cables but I would have to purchase another one to do this. I have updated the specifics of my Dell PC. Let me know if you need any additional information.

This issue seems to have popped up a few times in the past week. @Eric, does RAATServer on the local machine communicate via IP or some sort of inter-process socket? In other words, could a recent Windows update have changed the firewall rules so that communication to the local RAATServer process is blocked, but Roon can still talk to other RAATServer processes on the network?

@tarolane, just for grins try completely disabling the Windows firewall if you haven’t done so already and see what happens.

I have tried disabling my firewall with no effect. Here are the advanced settings related to Roon and RAAT Server

There is a number of big updates lately from Windows in the run up to and the delivery of the “Creator Update”. Sadly, it has been shown that Windows will sometimes decide to reset your chosen preferences in relation to default programs, security settings and other privacy choices.

@tarolane, I just wanted to restate some of your information for clarity. The Dell XPS in question is running Roon Core and is not an endpoint. You can play music to Apple TVs and a mRendu attached to an Oppo. You have a Peachtree Nova attached directly to the Dell XPS via USB and you cannot play music to it.

You have already “completely” turned off Firewall (not just added exceptions) and that did not change things. Have you also, turned off your machine, unplugged the USB, turned on the machine and then plugged the USB back in, allowing for OS rediscovery. Also, have you tried another USB port as per @eric’s suggestion?

I am assuming that you have installed the Peachtree driver which is needed to play music >96Mhz as per their manual.

In your audio settings are you choosing “System Output” which is the computer systems default or selecting the Peachtree USB driver? If you are using “System Output” what happens if you use the actual Peachtree USB output. I have added a screen cut below to show you what I mean, in my case where you see a Schiit USB driver on your machine their should be a corresponding Peachtree USB option. In either case, if you can grab a screen cut of your audio setup and post it, that would help a lot.

I have tried changing USB’s, turning off unplugging, restarting, replugging. I am able to play music through the Peachtree using JRiver, Apple TV, Netflix, etc. Roon is the only program that is not recognizing the Peachtree or my system output (see screenshot). When this was working I would select the Peachtree output and was good to go.

Hi @tarolane ----- Thank you for the follow up and the feedback, both are very appreciated.

I would like to have you test, temporarily of course, with a fresh install to see if things stabilize with new DB in place. Again this is only temporary :wink:

  • Locate your Roon database according to these instructions
  • Rename the entire Roon folder to roon_old
  • Relaunch Roon, sign in, and configure a new install
  • Let us know if you see this error again

FYI: Before anything, please make a backup of your current DB.

Thank you Eric! I have reconfigured and all zones are now working. But how can I get back to my previous database??

Hi @tarolane ---- Thank you for the follow up and my apologies for the wait. Moving forward this is what I would like you to please try.

You should currently have two Roon folders in place, the current install (“ROON”) and the previously used one (“Roon_Old”). Please close the application and delete the current “Roon” folder completely. Now that the fresh install is gone you should be left with your previous DB which has since been named “Roon_Old”. Please re-name it to just “Roon” and delete your RAATserver folder which can be found in the same directory as the Roon folder.

Once you’ve deleted the RAATServer folder, please re-launch Roon and see if the zones are still available.



I did as instructed and everything is working again. Thank you so much for all your help. If this happens again should I just delete the RAAT Server folder and rerun - or do I need to do the the first step (fresh install with new DB)

Thanks again,

Jim L

1 Like

We’re going to do some testing to see if we can figure out what happened here, so we can make sure it doesn’t happen again :slight_smile:

I suspect you would just need to delete the RAATServer folder, but please do let us know if this happens again, ok?

Sorry for the trouble!

1 Like

I will keep you posted on future events. Thanks again for all your help.