Tablet standby causes Roon app to crash on Android 8 [Ticket In]

First a bit of (Android) history:

I’m using a Nexus 7 (running Android 6) as a Roon remote without any standby issues.

I’m also using a Pixel C as a remote, and while it was running on Android 7 it had standby issues but I found a workaround for it. I wrote about this in another post:

With the battery optimization switched off I used the Pixel C as a well behaving remote for about a year. A week ago I updated to Android 8 and things got worse.

When the tablet switches to standby, due to a timeout or a press of the power button, at wake up the Roon app is gone. The optimization setting no longer makes a difference. It seems to crash immediately because even with a short standby period of a few seconds the app has to be restarted at wake up.

@support, do you already have a device running Android 8? I know that you could not reproduce standby problems on your Android 7 devices, hopefully you can reproduce it this time.

If I have to sent log files, please let me know.

I feel sorry to say this, but in my experience every Android update is a step back for the Roon app. I really hope you can track this down and bring it on a par with the other platforms again.

Hi @Jan_Koudijs ----- Thank you for the feedback and more importantly, thank you for your patience. My apologies for the slow response here.

Moving forward, I would like to grab some logs from the mentioned device running Android 8 so our techs can have a closer look into this behavior you are experiencing. I will be contacting you momentarily via PM with further instructions.


Hi @Eric,

Is there already something to share regarding the log files that I have sent you?

Hi @Eric,

I found a workaround that at least makes the remote usable again.

To have a good mix between convenience and battery life, I used the following Android settings:

  • A tablet sleep after 2 minutes of inactivity
  • An automatic lock after 30 minutes of sleep

This configuration avoids a lot of tablet unlocking, in most of the cases only a power button press will do.

The change that I made is that I changed the automatic lock setting to ‘Immediately after sleep’, with this setting the Roon app no longer crashes. It has a similar effect as minimizing the app before standby is entered but this one is much more convenient.

The disadvantage is the additional unlock actions that it gives. I could solve this by enabling Smart Lock for trusted places. Unfortunately this Android function is currently broken, but there is a workaround for that as well:

Although this gives me a usable remote again, it would be good if @support can test my initial settings on an Android 8.0 device and see if it reproduces. Also I am still willing to assist in collecting log data for further analysis by the team.

Hi @Jan_Koudijs ----- Thank you for the update and my apologies for the delay in response on my end. The feedback is ALWAYS appreciated :microscope:

To bring you up to speed, I touched base with our tech staff yesterday to see where we were in regard to trying to reproduce the reported behavior with a remote devices under Android 8. The teams has informed me that they have been able to reproduce the crash in our QA labs and have listed out the steps for our devs in a ticket.

While I can not comment on when our dev team will be addressing the mentioned ticket, I can certainly update it with your most recent feedback so they have your “work around” on hand as a data point for their analysis.


1 Like

That’s good news! Thanks for the update @Eric.