Tailscale implementation on ROCK (NUC) To circumnavigate ISP CGNAT for ARC

No, we considered implementing the ARC to Roon Core communication over QUIC.

No, as you can see from the screenshot above I completely quit the App. Of course this morning it’s lost the connection, I’ll reconnect and see how it responds to a full playlist.

Another thing to check is battery usage. I have seen some big figures for battery usage despite quitting the app. I need to look into it further but it’s too much for my 12 mini.

It looks like the tailscale app only indicates devises on the network.
Killing the app does not close the connection as you can see your phone on the tailscale dashboard.
The only way to close the connection is to turn off the VPN switch in the phone settings.

This explains why it carries on playing, one to watch if you get battery issues.

This seems like a terrific amount of effort to listen you your rip of Nora Jones.


It’s not that big an effort. In my case it took an hour to set up. If you’ve been waiting for Roon to go mobile but you are stuck with a CGNAT ISP this give you an opportunity to experience ARC.

It actually seems like a waste of human effort to write the comment you did though. Not much effort though.

1 Like

I should have said ‘type integration’ as I’ve no idea what QUIC is but thanks for clarifying that.

Thank you so much for this thread! My only decent option for Internet where I am is Starlink, so I was disappointed to learn that Roon ARC does not work with Starlink’s configuration but happy to discover this work around. I have run into a snag and am hopeful for some solution. I have followed all of the instructions in the mentioned videos and have installed Tailscale on my Synology NAS as well as my MacBook and iPhone. I SSH into my NAS and set itup as Subnet Router and confirmed all of this on the Tailscale admin portal. I have my CORE set up on a NUC ROCK but have not been able to get ARC to connect to my CORE, despite what appears to be an appropriate set up. This is the screenshot I’m getting. It appears it may be “seeing” the ROCK but not syncing to it (does this make sense)? I am grateful for any suggestions to get this working. Thanks again for your efforts in putting this forward to users such as myself.

Are you connected to your local wifi when trying to do the initial setup? It won’t work over Tailscale.

yes, I was connected to my local wifi network. I have actually tried multiple times both connected and with wifi off.

I would reboot the core if you haven’t already. Also force quit Tailscale and check it’s not still creating a VPN by looking in the settings.

Thank you. I did reboot the core yesterday. Forgive my ignorance here, but I assume I force quit Tailscale from my MacBook and do I then check my iPhone in regards to the VPN settings?

I meant force quit on the phone to try and connect through your own wifi. If you are running Tailscale on a MacBook I’m not sure how that configuration works as I’m running it on a Synology NAS.

Basically ARC should have worked on your home wifi before you got Tailscale involved. If that was not the case there’s something wrong that has nothing to do with Tailscale.

I found quitting the app does not close the connection on IOS.
The only way is to turn off VPN in settings.

Ok, I understand. That’s what I was wondering as it seemed like everything was installed correctly. I have Tailscale installed on my NAS, I just have also added my MacBook and iPhone as extra machines. So, for clarity, I should be able to get ARC connected to my ROCK when I’m home on my local network irrespective of my internet provider (Starlink) and Tailscale? I know I was unable to do this which is why I started exploring options and discovered this thread.

Thank you, I think I just discovered that myself by simply triggering VPN to “off” on my iPhone settings. I will see if that helps any when I get home and can try to reconnect on my local network again.

Yes, ARC should work on your home wifi without any additional software.

Thank you, that clears up some confusion and frustration but also opens up questions as well. I suppose my next step is to submit a support ticket to Roon to see if they can figure it out? Thanks again for your help and I am still excited to.use ARC away from my home once I can get the other issues figured out.

Not sure what NAS you have but if it does not work may be worth a try to install the core on the NAS as a function test.

It is a Synology NAS. So if I wanted to try that would I just move the core to the NAS and simply power off the ROCK?