There is an error checking for Update

Roon Core Machine

Mac mini mid 2011 / OS X El Capitán (10.11.6) / Roon version 1.8 (build 1136) production1x

Networking Gear & Setup Details

Router/ switch model Askey RTF8115VW
It provides connectivity via WiFi and Ethernet depending on the device as specified before.
Mac mini running the Core is connected via Ethernet with fix IP

Connected Audio Devices

Lampizator Golden Atlantic (Amanero version) connected via USB

Number of Tracks in Library

14566 tracks

Description of Issue

I’ve tried to update the core several times, also after restarting the computer, and always get the same message: “There was an error checking for Update”
Roon Core: Roon version 1.8 (build 1136) production1x

I’ve updated successfully the other devices working as remote devices: iPad (WiFi), iPhone(Wifi), iMac (Ehernet) and MacBook Air (WiFi)
Remote devices: Roon version 1.8 (build 1151) production1x

Hey @Juan_Piedrola,

It’s great to see you on the Roon Community! You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, after reviewing your account it looks like you’ve since been able to successfully update your core, is that correct?

I’ll be monitoring this thread for your reply :pray:

Thank you. Yes, I was able to solve the issue.
It was caused because the DNS addresses have disappeared.
I do not know why and I can only guess it happened when I changed back my Mac mini configuration to static IP instead of DHCP.

As I only use the computer to run Roon and store the music I could not realize that it was not able to reach any external IP.

1 Like

PC, win 10 64bit, LAN
restarting the core didn’t helped
otherwise internet connection is fine … i dont have any portforwarding or DNS tweaks or similar on my router

Same, even with different DNS and VPN.


@outfaced @Forsaked

(The solved issue from further up in this thread was apparently a different one)

ok, if the server is down … thats another issue :slight_smile:

1 Like

I am having exactly the same issue when looking at Roon->About, but I think it must be something to do with the Roon Update Server, which may be down at the moment, and not related to the DNS issue.

Btw, Roon 2.0, build 1167 seems to work fine for me, except it took an unusual long time for the Roon Remote to connect to the Roon Server.

Yes, known issue, see my post above and the huge blue banner at the top of every forum page

Build 1169 is in, all good.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.