There's an unexpected randomly static noise keeps happens when I use NAD T778 + ROON

There’s an unexpected randomly static noise keeps happens when I use NAD T778 + ROON.

Is there anyone with the same issue or someone can help me look into it?

Although it is not cheap, but I still decide to get one ROON READY because it supports different software and music format and can work on different platforms.

But recently I found out there’re some problems when pairing ROON with NAD.

I’m not sure is it due to BluOS version update or it’s because of the software.

When I’m playing music through ROON to NAD T778, I get burst sound or fuzzy sounds. There’s no fix frequency and it happens randomly.

At first I think it is because it doesn’t support Hi-Res, and maybe it only happens when playing 24bit 96k files.

However, after several comparison and test, I found that it (the fuzzy noise) happens no matter what music I played.

I tried different ways to test it.

-Using BluOS play FLAC or Hi-Res music files: no noise found

-Using ROON + OPPO BDP-203: no noise found

It only happens when I’m using ROON+NAD to play music.

Dose anyone have experience or anyone can tell me where is the problem? Or should I downgrade my software and test again?

Here is my equipment and hopefully someone can help.


ROON x QNAP TVS-h1688X (
ROON Core:1.8(831)

Is this with Dirac on or off?

I had a similar issue with my T758 v3i, but I was using Roon to control an external Bluesound NODE rather than the BluOS dongle connected to the receiver. Eventually I found out that it was an MQA issue. When I changed Tidal settings to HiFi, the problem went away. When I went back to Master quality streaming, I no longer had the static. Hope that helps.

Hi Rugby Dirac is off.

Thanks for your reply, but I did not use Tidal.I have try to turn off NAD MQA decoder at roon setting but not any help.My music file all save in NAS.
I don’t have any streaming subscriptions.

Try using Roon DSP engine to resample everything to 96kHz (or 48kHz)

Hi wklie
Yes,no fix frequency and it happens randomly.
Just now try using Roon DSP engine to resample everything to 96kHz (or 48kHz) but it’s useless.

I`m also noticing this lately. Did you recently update the firmware of the NAD?

I did so maybe it is related.

Thanks for your reply
Yes,I have upgrade NAD firmware.
I also suspect it is the new firmware or BluOS problem.
Maybe i need to downgrade to verify it!But I do’nt know how to downgrade it.

1 Like

I would like to do also… But I don’t know if it is even possible to downgrade.

Does anyone know if this is possible and if so how to do so?

1 Like

Hi, I have been fighting this exact issue for more than a year and gave up completely on Roon. Switched to Tidal Connect for my BluOS device (NAD C388). This weekend however I gave a try again hoping that firmware upgrades might have solved the issue, but still no luck.
Then I found this thread: Static/Sputtering noise during playback through Bluesound Nodes

Then using the BlusOS app, I tried to remove my library (shared folders) residing on a Synology NAS, and bing… The stutter is now gone!!!

But removing the library and shared folders defeats one major purpose with Roon which is playing your own music. But I’m ok with that as of now, since I only use Tidal - my old CD ripped library is really not that interesting.



It seems that the problem has been resolved on my end!

I have deleted the library in the bluos software (on a pc) and added again (plus started the reindexing proces). Afterwards I didn’t have any static noise anymore. Keep my fingers crossed!

I hope this helps!


Means Delete Music Library(Share path)?
I’ll try it now.
I hope this solution is useful.Thanks for sharing.

HI mtimmans

That’s incredible!!

By following your suggestion, all those fuzzy noise and burst sound disappears after deleting Music library .
My Roon is totally back to alive with your help and I don’t hear any funny noise when using Roon.
Maybe it’s my personal bias, but no matter on interface or users music play experience, I like Roon more than BluOS.
24bit/96KHz Hi-Res music file is working properly as well, thank you very much!!

I can enjoy music again.

1 Like

Good to hear! You’re welcome.

I also prefer Roon. Everything is working here also. Enjoying the music!

1 Like

I had this same problem with both my Bluesound devices (early Node and Pulse). No problem with Roon played through PSAudio Direct Stream DAC. Whether intended or not, the latest update to Roon seems to have resolved the issue. Fingers crossed it will stay that way.

1 Like

Thank you all ! we have solved this problem after two months!!
My NAD M33 produced this static noise every 20-30 second…I couldn’t stand it anymore!
Great community!
I’m very happy and purchase a life time roon subscription!

1 Like

:metal: guys you made my day. Thank you so much.
I thought I go crazy with my Bluesound node 2i and the static noise.

short story. I bought new home cinema speaker (Canton Chorus SL 516.2 higly recommended) and divided the stereo and the home cinema system. Therefore I had to reorganize the devies and the cables. After that i had these sh… noice when play music via ROON and the Node. If I played music via blueOS and the node anything was ok. So I thought, this must be a problem with the Node or the cables.

And then I found this thread. :face_with_raised_eyebrow:Stop! Didn´t I change the admin user a few days ago on the QNAP Nas? I did but I didn´t changed the login in the bluesound app.

After I changed the login and made a new index everything is fine.

What a crazy issue. Normally a technican like me would say the Node or a cable is broken. Replace it.

So, thanks again. Great community :star_struck:


I am very glad that I found this thread. What a crazy bug in BlueOs!

It had this issue when playing music from Roon with a NAD T777 and with a Node 2i connected connected with the NAD T777, but - surprisingly from my knowledge of today - with a Node 2 connected with an oder NAD receiver. I suspected network problems, but couldn´t find anything. I meanwhile got a Raspi 4 with RooPieeeXL connected via optical Toslink with the NAD T777 for being able to hear music from Roon without these repeating noises again, and RooPieee is indeed a very good solution.

Now after deleting the network shares in BlueOs, everything if fine again.

I do not regret to having installed the Raspi 4 with RooPieee, since I got it with the Raspi touch screen, which nicely enhances the experience also when I hear by means of the Node 2i.

I have had the same problem, and the same suggested fixes have worked for me, though the problem cropped up again after the first fix.