This CD was already ripped

I was ripping a CD but due to a mistake I made, the files have been deleted.
Now I get the message mentioned above and the repeated rip is impossible.
How can I get solved this issue?

What are you ripping it with?
Try DB Poweramp and then import it

1 Like

Yes, use some other method or product to do the ripping.

I’ve had the same issue with the Roon ripping process. It does warn you that the delete is not reversible as I recall. I did what others here have suggested, ripped with dbpoweramp on another machine then used drag and drop to move the files over.

Looks like I have to to do what I tried to ignore.


  • Roon Nucleus
  • AK CD Ripper II

What is giving you the message “This CD was already ripped”? I don’t think it is coming from the Nucleus - I suspect this is a message from the AK CD Ripper II?

Good question, that is just what the Roon Web Interface shows.

Have the files themselves been removed from he CD Rips folder on the storage? It must be keeping a database of what it’s ripped to I guess. An oversight though if it don’t allow a rerip

You mean the Web Administration Interface?

That’s very odd. I’ve just re-ripped a cd to my NUC running the Roon OS (which has the same CD-ripping feature as the Nucleus), and there was no problem - Roon just added the CD again.

Roon 1204

I wonder if the issue is being caused by the AK CD Ripper. This has its own ripping software. The CD Ripper software in the Nucleus (and ROCK) is intended to be used with a simple CD-ROM drive, not an intelligent ripper such as the AK CD Ripper.

I’ll bet what’s happening is this: when you delete a local album (i.e. not a streamed album) from your Roon library, Roon will delete the music files from the local storage - but not the folders that contain the files.

For a simple CD-ROM drive connected to the Nucleus these folders will be given a unique name (tied to the date and time of the CD-rip).

Your AK CD Ripper will probably create a folder with the name of the album. Once that album is deleted, the files will have gone, but the folder remains. When you try and re-rip the album, Roon discovers that that folder already exists, and throws an error.

You will have to use Windows File Explorer or the Mac Finder to locate that folder in the Nucleus storage and delete it manually. Then you should be able to re-rip the album.

Files an Folders deleted, Library cleaned up

The AK behaves the same way than any other device regarding naming folder and files on the Nucleus

Just retried after a day after checking all points in various comments, but no Same result.
Perhaps this is really something in the AK ripper it remembers.
Will check with my dealer.

So, in the Nucleus storage there is a folder created that is called CD-Rips, and inside that are a series of folders named with the date and time of the rip? Looking something like this…

Thanks, know that folder, it is empty and not existing anymore.

It must be something in the Nucleus. Ripped the CD with the AK ripper to my AK SR 15 and everything went perfect.

More likely to be the combination of using the AK CD ripper with the Nucleus, given that using simple CD-ROM drives with the Nucleus or NUC/ROCK systems don’t give this error. At least, I’ve never seen this being reported before.

Hi @Aquarius_M_Taurus,

Thanks for reaching out! Moving forward, here’s what I’m hoping we you can do:

  • Reboot the Nucleus
  • Try to re-rip this CD
  • Make a note of the time that it fails
  • Take a screenshot of the error message

Respond here with the time that the ripping fails and include the screenshot of the error message and we’ll enable diagnostics so the team can take a closer look.


The reboot solved the issue, before I only restartet the server software. Thanks for your help.

Would that be needed anytime if I have to re-rip a CD?

Hi @Aquarius_M_Taurus,

Thanks for the follow up. I’ll have the team look into this more closely. In the meantime, I’m glad it is working for you now!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.