This PC Audio - music wont start playing, stops immediately (repost as last topic disappeared)

Roon Core Machine

QNAS NAP TS-453 Pro, Celeron 4 cores, 4 threads, 8GB ram

Networking Gear & Setup Details

Hardwired ethernet network between NAS and all devices

Connected Audio Devices

Meridian 818/ID41
Windows 10 PC (This PC audio) - this is where I have the problem

Number of Tracks in Library

18500 tracks

Description of Issue

Have updated to Roon 2 and really like it, works really well with my Meridian ID41.

The trouble is when trying to use a PC local output, the device is shown and I can select it as an audio zone. But when selecting any track, whether locally stored on my QNAP NAS, or on Tidal, music stops as soon as I click play.

My firewall rules for both Roon and RAATServer both seem to be fully applied for both private and public networks, and are allowing traffic.

Anything I can do to fix this?

Many thanks,


Hey @Chris_Bowie,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

I wanted to check in on this thread to see if you were still having trouble playing audio from your PC remote? If so, are you able to play audio outside of roon on the system output of the PC?

Please recreate this issue and take note of the date and time and share it here. From there, we’ll enable diagnostics on your account and take a deeper look :+1:

Thanks - just updated server and pc client to latest version and have recreated the issue and still have the same problem.

Confirmed audio out of the PC works flawlessly from everything else.


Hey @Chris_Bowie,

Can you please share a screenshot of your signal output, as well as the endpoint selection (the speaker icon to the left of the volume level icon)?

With that, I’d be curious to see your Settings>Audio as well. Do you have any active firewalls in place on the PC? It could be that there’s a blockage preventing audio from reaching your system output.

With that, I’d also take a look at your PC system sound settings to see if the outputs align there as well. If you plug in headphones, does the same issue happen?

Hi Benjamin - my system is perhaps slightly unusual. I have two Meridian 818s, both with ID41 cards. In my lounge I have a Meridian 818 connected to Meridian 8kse speakers, and this is just a music room, and it works perfectly, using the SLS input on the 818.

I also have a Meridian 818/ID41/8kse combo in my study, which also works fine through the SLS input.

But…as it is in my study, I have my PC also connected to that Meridian 818 and 8kse’s through a usb connection, using the USB input on the 818 instead of SLS with Roon. My PC recognises the 818 (800 Series Audio) as a device and it is my default device for all windows sounds, including Teams/Zoom calls etc. For years, Roon has been quite happy outputting music through my windows 800 Series device as a local device to the 818 as that way it does not change input to the ID41 card (SLS), which means if I have to take a Teams/Zoom call, and pause the music, then I don’t have to manually change the input on the 818 back to USB from SLS. For some reason, after either a recent Roon update, or who knows a Windows 10 update, the Roon local audio no longer works through the USB…every time I try and play a track it stops immediately. If I try and play an album it rapidly skips through each track without starting any of them - this way I cannot actually take a screenshot of the signal output as nothing ever starts playing?

I have taken some screenshots of what I can though, please find them below. I believe my firewall is setup correctly, but perhaps you could give me some guidance on anything I could do there?

Pic 1 - before enabling devices, here are the two devices that used to work

Pic 2 - here is the 800 Series Audio selected after being enabled

Pic 3 - 818 USB selected, but no track will play

Pic 4 - Windows Sound

Pic 5 - Sound Control Panel

Pic 6 - Firewall

Many thanks,


1 Like

Hey @Chris_Bowie,

Thank you for the detailed follow-up!

As a next step, I’d like to focus on your firewall settings. Seeing that you have two separate ‘roon.exe’ apps, one for public and private, this may have happened after reinstalling roon at some point.

If you could remove both, and then manually add one ‘roon.exe’ and select both public and private access, followed by restarting your PC. Let me know if you run into the same issue after this :+1:

Hi Benjamin - I deleted both roon.exe instances in the firewall, then manually added the roon.exe file from c:\users\xyz\AppData…, then enabled it for public and private, then rebooted but it has not made any difference unfortunately?



Hey @Chris_Bowie,

Thank you for giving that a try! Following up on this, what happens if you power down and unplug all USB devices from your Core PC? Are you able to play audio from your system output?

If possible, are you able to test the setup with a different USB cable? If anything, this can verify that the current USB cord in use is functioning properly :+1:

Hi - yes have tried with another USB cable and sound works perfectly from the PC through the 818 for normal windows audio, teams/zoom, VLC with movies, or music etc. It is only Roon that cannot seem to play anything.

Is there a way to do a full remove and clean reinstall of Roon? Every time I’ve tried to remove and reinstall in the past, Roon seems to remember my previous local audio device name (that I typed in). Are there some registry keys I can remove etc to do a full clean reinstall?



remove the or rename the database folders then reinstall

Thanks - stopped Roon on the NAS, removed the Windows app, plus Roon and RAATServer directories, and reinstalled, but still not working unfortunately. Have confirmed that Roon and RAATServer are setup under firewall rules.

Hey @Chris_Bowie,

Thanks for giving that a try. Under your system sound preferences, you’ve selected the Meridian 818 on the dropdown. Do you have a system output option on that drop-down?

Beyond this, I’m not able to enable diagnostics on your account. With that, we’ll need to grab a set of manual logs from the PC having issues. Please use the directions found here and send over a set of logs to our File Uploader.

I’ll be monitoring this thread for your reply :+1:

How very strange - I changed my Sound Output device on Windows to “Speakers (Sonic Studio Virtual Mixer)”, then enabled the System Output (pic 1 above).

When I clicked play on an album, it did not skip through the tracks, but instead started playing (although no audio audible as that system output on my pc is not hooked up to anything). However, I kept the track playing on Roon, then I changed my Windows output device back to “Meridian 818”, roon went into pause mode, then i clicked play and the music started playing through my Meridian system!

Any idea why this is?

PS I tried to click on the directions link above but kept getting network errors?

Hey @Chris_Bowie,

My apologies, Please use the directions found here and send over a set of logs to our File Uploader.

This is odd indeed, would you be able to take note of the song that is playing the next time this happens, and share it here?

Thanks, Chris!

Thanks @benjamin - I have uploaded two log files from this morning - the older one was when tracks were just skipping, with Roon still skipping through tracks when using the System Output, unless I close down Roon, change the System Output to “Speakers (Sonic Studio Virtual Mixer)”, then restart Roon, start playing a track, then change the System Output to “Meridian 818”, Roon then pauses, I click play and the music starts again. (newer log file was after this).

The album in question is “The Best of David Bowie 1969-1974”, but it happens with any album, whether local library or Tidal etc.



Hey @Chris_Bowie,

After reviewing the logs with the team, we’re seeing a handful of errors around your PC output being unsupported, which is very odd. Digging in deeper, we’re seeing that the root cause may be linked to your Realtek ASIO driver on the machine, which has been known to cause issues in the past.

As a next step, please Uninstall this driver - it will not affect your audio playback experience. Here is a step-by-step on how to do this:

  1. Choose Start > Control Panel.
  2. Double-click the Add or Remove Programs icon.
  3. From the Currently installed programs list, select Realtek ASIO Driver.
  4. Click the Change/Remove button.
  5. Click OK to remove the ASIO Driver.

Let me know if the issue persists after the above :+1:

Thanks @benjamin - I removed all Realtek programs, then rebooted, but it did not fix the issue. I noticed that Realtek ASIO was still listed as an option in the audio settings of Roon however, so I removed the registry entries, then rebooted. The Realtek option within Roon then disappeared, but this still did not fix the issue.

Somehow, I stumbled across an advanced setting in sound control panel for my Meridian 818 device, to ‘allow applications to take exclusive control’. Clicking that on has seemingly fixed the issue - even after multiple reboots, Roon now allows me to play from this device without selecting another windows sound output, then toggling back to the 818 once Roon had started.

Weird - but at least it appears fixed for now - any colour on why that setting would make a difference here?

1 Like

Hey @Chris_Bowie,

You read my mind, and beat me to it! Digging into exclusive mode was an important step that I overlooked in the beginning. Here is some good information on its functionality:

I’m glad to hear you’re back up and running! Happy listening :notes:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.