Tidal albums won’t load

I’ve recently reactivated my Roon account and put my system back together. Everything is working with the exception of Tidal. When a try to see an individual album the screen stays on “Loading album…”

Hello @J_William_Truett,

Thanks for contacting support, I’d be happy to assist here. Can I please ask you to try disabling TIDAL and then re-enabling and if this does not resolve the issue then clear your TIDAL cache?

To disable and re-enable TIDAL, you can do so in Roon Settings -> Services. This is what it should look like:

If disabling and re-enabling does not resolve the issue, you can clear your TIDAL cache by doing the following:

  1. Close your Roon App

  2. Find and open your Roon database

  3. Navigate to /Library/Roon/Cache

  4. Move the contents of the /Cache folder elsewhere, like your desktop

  5. Try restarting Roon and syncing Tidal

The Cache folder looks like this on Windows:

Please let me know if any of my above suggestions help resolve this issue.


I’ve loggged out and back in to Tidal. I’ve also restarted all parts of the system with the same result. I use iPads and a Samsung Note8 as a controller, not Windows, so I’m unsure where to look for the cache file.

Hello @J_William_Truett,

What device are you using as your Core in this case?

To locate the Cache folder you have to navigate to your Database Location (https://kb.roonlabs.com/Database_Location) on your PC. This action is not cannot be done from an iPad/Samsung Roon Remote but has to be done on the PC itself (if using Mac OSX/Windows).

If you are making use of ROCK in this setup, you can access the Database Directory using these instructions: (https://kb.roonlabs.com/Roon_OS_Data_Directory) and access the directory from another computer on the same network.

Please let me know if you are able to use the above instructions to locate and move the Cache file as to generate a new one or if clarification is needed for any of the steps, just let me know.


Sorry, took me a while to get back to you. Deleting the Cache file worked. All systems go.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.