Tidal and Qobuz login fails

Core Machine

– Include your operating system, machine info (Model, CPU, RAM) →

NUC, i5 , 250Gb

Network Details

Ziggo (NL) modem/router> Supra cat 8>Netgear GP510 managedswitch> Wireworld cat 8> Silent Angel Bonn 8 switch>Supra cat8> EtheRegen switch> AQ diamond >SoTM ULtra Neo bridge> (Paul Pang Master Clock> SoTM and EtheRegn) Curious Cable USB>

Audio Devices

T&A DSD8 DAC> Balanced XLR>Gato pre amp > balanced XLR> Gato amp> CRL ls cable> Diptyques DP 160 ls

Description of Issue

Out of the blue there was no connection to the SoTM. So no Roon.
Whatever I tried nothing seemed to help.
I swapped cables, took out one, then two switches to no result. Same result after also deleting the external clock.
I succeeded restoring connection with the SoTM so that I can play from my library. The configuration is basic in this case. So only one switch (Netgear) and nothing else in the chain.
But whatever I try then, I can’t login either to Tidal or Qobuz. (Apart from Roon both services connect easily and work well).
Login through Roon in both cases results in a loop without escape (Roon directing to Tidal/Qobuz and vice-versa).
I checked updates on all devices, rebooted and restarted Netgear switch, Sotm, NUC, set the switch back to default but login to both services in Roon kept on failing.
I am at a loss what to try next.
Would appreciate some help very much.
Henk (NL)

try restarting the modem/router etc as well

what are your DNC settings showing

what core setup are you using? Rock or Windows or Linux?

what roon version too everywhere for that matter

Just started to re install the whole digital chain
Meaning that automatically the modem will restart.
ROCK is what I use.
And the latest update - as far as I know- is installed. I always do, the minute the opportunity it is published
What is DNC and where can I find its settings?

Hi Mr Fix It,

An update for your most appreciated support:
Just been busy reinstalling, resetting, rebooting.
Results: I can play from my library.
I can’t use Tidal, Qobuz or , new, Dropbox (for backup)
I tried to login in all three, to no avail.
In the case of Tidal and Dropbox I end up in a loop, that I can’t interrupt, even when trying the option of ‘switch account’ in Tidal.
In the case of Qobuz the same loop comes , but the screen says also: ‘network error, please check your connection’
I can’t discover anything wrong with network connection: mail, Qobuz, Tidal , all work flawlessly outside Roon.
Stil puzzling on DNC settings, what they are and where to find them.
That’s all for now.
Looking forward to your next suggestion.


hi Mr.Fix It,
I just jumped up from my chair, that me looking for possible solutions.
Ad suddenly : there it was. In the settings of my modem I had , for the sake of another setting, changed the setting from DHCP into Static.
II hd completely forgotten about hit. And up to now no idea that or why it had such an impact on the option to login.
You’d help me with an explanation, so that I can remember it and next time, don’t need tot come to ‘support’.
(and : still curious about DNC. Still learning as a pensioner…)

Hi @Hjcw_Roefs

Thanks for the followup here!

That definitely sounds like the cause here, I’m glad you were able to track it down! Setting a static IP can have its benefits, but it’s definitely something you want to be comfortable with because changing settings could certainly cause connection issues if not done a certain way.

When changing back to DHCP does everything work okay?

DNS settings…if you use static try DNS of or

Sorry for the typo on DNC

Mine looks like this…you numbers will maybe be different

Ah I see.
I’ll send a picture of mine. But don’t recognise the or part at the end of the IP

ok you are using DHCP

you might need to reserve an address ( as an example) in your router so you can safely set it as a fixed address and use the same numbers you see here but add a space and ( is your ISP’s provided DNS number)

Thanks again, wizard. Useful idea. Ready to execute it
Case closed.