Tidal and Roon on MacOS flakiness

Core Machine (Operating system/System info/Roon build number)

1.6 (build 416) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Henge Stone Dock on corporate ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Linn Majik DSM, 2018 variant, on corporate ethernet
software version: 4.69.289
software variant: Fw992

Issue: intermittent search failures and inability to play some albums/songs

OK, just had something strange happen that may be a clue to a lot of the Roon MacOS/Tidal weirdness.
Roon was ‘acting up’, only able to play albums previously played/added to my library. New searches would time out and tell me to ‘check my internet connection’. Rebooting/Restarting Roon multiple times did not fix this.

What did fix it was quitting Roon, starting Tidal’s app, quitting Tidal, and then starting Roon. Can’t explain it, possibly a coincidence, but I don’t think so. Now I can search/play as normal.


I think this may be the source of your troubles. Corporate networks often restrict or limit certain types of Internet traffic including streaming services.

Hi @Adam_Margulies,

I would agree with Martin here, sometimes Corporate networks have firewall rules in place that prevent Roon from operating properly.

It appears that it was a temporary issue since the reboot resolved it, but do note that running Roon on these kinds of networks where there are multiple firewalls at play can sometimes cause issues with Roon performing as it should.

If things are still working as expected now, I can go ahead and mark this thread as [Solved], but do keep in mind that troubleshooting these kinds of networks are often difficult simply because you can’t control all the variables.


What actually (and temporarily) seems to fix my issues is power-cycling the Majik DSM. Not sure if it is the corporate ethernet, although everything Martin and Noris have said makes sense to me.

I agree that this problem is hard to diagnose because I can’t tell if it is Roon, MacOS Mojave, my network environment, the Majik DSM, or some combination of the four that is at fault.

Lots of (closed) moving parts to the system.

It may just be that the Majik DSM needs a hard power-cycle periodically and I don’t know why. It is simple enough to do this the once per week it seems to require.

Please do mark this as Solved if you need to.

Hi @Adam_Margulies,

I went ahead and marked this thread as [solved], but if you do experience this issue on a non-corporate network in the future do feel free to reach out to us again regarding this behavior. Thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.