Tidal app problem in roon

Core Machine (Operating system/System info/Roon build number)

MacBook Air

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet, Ubee Part EVW32C, SSID 36D061, switch CUDY

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node 2i, Hegel H80

Recently subscribed on Roon and everything goes nice. Few days ago Tidal came in Serbia and I subsribed (get app on iphone, ipad, macbook) and working nice but cant work in Roon. There is Tidal tab, but if I want to select playlist or to search some song…nothing happened. It just say -playlist empty-. Tried to reboot, log in/out…but nothing. Would appreciate your help


You may have not configured/enabled Tidal in Services.

Go to Roon Settings - Services - and there you should have Qobuz, Tidal and Dropbox. Select Tidal and review the settings there. Maybe post a screen grab on here with what is being displayed once you select Tidal.

when go to settings-service-tidal… this screen open (tidal + roon) , than log in and Tidal open. But when revert to roon and go to Tidal, its not the same screen. It has new, tidal rising, etc…etc and nothing is in function on Tidal inside Roon

Don’t select Tidal but select login to the right of Tidal.

Screen looks fine. I take it it still does not load your Tidal playlists, etc? I see your wifi is disabled. You sure you are connected to broadband? :slight_smile:

this the screen when I choose Tidal service in Roon, where I cant do nothing .

and yes, broadband is doing ok as I listen roon live radio, as well as Tidal music from desktop app…

so my problem is that I want to listen Tidal via Roon as I already listen it through airplay via iphone, ipad and from Mac desktop app

Hi @Predrag_Aranitovic

Apologies for the trouble! As Serbia is a new region for TIDAL, integration with that region hasn’t quite made its way into Roon yet but it should be working for you very soon.

ok, hope so, as it works on other platforms. Thanks very much for your time and speak soon, regards

I would have never figured this out :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.