Tidal cannot play tracks & too many errors

Core Machine (Operating system/System info/Roon build number)

Mac Mini running running Mojave, 8 GB of memory

track currently not available on Tidal
too many failure stopping playback

issue happens when trying to play music on the core or remote notes such as my MacBook.

11 days left of my trial version - so far i am far from impressed

the Mac book is connected via an ethernet cable. the network is stable, no outages and missing packets. I can play exactly the same track on the native Tidal client running on both machines. why am i not able to do this reliably on Roon ?

tried rebooting the machine, tried logging off and on again

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
wired network with 100% ping reachability of internal and external end points such as Google.


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue


Hello @Camillo_Fernando ,

Welcome to the forum.

Can you confirm where these tracks are coming from, are they from a playlist or are you manually searching for them and getting the error? Do local library tracks work as expected - only TIDAL is affected?

How do you have your DNS servers configured on the network, are you using Cloudflare DNS, Quad9 or Google DNS?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.