Tidal is loading slowly - error



Hope very much you can help. I’m new to Roon and I would really like this to work out. Thanks!


Everytime I start playing a track “from” Tidal I get this error after 3-5 seconds in the song: “Tidal:Tidal media is loading slowly. This may indicate a networking ot connectivity problem.”


Roon version: 1.5 (build 363) stable (64)
OS: Windows 10, 64bit
Device: Lenovo Thinkpad T420s, i7, 8Gb Ram

Network: Fiber, ethernet. Actual speed, 300+Mbit/300+Mbit

Media: Tidal, Master, Exclusive mode on, Force volume on.

Hello @Mik_Shridhar_Hojlund,

Thanks for contacting us regarding this issue. Can you please let me know what the model/manufacturer for your router is? We have seen that some routers require special settings to be applied as per our Networking Best Practices Guide.

How is your Core connected to the network? Is it connected directly to the Router via Ethernet or are you making use of any switches/range extenders/powerline adapters in this setup?


Thank you Noris for responding so quickly.

The router is a Technicolor TG799VAC Extream. The core is connected via Ethernet. I have tried both directly to the router and through a TP-Link Gigabit Powerline Adapter - 2000 Mbps. Also wifi and it’s same outcome.

Thanks for confirming that info @Mik_Shridhar_Hojlund,

Since you are making use of a Technicolor router I would suggest you try the following:

  • Add an exception for Roon and RAATServer in the router’s IPV6 firewall settings (as mentioned in our Networking Guide)

  • Change your router’s DNS server to Google DNS or Cloudflare

I would not advise making use of powerline adapters as we have seen them cause issues in the past, having an unmanaged switch with a direct connection to the router is what we would recommend to have in place. Please let me know if my suggestions help.


It seems my IPV6 is disabled (see picture) and I don’t know how to enable it.

What data would I write in an exception?

I’m not sure how to change the router’s DNS.

What router would you recommend? If all go not so well…

Thanks for that info @Mik_Shridhar_Hojlund,

Hmm, there should be an option in your Router settings as to set the DNS addressing, can you take a look around to see if you can find it?

Also, I just want to verify here, does this issue happen with all of your endpoints or just that one DAC zone? Does “system output” play as expected? We also have some fairly extensive documentation for troubleshooting dropouts which may give you some more ideas here. I would also try a TIDAL Cache Clear in case that helps.

If we would need to go the router replacement route, we have seen the Netgear Nighthawk line have the fewest amount of issues, but I don’t think we’re there yet to say for sure that the router is the one causing these issue. Please let me know your results to my above questions when possible.


Well…I cannot find any other places to change dns that i’ve already shown in previous images.

I tried other endpoints and only the system output seemed to work that untill I changed to another song and then Roon crashed. It crashes allot now.

Under Internet Access I can see the DNS but I cannot change them.

Hello @Mik_Shridhar_Hojlund,

It appears that you cannot change the DNS for the router itself. I would try changing the DNS for your Windows 10 Core itself using these instructions. Please let me know if that and the cache clear I mentioned in my previous post help with this issue.


Hi again

The cache clear did not do anything. So I uninstalled roon and reinstalled it.

Now roon works directly with internal pc speaker(‘Lenovo’), and indirectly with the dac(‘Xiang Sheng’) via ‘system output’. But lossless is lost from ‘system output’ to the dac. Why is that?

Directly with dac, it’s the same. 4 seconds of music, 4 seconds pause and then skip to next number and repeat. And the error message regarding network etc. appears.

With Asio4all(‘unnamed’), only issue is the sound is cracked, like digital distortion. Useless.

I’ve tried change the usb cable, no difference.

I’ve not tried yet to change DNS as per your last post.

Thanks for the continues help.

Ok @support . I tried changing the DNS within windows 10, as I suspected it was not it, but now I know how to do that.

What seemed to be the solution was to untick the option ‘enable event mode’. What is that about?


Hello @Mik_Shridhar_Hojlund,

System output is limited in that it does not talk directly to the DAC but rather with your Core and then the Core passes that information on to the DAC, causing a limit in the sample rate.

Just so I understand you clearly here, once you disabled Event Driven Mode everything is working as expected and you are not seeing this issue anymore? As per our KB’s description of this feature:

This setting enables a cleaner and more modern mechanism for passing audio to the device driver.

We recommend leaving it turned on whenever possible. Some devices, particularly “HD Audio” implementations often found on PC motherboards, can’t handle this mode, so you’ll have to turn it off. We enable this setting by default whenever Exclusive Mode is turned on. One somewhat counter-intuitive consequence of turning it off is that our Zone Linking functionality doesn’t work quite as well without it.

Does having Event Driven Mode disabled allow proper communication with the DAC directly? Please let me know when possible.


Hello @Mik_Shridhar_Hojlund,

Adding onto what @noris had to say, what other audio applications or plugins do you have installed on this PC? I believe the issues you are seeing may be caused by other programs attempting to access exclusive audio devices at the same time as Roon. Could you try installing Roon on a fresh user account on your PC without any audio plugins installed and seeing if things work correctly?



As you understood it, yes “having Event Driven Mode disabled allow proper communication with the DAC directly”. It did the/a trick.

Why does the core cause limitation? I thought it would be the system that would be the limitation.

Hi John

Yes sure I will try that.

Thanks for adding onto.


I did and it does not work with ‘enable event mode’ enabled.

I will try later on another computer with a fresh unused user and roon installed.


1 Like

So…I installed roon on my son’s laptop and everything went well. Also with the event mode enabled. But it did give the laptop the blue screen twice.

I guess something on my laptop does not compute well with roon.

Hello @Mik_Shridhar_Hojlund,

Apologies for the slight delay in getting back to you here. Roon does not cause blue screen issues since it runs in user space, so I would take a look at the graphics drivers or audio drivers on that computer. In any regard, glad to hear that you’re up and running with Event Driven Mode disabled, do let me know if you run into any other issues!