Tidal issue - can't play any albums in my collection


I’m in the Netherlands, and if I try and play any Tidal albums, I’m getting “TIDAL: This track is not currently available from Tidal” for every track/album I’ve tried.

I’m signed into Tidal (in Settings/services), and it says I’m successfully signed in, but I notice that if I try and sync the library, the timestamp doesn’t change.

I can play Tidal albums fine via the browser - just not through Roon at the moment…

I had the same issue just now (also, synching through services didn’t work), restarting roon on the server fixed it.

You’re right - restarting the Core server (running on a NUC with ROCK) has cleared the issue. Thanks. I’ll snapshot the logs in case @support want to take a look…

Thanks @Geoff_Coupe – can you PM a link to @Ivan and myself?

1 Like

Interesting - had the same issue, re-booting NUC did not eliminate the problem. in my case, I logged out of Tidal in the services tab within Roon Core and the new attempt to login resolved the issue for me.

I didn’t reboot the NUC, I restarted the Roon server via the web page. This might explain the difference in behaviour? At any rate, I’ve sent the logs into the Roonies for them to take a look.

Sorry I meant - I did the same via web page on my mac.