TIDAL issues on wifi at work via Roon ARC

When playing anything from Tidal via ROON ARC, including just CD quality tracks with no MQA, I can’t seem to get it to play when on the Wi-fi at work. I get the “unexpected error” message. Occasionally, it will play a few songs but as soon as you skip to another song from Tidal, it won’t play. When I play anything from Qobuz via ROON ARC up to 24/192, I have no issues and even DSD tracks up to 256, they’ll play just fine. Also, music plays just fine from Tidal’s native app including MQA tracks.

I have an i5 Small Green Computer Server hooked up directly to my router with an average of 20 MB/s upload speed currently. I turn off all security apps on my phone. I even tried logging out of Tidal in ROON and restarting and then logging back in to see if that fixes the problem. But nope. So when I’m at work, if I want to listen to anything from Tidal, it has to be only through the native app and not through ROON ARC. Not sure why this issue exists with only Tidal, but I’m hoping a future update will magically fix it. Also, Tidal via ROON ARC on my Wi-Fi at home or via just cellular data plays just fine.

Wondering if anyone else has this issue?

perhaps you office has some firewall policy that is not ARC tidal API freindly…could well be a different API that roon uses to what Tidal native app uses.

Yeah I suppose that’s possible. Doesn’t help that they tightened things down a bit after my company got hacked. But being that Tidal plays fine from the native app and Qobuz and other local tracks play fine via ROON ARC on Wi-if, I’m hoping that maybe a fix will come along for this. Or maybe there’s some kind of workaround I can do on my end. I know ARC is in its early stages so you never know. Or maybe it’s just a lost cause.

see what support think

Roon Core Machine

Sonicorbiter OS/Linux - Small Green Computer, Intel i5, 8 GB RAM

Networking Gear & Setup Details

Linksys AC1900 Dual Band Wi-Fi 5 Router hooked up to my ARRIS T25 MODEM and my server is hooked up directly to the router. No VPN in use. I have an average of 20 MB/s upload speed.

Connected Audio Devices

Playing music via ROON ARC at work on Wi-Fi with the iFi Go Bar from my iPhone 11 Pro with latest updates. Also same issue I’m having also occurs on my new iPad Air 5.

Number of Tracks in Library

About 3,000 tracks 70 of which are local files.

Description of Issue

I can play Qobuz and local files just fine via ROON ARC but Tidal won’t play at work via ROON ARC on the Wi-Fi. Tidal plays just fine via the native app. Also, Tidal plays fine via the Plex Apps with no issues at all. Tidal via ROON ARC will play via Wi-Fi at home or via cellular data with no issues. Maybe it’s some type of security setup on my work’s Wi-Fi that’s blocking Tidal through ROON ARC. Playing either standard CD quality tracks or MQA tracks have the same result when trying to play them via Tidal in ROON ARC. So I’m kind of hoping that maybe there’s some kind of magical fix or something that a future update could possibly fix.

Hi @Drake_Potter,

Please accept my apologies for the long delay in responding here.

Diagnostics from your ARC account show errors associated with Tidal cached playback on cellular connections, suggesting this might not be an issue with enterprise WiFi after all. These errors crop up when ARC relies on cached versions of a track during periods of poor connectivity. Let’s first try deleted and reinstalling the ARC app, to fully and deeply clear that cache.

Do you experience this issue with one particular filetype or sample rate? I’m curious if the same file formats exhibit playback issues when you try with local content, as well.

In the meantime, if you haven’t already, sign out/in of Tidal in Roon. I also recommend clearing your Roon database, in case there is some authorization mismatch occurring. Take note to save a Backup first.

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall Roon on your Core
  • Verify if the issue persists on a fresh database, then restore your Backup and try once more

We’ll be standing by for your response.

Hello,

Thanks for getting back to me.

I tried uninstalling ROON ARC yesterday and reinstalling it and tried it at work today. Same issue seems to happen still where all TIDAL tracks either just CD quality or MQA tracks of any quality pop up with that unexpected playback error message. But QOBUZ tracks of all qualities up to 24bit/192khz and local tracks not downloaded to my phone play back just fine of any quality as well. Also, I have a local album that’s MQA 16bit/88.2khz and that plays just fine. So it seems to be an issue strictly with anything from TIDAL no matter what it is.

When I have a chance, I’ll give the other steps a try to see if that resolves the issue or not. Once I do, I’ll be sure to report back here with the results.

Thanks

Hello,

So instead of having to deal with the ROON backup procedure on my ROON core on my Sonic Transporter for now, I decided to install ROON server on the laptop I have after uninstalling any previous copies of ROON on my laptop. I then signed up for a 2 week trial for the laptop after setting up a new account. Afterwards, I logged out of TIDAL on my Sonic Transporter and then logged into TIDAL on the ROON CORE on my laptop.

Then I uninstalled ROON ARC from my phone and then installed it again and connected it to the ROON CORE on my laptop this time instead of my Sonic Transporter.

I made sure everything was working with ROON ARC from my laptop before I left for work this morning. I tried playing various albums from TIDAL once I got to work at different times of the day. I’m still getting the same result regardless of it’s cd quality or MQA. I also tried playing local files on my phone via ROON ARC and there’s no issues there. I can play the tracks from TIDAL just fine though as soon as I switch to using my cellular data in the office instead of the Wi-Fi.

So I’m not quite sure what’s going on.
I suppose it’s possible there’s something with the Wi-Fi at work that just blocks tracks from TIDAL for whatever reason.
Also please note that I don’t actually have a password for the Wi-Fi at work. It’s our guest Wi-Fi access I’m using but somehow we’re able to use the Wi-Fi still without putting a password in. Our company had their system hacked recently so they’ve got things locked down a little bit and are not willing to give out the password for security reasons.

If you have any ideas, let me know.

Nobody here can solve your WIFI issue at work, but you should be able to use your cellular data plan with Roon ARC. Where I worked for 34 years, we would have been fired for trying to use the company WIFI for non work related activities.

The thing though with ROON ARC is that it works perfectly fine on the Wi-Fi at work when playing my local tracks saved on my ROON CORE of any quality including Flac files up to 24 bit/192 kHz and DSD files up to 256. Also, any tracks from Qobuz up to 24 bit/192 kHz play without any issues as well. They play almost instantaneously.

It’s like the Wi-Fi at work doesn’t like TIDAL for whatever reason. Although, any tracks including MQA tracks from TIDAL play just fine from the native app. Also, TIDAL tracks play just fine through PLEX SERVER which I also tested out when at work via the Wi-Fi,

So everything seems to work except for playing music from TIDAL via ROON ARC which is the frustrating part. Luckily, I do have unlimited data now but still.

I’ve never tried Roon ARC on any WIFI except at home where it works fine. It’s also working great now over cellular. This is with Tidal and Qobuz and a couple local albums.