TIDAL login won't stick

Can we hear from people that do not have this issue… :rofl: :rofl: :rofl:

I have zero problems with Roon, Tidal, and Qobuz. Not sure why. I still wonder if it’s a geographic thing.

With all that is going on in the world I realize this is a rather petty issue. With that said I am getting frustrated with having to do this at least once a day. Roon and/or Tidal need to figure this out. I wont bail on Roon as I am a lifetime subscriber. I am starting to save everything in my Library that I can in Qobuz because I am tired of having to open up my screen and relog everyday.

Hi Miguel, I don’t have the issue but my core is running from a Ubuntu NUC and the endpoints are Windows, Android and occasionally Apple OIS.
I hope the cause of this behaviour will be addressed soon.

1 Like

I am still having the same issue. Been about 4 months and ongoing. \

Same here. There seemed to be a change in the TIDAL login method this morning (on the TIDAL native app on the mac) so I tried again. No dice, Roon still does not remember the credentials.

Exact same here


Also have same issue, each restart, message tidal logon retry, pressing retry brings safari, yes, open, and ok.


same here on a Windows 10 Machine. If you need more information, please let me know. You are doing a very good job in bringing us this fabulous product, thanks for that♥️. I am working in a company that is doing software development too, so I know about issues that are hard to reproduce and to fix. So take the time that you need and don’t be bothered by harsh comments here. I also understand that people are frustrated by this bug, but some things take time and…come on… there are worse things in life than that.
Kudos from Germany,

There’s a fix in development according to a reply to another thread.

1 Like

Still having this same problem (having to login again to Tidal after restarting Core/RoonServer) after months of waiting for a fix.

Very disappointed in Roon’s failure or inability to squash this very annoying bug.


Just installed the latest revision (1.7/571).

The TIDAL token seems to be remembered on restart, although I do get the “Retry” dialog box still.

The Qobuz login does not work anymore, the password is lost on restart. I can retype the password and that works, but EVERY TIME?

Roon guys: Really? WTF?

1 Like

For the record, I have tried all manners of setting clean credentials. That is logging out and disabling both TIDAL and Qobuz and redoing the logins. The result is the same:
1- TIDAL remembers the credentials / keep the token, but still times out and requires a “Retry”
2- Qobuz does not remember my password no matter what and requires me to re-enter it. Even worse: the failure is silent so I don’t know that I was not logged into Qobuz until I realize there are no Qobuz albums in my library.

Frankly guys, you suck. I don’t recall EVER having a problem like this with Audirvana.

Very same story here - having to login again to Tidal after restarting Core (i.e. every day, my Roon core is PC/Windows10/64 based and I have it automatically shut down every night at 1AM). No change with the latest revision. This is not a great problem, but it sure is annoying.

Can you guys explain where we are at here please?

Hi! I have same problem for dew months. Only solution is to rebuild library from scratch wchich is pain the as… But what is very strange that after about 3-4 weeks “Too many failures. Stopping playback” info starts to show and then after next weeks It is so annoying that I need to start over again.

Hi everyone,

The latest release included some changes to improve our login process with TIDAL. A number of underlying issues have now been addressed, but we are aware of some cases where Roon can still display error messages related to TIDAL log in, typically due to performance problems – either the speed of the Core device, or the performance of the network or internet connection. In all these cases Roon should now try to log in again without forcing you to log in through the TIDAL website, as was happening before.

We’re looking into whether we can do better in some of these cases, but resolving the environmental slowness will also cause the error message to go away entirely, and this week’s update should improve the overall experience even for setups .

I hope this helps to clarify things. Please let us know if you have any other questions!

Nope. I run a mini with an i7 quad processor (quad core, 2.6GHz), 16GB of 1600MHz RAM, and a 250GB SSD (Samsung, new, 10% full) for system+Roon db. Nothing else runs on this machine. I can do DSD upsampling, no issues.

My internet connection has ~11ms ping time, 350Mbps down (consistently), and 20Mbps up (consistently). The LAN is all gigabit. The mini is connected over wired gigabit ethernet to the network. Again, no.

More importantly, I NEVER ONCE have an issue with Audirvana logging on, timing out, losing credentials or anything else.

I think you need to really need to put some expertise into this problem.


Please explain to me how a slow network connection or a slow machine can result in LOSING your credentials. Please do.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.