Tidal Masters tab playback error (1.3 - build 208)

The new Tidal Masters tab is great - but I’m unable to play some albums - a pop-up appears saying “Tracks played are unavailable”.

Strangely I am able to play these albums if I search for the artist and then manually figure out which is the 24-bit version.

I’m in the UK - perhaps this is a location issue?

I also notice that the majority of albums I can’t play from the masters tab are Tidal Masters titles I’ve already added to my library. I can play them fine from within my library (searching for artist and then playing album) - but not from the Masters tab.

Can anyone else reproduce this? I’m wondering if it’s UK specific.


I just tried several albums from the Tidal masters Tab, all began play successfully. I’m in the US.

@Simon_Finch This happened to me too this morning (I’m in the UK as well). When I tried again it worked; unfortunately, I think this is probably an issue at TIDAL’s end, but I’m going to keep an eye on it.

Can someone tell me where they are seeing a Tidal Masters Tab in Roon now? I am upgraded to build 208. I have Roon as a remote on two pc’s, one iPad and one iPhone.



We await the iPad app update.

Okay, thanks Joel.

Thanks… I do see the tab on my Windows machines now. I’ll wait for the 207 iOS update.

Hi Joel

This is still an issue for me.

To clarify, it only affects Tidal masters albums which I’ve added to my library. i.e. if I’ve added a ‘Masters’ album to my library it will not play via the Tidal > Masters tab (it gives the error “Tracks played are unavailable”). They will only play if I search for the artist and play the album from there.

This failure to play is 100% consistent. As previously mentioned, I’m in the UK - this may be relevant.

Would you mind adding a Tidal Masters album to your library - and then trying to play it via the Tidal > Masters tab?


Hi Simon, no problems here (I tried three from the TIDAL Masters tab that I have already added to my library). Best flagging @support on this one…


Not an urgent issue - but an issue nonetheless. Also reported by Jeffrey_Robbins in this thread Tidal Masters via Roon

When trying to play a Tidal Masters title - from the Tidal > Masters screen - Roon gives the error “Tracks played are unavailable”. This only happens with Masters which I’ve previously added to my library. If I hit play a second time - after the error display - it plays fine.

I’m in the UK - not sure if this is relevant.

Hi @Simon_Finch ----- Thank you for the feedback. I would like to gather some additional information from you as well as a set of logs and will be contacting you via PM momentarily.