Tidal media is loading slowly - any fix yet?

**Core Machine - windows 10 pc, ryzen 3700x, 16 gigs 3600mhz ram, roon version 1.7 571


Network Details (tp link router, netgear modem, core and endpoint on ehternet)


**Audio Devices (rpi 3b+ w/allo boss dac, ropieee OS, connected to yamaha a880 with Monster rca’s)


Repeatedly getting tidal media loading slowly prompts when streaming tidal tracks. System output streams without issue, same tracks. I’m noticing it occurs on tidal masters/192khz but maybe more. Tried the cache delete fix, modem reset, router reset, disable/re-enable tidal, reboot rpi, unplug/plug. Still happens. Sometimes after hours of listening sometimes after mins.


Try changing the DNS address used by your router to (or
It’s also recommended to connect your router & core via ethernet cable, as is already the case.

Hello @damien_lahoz, MJB has a great suggestion here. Have you had a chance to change your DNS? Please let me know if that produces better results!

I did. No change at all. I have seen that this effects only, so far, the master recordings, ie 24 bit 192khz. I didn’t think dns settings would effect this. The forums are filled with users with many different use cases reporting the same issue with tidal and roon. Are there any resources being used to figure this issue out?

Hello @damien_lahoz, is this endpoint the only one showing the issue? And yes, we’re currently working on some issues with TIDAL, but yours is likely different if you’re only seeing this on hi-res tracks and not system output.

Correct, only on the endpoint. Is there a setting in roon or in tidal that could restrict bandwidth? I’m going to use a cat8 cable and see if that works. I can’t imagine a hi res file is so large it can’t stream easily over ethernet, which is what makes me think it’s a setting or the raspberry pi itself.

Hello @damien_lahoz, you can limit streaming quality in settings>services>TIDAL as a test and see if performance for that endpoint improves. Let me know, though!

I just installed the latest Roon update today (patch never comes with an identifier or ability to rollback) that gave way to the old “Tidal Media Loading Slowly…” error string. I must say this gets really frustrating that several times now after applying patches either things don’t work or become unstable. This is not on top of significant instability introduced with v 1.7.

I’ve read through a bunch of threads (like groundhog day) that advise to clear cache, delete the usual suspect cache files etc. and still getting the issue. Seems like QA issues are contributing to larger number of defects showing up in shipping product. Not good and my rig looks to be down for the weekend.

Help appreciated and I will continue to spend my time reading through a bunch of threads that could be spent listening instead (sad face). I have 200 MB of download bandwidth and ultra fast ping responses, so the error message itself appears to be misleading. Tidal as always works fine on my mobile device.

If you’re having a problem with Roon, you should enter a new post in the Roon Support forum and also fill out the page where you describe your Roon setup in detail. Roon support wants/needs support request entered separately, not tagged onto the end of some other thread.

Plugging the endpoint directly into the router with a cat8 is the only fix iv found so far. The problem, at least for me, is with high res MQA audio ONLY, any Mqa not just 192 and above. Hifi was without issue. And being that my endpoint is not MQA, It is not a deal breaker. But again, cat8 cable direct to the router is a fix for me so far. What that says about where the issue truly lies is beyond my skill to determine. But that is not a real fix imo. The bandwidth of hires audio streaming should not require such a draconian solution in 2020. It isn’t an option for alot of people anyway. First world problem for sure. I appreciate the assistance but I hope roon continues to try to find the real reason the “tidal media is loading slowly” issue is happening

Hello @damien_lahoz, I’m glad you’re getting better playback via Ethernet. This is something we discuss in our networking guide.

Avoid connecting high resolution/high-performance audio devices to Roon via WiFi to ensure optimal performance.

I actually was on ethernet before. Plugged directly into a wall socket with a cat5, then cat6. But that didn’t cut it. So far, cat8 into the router is a go.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.