Tidal media loading slowly problem

Core Machine (Operating system/System info/Roon build number)

Nucleus: Roon Version 1.6 (build 416) stable (64bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Asus RT-AC68 router lan direct to Nucleus

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Nucleus usb to Oppo udp-205 usb audio input

Description Of Issue

Have had nucleus for about 3 months since Feb 2019, works fine for over a month. Then since about mid March 2019 there have been major issue of skipping all tracks after plaing for 16-17sec of streaming with 80% of albums - “TIDAL media is loading slowly. This may indicate a networking or connectivity problem”.
I recall Nucleus had some firmware update back then and I suspect it’s related as there was no such problem before. I have read that many many people with same issue, hopefully there will be a firmware fix to resolve this.

Please supply the requested information otherwise we have very little to go on…I’m betting is a networking / wireless issue or you have slow internet.

If its lan or network related then how come it works perfect for over a month?
nothing is change in my network since

Well now there are the missing blanks filled in we have something to go on.

What do you get on a Speedtest.net test? Also what is your external providers service speed rated at?

Does it work fine if you use tidal app on your pc/Mac?

Have you restarted the Nucleus? Done in the web GUI

Please… i don’t want to go through the same standard trouble shoot like the others ie. using Google domain, ping test, etc and end up having the same problem.
My Ipad plays Tidal fine by it’s self. My problem like most user is Nucleus usb connection to my DAC - Oppo 205
I know that certain album plays fine - Diana Krall -The girl in the other room, plays fine the whole album. How do you explain that?
But 80% or 90% of all other albums i try have the same problem - plays for 17sec then skip to next track with error msg - “TIDAL media is loading slowly. This may indicate a networking or connectivity problem”

Just want to add that i have tried rebooting (including uppluging power & wait over 30sec) my modem, router, nucleus, my dac but same problem.
ipad works fine playing Tidal
but not nucleus to my dac

Is the Diana Krall album a Tidal album as well? Can you give examples of albums which don’t play for comparison? Are some MQA and some not? These are some informational bits that might help support to know.

Can you also try changing your DNS to Google ( or Cloudflare ( as I’ve seen this often helps.

3 posts were split to a new topic: Slow Search with TIDAL enabled

Example of a non MQA album with problem -Queen The Works (2011 Remaster)

I download an album from my cd and load to Nucleus harddisk to see what happen. Surprisingly i get same drop off after playing a song for 17sec with a slightly different message “An audio file is loading slowly. This may indicate a performance of hardware problem” So it seems it’s not Tidal related.
Spoke to the shop who sold me Roon Nucleus about this, he told me to try disable DSP.
Then I recall when playing around with Roon I did set DSP up-sampling aprox a month or so ago. After i disable DSP, everything works fine again, no more drop off playing from harddisk or Tidal streaming.
So the problem seems to be not related to my network but something to do with streaming data if converted into DSP will somehow jam up my Oppo 205 DAC usb audio input and Nucleus auto respond was to skip to next track.
Is there a way to fix this?

Can you list the DSP you were using, like upsampling to DSD128, apply volume leveling, etc. Maybe a shot of the Signal Path with DSP enabled.

Hi Rugby, perhaps I didn’t try or understand how to set all the DSD perimeters properly.
Sample rate conversion to DSD
DSD sample rate set to 256
Enable Native Dsd Processing

Dsd to pcm gain +6 db

Hi @Robin_Yue,

Since this behavior is occurring for both Local + Streaming content with DSP turned on there is likely a bottleneck somewhere, possibly the connection between the Nucleus -> Oppo. The follow-up questions here are:

  • Does this behavior occur on other zones or is it limited to the Oppo zone?
  • Is you Oppo using the newest firmware?
  • Have you tried a different USB cable in case the one you have is damaged? I have sometimes seen cables go bad so I wouldn’t just assume that it is working properly.
  • Can you share a screenshot of your Signal Path when there is content playing to the Oppo zone with DSP turned on?


Try turning “Parallelize Delta Sigma Processing” ON and “Native DSD Processing” OFF and see if things improve.

Hi Noris, it’s strange but after I turn back on DSP neither problems appeared anymore in Tidal nor from hard disk.
Even with both Parallelize Delta Sigma processing On and Native Dsd Processing On.
My Synergistic Research Atmosphere x usb cable should be good then.
Hope it stay this way as it should:)) as Nucleus Sounds amazing. I’m a happy camper.

Thanks again for your help Noris, Rugby!


Glad to hear it Robin. If you look at your processing speed, you will notice that it is 2.2x. If it drops lower than 2x that is a sign that a faster machine could be needed to do the DSP. Upsampling to DSD’s higher resolutions are very processor intensive.

Hi @Robin_Yue,

Thanks for sharing that screenshot and for letting me know that this issue has resolved itself!

I too hope that it stays that way, but if you experience this issue in the future again feel free to reach out to us again and you can give the optimizations above a try to see if it helps. Happy listening!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.