Tidal not playing in Roon [Resolved]

I’m able to open albums, access playlists and select “play”. But thereafter, nothing plays. The song just doesn’t start. I have tried logging out of Tidal and logging back in. Also, Tidal plays well on mobile (iOS) app.I haven’t tried the desktop app. Is this a Tidal issue or a Roon issue?

Kindly help!

Hello Gurpreet, the support team is going to need to know more about your situation. They will probably want the following;

  • A brief but accurate description of your current setup, using this link as a guide.
  • Please outline your network configuration/topology, being sure to provide insight into your networking hardware
1 Like

Hi @Gurpreet_Kohli ---- Thank you for the report!

Moving forward, to help aide in our understanding of this behavior you are experiencing, would you kindly please provide the information requested in @Rugby’s post (:thumbsup:) , as well as the following:

  • When you notice this issue, do receive any error messages in Roon?

  • Do you ever experience the same issue when playing back locally stored content from your personal collection?


Dear Eric,

Thanks for a prompt reply. I could not see the link in @Rugby 's post. But, i get what you need.

Roon Server on Windows 10 Creators Edition Laptop (HP) on Wifi (not Ethernet)

  • DAC: Mojo
  • Roon Bridge on Allo USBridge on Dietpi Ver 156
  • Allo USBridge on Wifi or Ethernet (tried both)
  • Roon Remote app on Iphone 7 (iOS 10) on Wifi
  • Squeezebox option is off (i can try Ipeng on Iphone which i have used in the past to play via Squeezebox option in Roon, but i haven’t tried it lately).

In this configuration, i can see Tidal albums and select them for playback, but the song doesn’t play. It also takes a long time for Tidal albums to show up.This problem started about 3-4 days back. TIll then, i have not had a problem since i started using Roon a month back in this configuration. Please note that i have recently subscribed to Roon and this is a rude shock (glad i did not buy a lifetime subscription!).

I do not see any error messages. Sometimes, there is a popup that there is a network issues in Tidal playback, but it used to appear earlier too and Tidal just moved to the next song in the playlist. Now, this popup isn’t there most of the time and the song is just stuck at 0.00 on the timer.

I have no problems playing local files on my laptop (stored on hard drive or SD card) with Roon. They play instantly.

Roon on Windows 10 (HP) - Laptop playback - Laptop on Wifi or Ethernet (even direct to modem/router)

  • Same problem. It takes a while for Tidal to open and then when i play a song, it selects the song but playback is stuck at 0.00.
  • Local files on the hard drive / SD card on laptop play fine.No issues here.

Other Configurations to Playback Tidal (all on Wifi)

  • Tidal plays perfectly well on my Iphone iOS Tidal app. I can even Airplay is (through Shairport) to USBridge. No issues there.

  • M Connect app connects to Tidal easily and i get playback on my Iphone 7. No issues here too.

  • I played Tidal through Chrome browser on my HP Laptop. Again, no issues - playback is fast and good.

  • On Android Marshmellow, i used UAPP app and i got Tidal playback without any issues.

  • On Android, i also used Bubble UPnP app and again, no issues with Tidal playback.

  • On Tidal Desktop app on Windows 10 HP Laptop, i got the same issue. I could select the song/album and when i clicked to play, there was a rotating wheel showing the song was loading, but it got stuck and there was no playback. I tried this on Ethernet too and i got the same problem.

Later today, i will try my Surface Pro 4 Windows10 Enterprise Edition (1607) and see if i can get Roon Server to play on that ( it will mean switching libraries, but all worthy in the spirit of problem solving!).

So, there seems to be some issue with connecting to a Tidal server on Roon and Desktop app. Every other software (iOS app, MConnect app, UAPP, Bubble UPnP) seems to be able to connect and play without an issue.

My internet speed is 40 Mbps. I’m based out of India and using a Hongkong subscription for Tidal. Since Roon is not working, i am not using Shairport to play Tidal from my phone to my audio system… Its free and still works!

Could it be a firewall issue? I did change some settings, but it is strange that only playback is impacted - i can still open all Tidal albums and playlists.

Hope you can figure out why Roon is struggling to connect to the Tidal servers.



Dear Eric,

So, here is another system that i tried and it works …

Roon Server on Surface Pro 4 Windows 10 Enterprise Edition (on Wifi)

DAC - Bluetooth Headphones (Jabra)

  • I’m able to play Tidal well and without any issues.
  • The Wifi connection is not my home connection, but my IPhone (using its hotspot).
  • I’m using the iOS Roon Remote app to control Roon Server.


Does this mean the issue is my home wifi? I will try the same configuration in my home wifi later today (i’m in office now).



If the same issues are happening in the Tidal desktop app, then the issue is environmental to the laptop and not Roon’s software. Try checking if you had a windows update right before this issue started.

Dear Daniel,

Thanks - i also think it might be the laptop. But, the question is what i should fix. Everything else seems to be working fine. Has there been a change in Roon software too lately? I saw an update for the iOS app this week. I’ll now try the Android app and see if that makes a difference.

To be honest, a software so expensive should not be having these problems. I use Dietpi which is free and can understand such issues there, but not with Roon.



Hi @Gurpreet_Kohli ----- Thank you for touching base and sharing the observations you ave made during your testing with us. The insight is appreciated.

Moving forward, you mentioned the following in your report:

“Could it be a firewall issue? I did change some settings, but it is strange that only playback is impacted - i can still open all Tidal albums and playlists.”

Have you tried testing with the mentioned firewall disabled (temporarily) to confirm if things improves?


Dear Eric,

Roon is activated in my firewall options. I haven’t tried with the firewall deactivated - will try it later today.

I called my internet provider and they indicated some new DNS server addresses. I tried one and it worked for a while and is not working anymore.

Is there a DNS address that you would recommend for best Roon operation?



I’ve had good results from the Google Public DNS

Just tried the Google DNS servers - not working still. Also, disabled the Windows Defender - that too did not help. The problem is clearly accessing the Tidal servers. I’ve reinstalled Roon Server and still no improvement.

What else can i try? iOS Tidal app via Shairport is working without any hitch … on the same network.

I also tried my Surface Pro 4 with Roon server - it too does not work. It was working well with my office wifi. So, clearly it is some internet setting/access issue.

@Eric @andybob @Rugby Well, as suddenly as this problem had come up, it has suddenly disappeared.

I tried playing through Roon and the Tidal desktop app today and both are working fine. I haven’t changed anything in the system (except switching on Squeezebox mode so that i could test it on my Iphone through iPeng). But, no change was made for the Tidal desktop app.

So, it appears that the issue was with my internet service provider or Tidal servers. I guess all that is fixed now.

1 Like

A post was split to a new topic: TIDAL content is being listed as “unavailable” in Roon