Tidal Not Working - Too Many Failures

Roon Server Machine

Mac Mini M1 16gb ram

Networking Gear & Setup Details

Ethernet connected from Mac Mini direct to router

Connected Audio Devices

Roon Bridge running on RPi. All connected via ethernet.

Number of Tracks in Library

50k+

Description of Issue

For the last couple of weeks Tidal does not want to play through Roon - “too many failures” is the error message. I have logged out/reconnected multiple times to Tidal, but this does not work. I have tried restarting the Mac Mini running server. My Tidal account works fine when using through Tidal app. No issues with updating payment, etc. Tidal had been working fine no issues up until this point.

All server, remote, and bridge softwares are up to date.

Note that Roon ARC seems to have no trouble with accessing and playing Tidal files.

Hi @Peter_Northcott,
Thank you for your patience while we worked through the queue. If you can provide the date, local time, and track playing when these failures happened I will activate diagnostics on your account and look into this further.

Hey @daniel these failures are not a one time thing and have been recurring for weeks/months now. I try every day or so to reset/reboot and try another Tidal track to play, so you should see in the diagnostics a rolling pattern of this.

I just triggered this now again at 5:56 EST Dec 29.

Let me know if you need more info, thanks.

Hi @Peter_Northcott,
Upon reviewing diagnostics at the time you specified it looks like you’re requests to tidal are timing out. This points to an unstable internet connection. We can confirm this by doing a ping test. Please follow the below steps to do this:

  • Press cmd + space bar to bring up quick access
  • Type terminal in the prompt that opens and select that option.
  • In the terminal type ping 8.8.8.8 then enter
  • Let it run for a few minutes and let me know the result.

Hi @daniel it’s still running (into the 1400s) - so I pasted a small sample here. Let me know if you need more data.

64 bytes from 8.8.8.8: icmp_seq=1290 ttl=116 time=5.891 ms

64 bytes from 8.8.8.8: icmp_seq=1291 ttl=116 time=6.286 ms

64 bytes from 8.8.8.8: icmp_seq=1292 ttl=116 time=8.396 ms

64 bytes from 8.8.8.8: icmp_seq=1293 ttl=116 time=5.709 ms

64 bytes from 8.8.8.8: icmp_seq=1294 ttl=116 time=37.205 ms

64 bytes from 8.8.8.8: icmp_seq=1295 ttl=116 time=11.172 ms

64 bytes from 8.8.8.8: icmp_seq=1296 ttl=116 time=29.410 ms

64 bytes from 8.8.8.8: icmp_seq=1297 ttl=116 time=6.627 ms

64 bytes from 8.8.8.8: icmp_seq=1298 ttl=116 time=5.740 ms

64 bytes from 8.8.8.8: icmp_seq=1299 ttl=116 time=5.485 ms

64 bytes from 8.8.8.8: icmp_seq=1300 ttl=116 time=30.086 ms

64 bytes from 8.8.8.8: icmp_seq=1301 ttl=116 time=19.866 ms

64 bytes from 8.8.8.8: icmp_seq=1302 ttl=116 time=5.831 ms

64 bytes from 8.8.8.8: icmp_seq=1303 ttl=116 time=8.432 ms

64 bytes from 8.8.8.8: icmp_seq=1304 ttl=116 time=4.541 ms

64 bytes from 8.8.8.8: icmp_seq=1305 ttl=116 time=4.667 ms

64 bytes from 8.8.8.8: icmp_seq=1306 ttl=116 time=25.226 ms

64 bytes from 8.8.8.8: icmp_seq=1307 ttl=116 time=5.655 ms

64 bytes from 8.8.8.8: icmp_seq=1308 ttl=116 time=7.544 ms

64 bytes from 8.8.8.8: icmp_seq=1309 ttl=116 time=7.844 ms

64 bytes from 8.8.8.8: icmp_seq=1310 ttl=116 time=5.968 ms

64 bytes from 8.8.8.8: icmp_seq=1311 ttl=116 time=9.358 ms

64 bytes from 8.8.8.8: icmp_seq=1312 ttl=116 time=6.621 ms

64 bytes from 8.8.8.8: icmp_seq=1313 ttl=116 time=5.999 ms

64 bytes from 8.8.8.8: icmp_seq=1314 ttl=116 time=49.265 ms

64 bytes from 8.8.8.8: icmp_seq=1315 ttl=116 time=6.387 ms

64 bytes from 8.8.8.8: icmp_seq=1316 ttl=116 time=7.418 ms

64 bytes from 8.8.8.8: icmp_seq=1317 ttl=116 time=5.863 ms

64 bytes from 8.8.8.8: icmp_seq=1318 ttl=116 time=6.422 ms

64 bytes from 8.8.8.8: icmp_seq=1319 ttl=116 time=9.280 ms

64 bytes from 8.8.8.8: icmp_seq=1320 ttl=116 time=5.131 ms

64 bytes from 8.8.8.8: icmp_seq=1321 ttl=116 time=5.750 ms

64 bytes from 8.8.8.8: icmp_seq=1322 ttl=116 time=31.614 ms

64 bytes from 8.8.8.8: icmp_seq=1323 ttl=116 time=12.115 ms

64 bytes from 8.8.8.8: icmp_seq=1324 ttl=116 time=39.390 ms

64 bytes from 8.8.8.8: icmp_seq=1325 ttl=116 time=5.321 ms

64 bytes from 8.8.8.8: icmp_seq=1326 ttl=116 time=14.486 ms

64 bytes from 8.8.8.8: icmp_seq=1327 ttl=116 time=7.043 ms

64 bytes from 8.8.8.8: icmp_seq=1328 ttl=116 time=5.832 ms

64 bytes from 8.8.8.8: icmp_seq=1329 ttl=116 time=9.281 ms

64 bytes from 8.8.8.8: icmp_seq=1330 ttl=116 time=5.932 ms

64 bytes from 8.8.8.8: icmp_seq=1331 ttl=116 time=5.337 ms

64 bytes from 8.8.8.8: icmp_seq=1332 ttl=116 time=22.744 ms

64 bytes from 8.8.8.8: icmp_seq=1333 ttl=116 time=8.966 ms

64 bytes from 8.8.8.8: icmp_seq=1334 ttl=116 time=6.065 ms

64 bytes from 8.8.8.8: icmp_seq=1335 ttl=116 time=9.014 ms

64 bytes from 8.8.8.8: icmp_seq=1336 ttl=116 time=7.460 ms

64 bytes from 8.8.8.8: icmp_seq=1337 ttl=116 time=11.130 ms

64 bytes from 8.8.8.8: icmp_seq=1338 ttl=116 time=6.428 ms

64 bytes from 8.8.8.8: icmp_seq=1339 ttl=116 time=6.095 ms

64 bytes from 8.8.8.8: icmp_seq=1340 ttl=116 time=5.665 ms

64 bytes from 8.8.8.8: icmp_seq=1341 ttl=116 time=5.504 ms

64 bytes from 8.8.8.8: icmp_seq=1342 ttl=116 time=6.031 ms

64 bytes from 8.8.8.8: icmp_seq=1343 ttl=116 time=8.154 ms

64 bytes from 8.8.8.8: icmp_seq=1344 ttl=116 time=39.886 ms

64 bytes from 8.8.8.8: icmp_seq=1345 ttl=116 time=8.553 ms

64 bytes from 8.8.8.8: icmp_seq=1346 ttl=116 time=5.523 ms

64 bytes from 8.8.8.8: icmp_seq=1347 ttl=116 time=32.844 ms

64 bytes from 8.8.8.8: icmp_seq=1348 ttl=116 time=6.419 ms

64 bytes from 8.8.8.8: icmp_seq=1349 ttl=116 time=14.967 ms

64 bytes from 8.8.8.8: icmp_seq=1350 ttl=116 time=6.696 ms

64 bytes from 8.8.8.8: icmp_seq=1351 ttl=116 time=6.680 ms

64 bytes from 8.8.8.8: icmp_seq=1352 ttl=116 time=24.266 ms

64 bytes from 8.8.8.8: icmp_seq=1353 ttl=116 time=9.533 ms

64 bytes from 8.8.8.8: icmp_seq=1354 ttl=116 time=6.457 ms

64 bytes from 8.8.8.8: icmp_seq=1355 ttl=116 time=8.287 ms

64 bytes from 8.8.8.8: icmp_seq=1356 ttl=116 time=6.733 ms

64 bytes from 8.8.8.8: icmp_seq=1357 ttl=116 time=10.432 ms

64 bytes from 8.8.8.8: icmp_seq=1358 ttl=116 time=5.567 ms

64 bytes from 8.8.8.8: icmp_seq=1359 ttl=116 time=5.334 ms

64 bytes from 8.8.8.8: icmp_seq=1360 ttl=116 time=6.239 ms

64 bytes from 8.8.8.8: icmp_seq=1361 ttl=116 time=6.326 ms

64 bytes from 8.8.8.8: icmp_seq=1362 ttl=116 time=6.902 ms

64 bytes from 8.8.8.8: icmp_seq=1363 ttl=116 time=6.089 ms

64 bytes from 8.8.8.8: icmp_seq=1364 ttl=116 time=6.564 ms

64 bytes from 8.8.8.8: icmp_seq=1365 ttl=116 time=7.214 ms

64 bytes from 8.8.8.8: icmp_seq=1366 ttl=116 time=6.333 ms

64 bytes from 8.8.8.8: icmp_seq=1367 ttl=116 time=7.109 ms

64 bytes from 8.8.8.8: icmp_seq=1368 ttl=116 time=6.494 ms

64 bytes from 8.8.8.8: icmp_seq=1369 ttl=116 time=8.776 ms

64 bytes from 8.8.8.8: icmp_seq=1370 ttl=116 time=6.711 ms

64 bytes from 8.8.8.8: icmp_seq=1371 ttl=116 time=6.614 ms

64 bytes from 8.8.8.8: icmp_seq=1372 ttl=116 time=16.880 ms

64 bytes from 8.8.8.8: icmp_seq=1373 ttl=116 time=10.226 ms

64 bytes from 8.8.8.8: icmp_seq=1374 ttl=116 time=6.668 ms

64 bytes from 8.8.8.8: icmp_seq=1375 ttl=116 time=6.074 ms

64 bytes from 8.8.8.8: icmp_seq=1376 ttl=116 time=6.785 ms

64 bytes from 8.8.8.8: icmp_seq=1377 ttl=116 time=10.720 ms

64 bytes from 8.8.8.8: icmp_seq=1378 ttl=116 time=8.140 ms

64 bytes from 8.8.8.8: icmp_seq=1379 ttl=116 time=7.367 ms

64 bytes from 8.8.8.8: icmp_seq=1380 ttl=116 time=10.357 ms

Press ctrl + c to stop it and it should give a summary at the end of any packet loss.

2642 packets transmitted, 2642 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 3.885/10.759/243.707/12.391 ms

Any update on the analysis of this @daniel ?

Hi @Peter_Northcott,
I brought your case to the rest of the team and there are some more diagnostics questions I would like to ask and some possible troubleshooting steps. Try playing a song in low quality and the same song in mqa and note the difference. Also, are these tracks in playlists in Roon? Can you try logging out of and back into Tidal in the Roon client and also clear out the cache? Does Tidal work on ARC?

@daniel

“Try playing a song in low quality and the same song in mqa and note the difference.”

  • I can’t play any tidal songs through Roon - so cannot test this. I can play both hi res/low quality when playing directly in Tidal and ARC. I did update the settings just now in Roon for making Tidal use ‘normal’ quality - but this had no impact - could still not play.

“Also, are these tracks in playlists in Roon?”

  • Some are in playlists, but most are just albums I add to my collections - and then I cannot play any of them. I can search and add to my collection - but cannot play any of them.

“Can you try logging out of and back into Tidal in the Roon client”

  • yes have done this multiple times already. Did so on the Tidal app, as well.

“and also clear out the cache?”

  • I just did this via Settings>Setup - but no change after it restarted

“Does Tidal work on ARC?”

  • just retested this, and yes, it still works for any/all Tidal tracks via ARC

Followup @daniel - is there any direct tech support now from the Roon team? This seems to be lagging quite a bit. Looking forward to getting this resolved as I am continuing to pay monthly Tidal fees which are wasted if I cant use it within Roon.

Sorry for the delayed response. Your issue is a bit complicated so I’ve had to work with the rest of the team on it. So it looks like you’re receiving a 403 or “forbidden” response from Tidal when requesting certain tracks. This may mean you are requesting tracks from Tidal Max. Can you check if your Tidal subscription includes Max? Another test is to open the terminal and type ping sp-pr-cf.audio.tidal.com followed by enter.

hey @daniel I have the HiFi subscription and have been unable to play the 16bit files. Those fail as well.
image

From terminal

2 posts were split to a new topic: Tidal and Roon problems

Okay let’s try resetting your server using the instructions below.

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

If that doesn’t solve your problem I have two more questions to ask:

  1. I know you said you can play songs from Tidal directly. Is this through the same MacMini that your Roon server is on?
  2. Are you using a private IP address?

Hi @daniel I did the fresh install of Roon on the Mac Mini to replace the existing install. On restart of Roon, Tidal tracks started to function. I have not restored the backup yet. But this fresh install seems to have solved the problem at the moment. I will restore from back and report if any further issues. Thanks.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.