Tidal not working with Hughesnet satellite ISP

I use ROON with Tidal embedded in two different homes with 2 different stereo systems and dedicated servers. The difference is one home has cable internet and the other satellite internet. Cable internet works great, but the home with satellite ROON controls my own library fine but when I select Tidal the interface functions and looks fine. However when I select a Tidal song a blue light travels back and forth on the timer on the bottom of the screen like it is loading then eventually stops but it never plays the song. Instead it will do the same thing on the next couple of songs if I’ve selected a whole album then flash an error message " Transport too many failures stopping playback" My antipodes server is connected to the satellite modem via a 20 foot high quality ethernet cable. I have spent a lot of time on the phone with Hughsnet changing there settings but no sucess

Bill Rooney

Probably, the download speed of the satellite link is too slow.

No I get a consistent 45mbps

Hi Bill,

Are you able to stream Tidal using the Tidal app?

Cheers, Greg

I have a read that satellite will burst well for fast loading web pages but it does not maintain speed for sustained streaming or downloading.

Hi @william_rooney, your Roon Server log that you sent me shows multiple ‘Corrupt Media’ messages:

08/25 07:37:32 Error: [seekableurimediafile] while determining length: System.IO.IOException: streaming media failed due to network
at Sooloos.Media.StreamingMediaFileImpl.get_Length () [0x00038] in <23acf53cc9eb42139351d2f667c77e76>:0
at Sooloos.Media.StreamingMediaFile.get_Length () [0x00000] in <23acf53cc9eb42139351d2f667c77e76>:0
at Sooloos.Media.CachingSeekableUriMediaFile.LengthCallback (System.IntPtr userdata, System.Int64& out_length) [0x00017] in <23acf53cc9eb42139351d2f667c77e76>:0
08/25 07:37:32 Warn: [zoneplayer] Corrupt Media Detected
08/25 07:37:32 Info: [Bill] [zoneplayer] Open Result (Playing):Result[Status=CorruptMedia]
08/25 07:37:32 Trace: [Bill] [Inactive] [LOADING @ 0:00] Mirror, Mirror - Amanda Shires
08/25 07:37:32 Warn: [zoneplayer] couldn’t play URL http://ab-pr-ak.audio.tidal.com/72562ef92bde80e2d88f1829ab6bffa9_26.flac?token=exp=1535200636~hmac=d1b0313b1027189658f3f5df4b8f3295eaa66b29e2b06c8dd188cadcf7a9773e: corrupt media
08/25 07:37:32 Warn: Track Stopped Due to Bad Media
08/25 07:37:32 Info: [zone Bill] OnPlayFeedback StoppedEndOfMediaUnnatural
08/25 07:37:32 Info: [zone Bill] OnPlayFeedback Stopped
08/25 07:37:32 Trace: [Bill] [Inactive] [STOPPED @ 0:00] Mirror, Mirror - Amanda Shires

I suggest you raise a Roon Support ticket.

Yesterday I was able to play Tidal files in Roon after I changed a setting in Hughesnet. It is a setting that restricts video to 480p to prevent you from using up the monthly data allotment too quickly when Streaming HD video.

Another thing I did was to download the Tidal app, because of a question by Greg in this forum… I was able to stream music to my Iphone, so then I turned on the Antipodes DX server and it played music through my HiFi system

I haven’t been able to do so for months. Additionally I haven’t been able to stream Netflix for more than 15 minutes at a time since I had the Hughesnet system installed 9 months ago

I’ll have to do some more testing with Tidal and Netflix today.

Hopefully it keeps working, but I’m still not sure why?


How do I get a tech service person from Roon to look at this topic and examine the log from Roon server? Tony suggests opening a service ticket, but I’m not sure how?


You can tag @support, so they’ll get notified.

I’m not sure where or how to do that?

could the support team please reply t this post and the error log from Antipodes support

Hello @william_rooney,

Thanks for contacting support, I’d be happy to take a look over this issue with you. Just so that we have all the necessary information for a report, can you please provide the model/manufacturer of the computer running your Roon Core?

Generally speaking, satellite ISPs such as Hughsnet have a large Latency, meaning that the time for the internet file/stream to reach Roon is much greater than it would be with land-based connections, this can sometimes cause issues when Roon attempts to download the next “piece” of the track and TIDAL takes too long in replying due to the Latency of the internet connection.

I would also take a look at our networking best practices guide to see if there are any additional settings you can enable on that router for better performance, would you be able to please provide the exact model/manufacturer of your Hughsnet Router?

Please let me know when possible and we can continue troubleshooting from there.


Hi Noris

I had contacted Tidal tech support and Hughesnet support too about this issue. Hughesnet had me change some settings on the Hughes HT2000W router without fixing the problem. Tidal told me to log out of Tidal and log back in. When one of the members asked if I had the same problem with the Tidal app I downloaded the app to my IPhone and logged in after download. I had no trouble listening to music and it was streaming through the satellite. When I urned on my Antipodes DX music server( runs Roon core), everything worked fine and I could stream Tidal. This occurred before I go the reply from Tidal so I guess that I inadvertently fixed the problem when I downloaded and logged in to my account. There is a couple of second delay when I select a song before it plays, but other than that it seems to be OK.

Please let me know if there are other settings to change on the Hughes HT2000W


Hello @william_rooney,

Just to confirm, the problem has since gone away in Roon after you have logged out of TIDAL and have logged back in? Or has the issue only gone away when using the TIDAL app on your iPhone? If the issue has gone away I would leave the setup as is.

It is possible that the streaming of the track was working fine using a lower quality version of the track and then fail to work properly when using higher-quality tracks from within Roon.

One other thing that you can do if you are still experiencing issues with TIDAL within Roon is clearing the TIDAL cache. To do so you can use the following steps:

  • Quit Roon
  • Find and open your Roon folder
  • Locate and delete only the cache folder (Roon/Cache)
  • Restart Roon

I have not been able to find much information regarding that router’s specific settings but if you are still experiencing issues I would take a look at “Multicast Settings”, but to reiterate again, if the system is currently working fine I would not edit any other router settings nor clear the TIDAL cache.


Yes it worked withTidal through Roon on my server as well as the tidal app on my IPhone. MQA palys too just takes a few seconds more to load

I never had a problem with my personal library on Roon just Tidal tracks

I see an option in Roon’s setup menu to clear image cache. Is this the one you mean?


Hello @william_rooney,

If it is working fine now you do not need to clear the cache, that is just a troubleshooting option if the playback does not work again. The option would not be listed in Roon itself, you would have to manually access the Roon folder but as I mentioned, your issue seems to be resolved at this point so I would not change any setup settings for the time being.

I would leave your system as is and verify how playback works over the next few days. If you have any other issues please let me know, otherwise I would just use Roon as normal.


Hi Noris

Tidal worked fine in Roon yesterday, now today it is back to not working with the same symptoms as I previously described in this post. I did the exact same steps as I did yesterday to get it working again but no dice. i’m scratching my head as to what’s going on?
The tidal app on my cell phone did work today but not on my server using Roon

Hello @william_rooney,

Since the setup worked yesterday and it is not working today anymore, signs are pointing to the network connection.

There is one setting on the Hughsnet Router that you can try, if you can log on to the router and edit the DNS settings, I would point the DNS to Google’s DNS just to make sure that Hughsnet DNS service is not causing the issues here. The page you are looking for on the Router looks like this:


You would need to uncheck that box that says “Obtain from ISP” and I recommend that you try: as the primary DNS as the secondary DNS
These DNS servers are obtained directly from Google’s public DNS

Please let me know if that Router DNS change helps the streaming stability.


Hi Noris

I tried it but it didn’t work. It stopped my computer from getting on the net so I changed it back. Tidal not working on my music server again today, but it works on the mobil app on my IPhone

Hello @william_rooney,

Sorry to hear that the DNS change didn’t work. Do you by any chance have another device around the house and can confirm that the TIDAL app streams works outside of Roon with? Something like a Bluesound Node2, SONOS device, or Apple TV with the TIDAL app installed would be a good data point in seeing if something is going wrong on the network side of things.

I would also try streaming different quality albums (FLAC vs AAC vs Lower Bitrate tracks) to see if that is a limitation in itself. Please let me know your findings if you are able to perform this test.