Tidal pausing and skipping

Roon Core Machine

I have a Nucleus core connected to a 2021 iMac and the wireless speakers are Bowers & Wilkins Formation Duo. I updated to the latest core firmware today.

Networking Gear & Setup Details

The computer and Nucleus are connected to Spectrum internet via ethernet. I have Orbi AC4200 mesh WiFi, wireless download speed is about 450 mbps.

Connected Audio Devices

Formation Duo speakers are wireless.

Number of Tracks in Library

3,800 tracks

Description of Issue

Hi, when playing playlists and albums from Tidal, the songs are pausing multiple times, then skipping to the next song. I get a message saying something like “Tidal is slow loading and there could be a connection issue.” This hadn’t happened before but now is continuous. When I play the same Tidal music via the Tidal app or Bowers & Wilkins app it works fine, so the issue is Roon-related. I am not expert on computers so reading posts in the Roon community with similar problems wasn’t much help.

Also, I’ve tried rebooting the Nucleus, iMac, speakers and iphone, but nothing has helped.

I encountered a similar issue this week. I am running Roon ROCK on a NUC-I5 streaming to a Cambridge Audio CXN. Whether I am streaming music from Qobuz or from an SSD drive attached to the NUC, I started noticing that the music would pause, mid-stream, and then continue after a second or two or would just move to the next song. This afternoon it was happening every 10 mins or so. This just started after the most recent s/w update (ROCK 1.8, buIld 903).

I have also been suffering from this for a couple of weeks now. I run three systems based on Sonictransporters and they have been 100% rock solid for years. Now it is hard to get it to play at all as it just keeps saying that every track is unavailable on Tidal then skips then says too many errors. It does this when I pause a track and restart it. I doubt Tidal just removed the track that instant.

Sonictransporter - Sonore Optical Rendu - Chord TT2 DAC with MScaler. All ethernet using Ubiquiti networking throughout

I encounter similar issues since last update. I have a Roon Nucleus and stream to an Auralic Altair G1. I stream from Qobuz and now and then some tracks from the SSD inside the Roon Nucleus. Tracks will stop playing for a second or two and then remain playing or I have to restart the track manually. Very annoying. Problem occurs both when streaming from Qobuz or from internal SSD.
When streaming directly from Qobuz to Altair, so without Roon, no problems at all. Therefor I also address this problem to Roon…

I’m having the same “Tidal is running slowly” issue and Roon skips to the next song. I have the Roon Nucleus, ethernet cable (audio quality) connected directly to my router. I get 900 Mbps. One of my speakers is also connected via ethernet to the router. The other speaker is over the Wi-Fi, which is probably around 700 Mbps (speed test on my Macbook Pro).

I have also experienced this over the last couple of days - also last week, but I think that was due to a larger cloud outage. Just logged out of Tidal everywhere then rebooted core and remote and logged back in and it seems to be OK (for now…).

I had issues with TIDAL MQA tracks played through Roon kicking out of MQA and into PCM, as indicated by my DAC (iFi xDSD Gryphon). After only a few seconds, they’d go back into MQA, and then repeat the cycle.

For the solution, I had a similar experience as @Rockhound.

Signing out, signing back in, rebooting my MacBook Pro core and restarting Roon (in no particular order) seemed to fix the skipping/format shifting.

1 Like

I too have had this issue. I set DNS to the recommended ones. Latest build (911) made this worse. I wrote a thread about it today.

I’m still having this problem. I restarted my Roon Nucleus and logged out of Tidal. No love… Just about every song drops and then skips to the next one. Super frustrating.

There’s your problem, you should be using a data quality ethernet cable.

Does it do the same thing when you try to play from local files?

Data quality? Such as? I am using a high end QED ethernet cable. Surely that is enough?

No, just when streaming from tidal and radio stations. With radio stations, I get a message that says something like the internet address may have changed… Cheers

Hi Roon Technical support. Any feedback please? I am still having issues with both Tidal and when streaming radio. I find it hard to believe it is my network given how simple my setup is. As mentioned above, I have the Roon Nucleus connected directly to my router on a QED Performance Ethernet Cable Graphite. I have fibre to the premise and get 900Mbps. I should not (could not) have any latency or capacity issues. Yet, songs constantly skip from one to the next when streaming Tidal and Radio streaming drops constantly.

Have you upgraded to 913 - that seems to have fixed it for some users? Also, have you set the DNS server in your router to point to Cloudflare ( - this also helps some users?

Thanks, I have the latest version (913) and just pointed my DNS to Cloudfare. I will test for a few days and get back to you.

1 Like

Just an update. In addition to pointing my DNS to Cloudfare, I purchased a better (high end) router. After 4 days of listening to music via Tidal and streaming various radio stations, I have had no problems whatsoever. Music is playing smoothly. Not sure if it was my router or the DNS, but problem solved.


Great to hear you got it sorted Nick. Probably a combination of solid DNS and decent router. Enjoy the music!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.