Tidal Play issue through Nucleus

Hi I’m sandro and I need @support.
After the new 1.6 release I’ve problem playing Tidal tracks.
Clicking the PLAY button produces no action !
Every other function is ok; selecting album, selecting tracks, skipping tracks, adding tracks to playlist,…

No issue playing my files (via usb pendrive)
No issue playng tidal tracks by a different core (in my windows PC).
No issue playing Tidal (by its direct app)
I’ve already tried:

  • disconnect and reconnect (roon and tidal)
  • reinstall the operating system
  • reset the settings
  • restart the roon server sosftware
  • tried to change the dns by dnsjumper (selected US open DNS, the faster)

My setup is made by:

  • Core NUCLEUS (1 month age)
  • PC HP Zbook with Windows 10
  • Ipad pro as endpoint
  • Samsung galaxy S7 (andoid 8.0.0)
  • MSB platinum 4 DAC

Please help me to solve the problem.
many thanks

Hi @sandro_loreti,

Thanks for contacting us regarding this issue. I am not sure if the DNS change to DNSJumper might have affected you here, I have not heard of this service before.

Can you please try using Google DNS or Cloudflare DNS instead? Also where are you configuring this DNS Server, is it in your Router or in the Nucleus WebUI?


Hi Noris, thanks for your reply.
I have tried past days to configure that DNS Server in the Nucleus WebUI, but apparently without success as Tidal was still not working. Today, after the week end where I was not at home and the set up not in use , Tidal is working fine again. I have just unplugged the Nucleus, waited some minutes and restarted. Clearly I have gone through that operation several times in the past days , just now is working.
I don’t really know if the issue is definitely solved, will keep you up to date.

1 Like

Thanks for the update @sandro_loreti. Just as a warning, I would be very careful with having the Nucleus on static IP since you can run into issues if the IP address you specified is assigned to another device on your network.

A better practice would be to set the Nucleus as a “Reserved IP address” in your router configuration and change the DNS servers in the Router and not the Nucleus. If it’s working as expected you can leave it as-is but this is just something to be aware of, especially if you ever switch networks and the subnet range changes as this can lead to loss of communication with the Nucleus.

– Noris