Tidal playback hangs after resume [with workaround] - Roon 1.8 build 783 macOS

Context

I’m currently playing with trial roon version before bying dedicated hardware and permanent license. I’m experimenting with Mac and Win version, but thinking of NUC and ROCK as a target configuration.
Overall impression is very good including usability, features and sound. The only doubt is about quality and stability of the product. Sometimes it’s minor glitches that go away after roon restart, but sometimes it takes more time to get rid of. Following is a description of one case I faced with on Mac, with workaround.

Core Machine (Operating system/System info/Roon build number)

MacBook Air 2020 M1 / macOS BugSur 11.2.3 / Roon 1.8 build 783

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

  1. TP-Link Archer AX90, 2. D-Link DIR-300.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  1. Cary DMS-600, Ethernet. 2. MacBook system audio.

Description Of Issue

On Mac, after pausing Tidal tracks and waiting for 10-15 seconds I cannot resume playback quickly. After pressing “play” it takes up to one minute before it starts to play. As it seems to me, the problem appeared out of the blue. The only thing I did: logged out from Tidal on Win laptop, switched back to Mac and deauthorized Win laptop.

I tried to:

  • relogin to Tidal
  • reboot everything
  • strip down roon configuration turning off DSP, upsamping, roon radio, lyrics and album info
  • switch from network player to Mac speakers
  • switch from Ethernet to WiFi and back
  • replace router
  • completely uninstall roon and install it again from scratch

No effect. The problem still persisted. Resource monitor in OS shows no significant CPU load or heavy network traffic but roon keeps silence. Then after a long pause it starts to play by itself. At the same time Tidal played perfectly on the network player (it has it’s own Tidal support) and on the laptop via Tidal web app, both of them connected to the same network.

Workaround

At that point my wife came to a rescue. Try to play local file, not Tidal, she said. I followed her advice (as I always do). Local file played with no hangs after resume, as expected. But it also solved the initial problem with Tidal. Just after playing back local file I tried Tidal again, and could not reproduce the problem. Gosh, how it can be!

Conclusion

At the moment everything seems to be OK. At least, I have workaround. And my wife once again confirmed that she is my best support. But I think it’s a good idea to report this issue also to Roon Support because I hope it may help the developers in future bugfixing.

Regards,
Alex

1 Like