TIDAL Playback Issues - "This Tracks is not currently available from TIDAL"

@support - getting this very issue all day today with various songs.

Examples include “Touch, Peel and Stand” - Days of the New, “Possum Kingdom” - The Toadies, and many others from various playlists that Roon is supporting for me via Tidal.

To answer the usual support questions - Yes my Internet is working great, I am running the latest version of Roon, Yes I can play these songs seamlessly on Tidal’s desktop and phone apps, and no, when I select my Zone as just the PC itself the songs STILL will not play with the error message to start this thread.

To the notion that Roon can lag a day or two behind Tidal - no these are not new tracks. They have been on my playlists since before I even tried Roon and basically since Tidal became available in NA. I have played them extensively on Tidal and Roon in the past year.

The issues are really piling up here for me and my subscription (which was only one-year in case of this or if I changed equipment) is about to expire, so maybe I’ve dodged a bullet. I don’t want to minimize this - I am incredibly frustrated and annoyed with Roon. It has “Rooned” several parties (OK that was not very nice of me and I exaggerate, but it caused some real issues and actual embarrassment after my own unnecessary bragging about your system) and I have problems with the software on a daily or every-other-day basis, always when Tidal is working fine and my Internet speeds (to this laptop WiFi >50MBPS, LAN >200MPBS) are just dandy.

Oh yeah here’s another edit - In just a few of these cases, the SONG PLAYS ANYWAY (for example today “Sex and Candy” - Marcy Playground), even while the message stays on the screen. But others don’t play.

Any fixes that I am unaware of? Feel free to pull my logs or whatever you might need to do in order to assess.

Hi @casey_cook,

I just tried playing “Touch, Peel and Stand”, “Sex and Candy”, and “Possum Kingdom” without issues on my end.

I understand you are frustrated here, but I believe you might be having some deeper PC issues here as I mentioned in the last active thread you have with us:

I am looking through the diagnostics from your Core for a few of these attempts and when you tried playing Touch, peel and Stand, I see that there was a TIDAL account error at this time and it’s showing you as unauthorized to play this track:

04/13 19:19:01 Trace: [Living Room] [Lossless, 16/44 TIDAL FLAC => 16/44] [100% buf] [STOPPED @ 0:00] Touch, Peel and Stand - Days of the New
04/13 19:19:01 Trace: [Living Room] [Lossless, 16/44 TIDAL FLAC => 16/44] [100% buf] [LOADING @ 0:00] Touch, Peel and Stand - Days of the New
4/13 19:19:01 Warn: [tidal/media] could not get playback info for 168:0:6551546: Result[Status=Unauthorized]
04/13 19:19:01 Info: Alert: TIDAL: tidal_account_error
04/13 19:19:01 Info: Alert: TIDAL: tidal_account_error
04/13 19:19:01 Warn: [tidal/media] could not get playback info for 168:0:6551547: Result[Status=Unauthorized]
04/13 19:19:01 Info: Alert: TIDAL: tidal_account_error
04/13 19:19:01 Info: Alert: TIDAL: tidal_account_error

My follow-up question here is, are you only unable to play this track if you start it from the playlist, or is the behavior the same if you search for it and try playing it that way? Are you still unable to play these tracks even now or are you still being presented with the “Track not currently available from TIDAL error message”? Can you share a screenshot of the “File Tag” info for this track? This can be accessed by right-clicking the track -> Edit -> File Tags and should look something like this:


Tidal account error? Unauthorized to play the track? Is this something you’ve ever seen before? Obviously that is not the case.

Yes there were several others on that playlist that would not play yesterday - or would provide the same error but then play anyway while the error message hung in the air (popup) over the play section of Roon.

Did anyone else report similar issues yesterday? I’m willing to accept that it has SOMETHING to do with Tidal, but again I was logged into Tidal and it worked fine using their desktop app at the same time your software was giving me the error message.

OK - I also just now checked - it’s STILL not playing that song at the very least (Touch Peel and Stand). What gives guys? I just opened Tidal desktop and it plays fine.

To answer your earlier question about that playlist, again today it’s still doing the same thing and Roon skips over both Days of the New tracks in that list and plays Rage Against the Machine.

Here’s a slight update. I had only tried playing the song from my playlist, both within Tidal’s app and Roon. I had not tried to go straight to the band and album via Tidal OR Roon. When I did that, however, and went BACK to the playlist, in Tidal, it was then greyed out. Literally just that song. SO I re-added it to my playlist (in Tidal but you can see it down at the bottom now in Roon and Tidal) and it plays fine! And also NOW the song immediately after plays fine too (doesn’t skip straight to Rage Against the Machine if I click on “Shelf in the Room” which is the 2nd of two Days of the New songs in that playlist).

Just in case I reset my Tidal password and edited my Tidal login info in Roon. Then I went back to the playlist in Tidal and Roon. In Tidal it was still grayed out, so I went straight to the album and played the song and it worked fine. As mentioned above I readded it to my playlist (at the bottom as stated) and it plays fine in that position in both Tidal and Roon. However when I attempt playback from its original position/place in my list it still registers the same error in both Tidal (actually just greyed out as if not available) and Roon (same error message as before).

Very strange. Any idea what could be going on?

Bottom pic is the Tidal display for this list and the top pic is Roon. As you can see, in Roon there is no indication that the song is unplayable OTHER THAN the fact that the album cover is blacked out. In Tidal the whole song is greyed out.

FWIW, in the top pic (Roon) I had tried to play “Hey Man Nice Shot” by Filter and the Roon error popped up and then it skipped to “Sex and Candy”.

Now everybody is aware of my horrible taste in music. Thanks guys. :wink:

As far as deeper PC issues, I’m willing to accept that explanation for the OTHER thread - where the system totally freezes up - BUT - in that case (will update there later) the ONLY apps/programs where this happens are when I am sharing a screen to a wireless display and a movie is playing via MPC player - OR - using Roon. Have never tried both of those at the same time, so they are not related insofar as the Roon freeze being caused by the wireless monitor sharing.

However, for this issue, that seems very unlikely given that it only affects a few songs (that I’ve tried) and it appears that it’s some bizarre combination of Roon and Tidal - mainly the latter given that for some crazy reason these tracks now appear as unavailable ONLY on my playlists in both Roon and Tidal, but when re-added from their respective albums within Tidal they play fine and propagate over to Roon fine, just not from/in the original position in my playlist.

And for the other ongoing issue - namely, being simply unable to play some songs on some days and cutouts, I’m pretty sure that’s on you guys and how your software interacts with Tidal - or your server’s ability to stay up and connected.

It could be that Tidal changed the ID of that album/track. When you add a track from tidal to a playlist, I think that it references that specific Tidal ID. If Tidal changes the track or album ID on their side, then that track reference points to an unused deprecated ID. That would explain why you play the track and add the track again, it plays but the original add is still treated as not there.

Hi @Casey_cook,

I just wanted to touch base with you here.

We’ve made a few server-side changes that may help in cases like this. You’ll need to restart your Core in order to pick up the changes, but I’d be interested to see if you note an improvement once you do.

Obviously, we are still investigating this issue, but please let me know how it goes and we’ll keep working until we get to the bottom of this.


A post was split to a new topic: Unable to play TIDAL Content

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.