Tidal playback issues

Flagging @support as I’m getting much more frequent TIDAL issues. No issues with local files by the way. Or with the TIDAL app for that matter.

The issue

The dreaded “TIDAL media is loading slowly. This may indicate a network problem” (I doubt it) and “This track is currently not available on TIDAL” (yes it is). I haven’t had these issues for years. Now I’m getting them almost every day. Around the time of the 1.6 release, but that may very well be a coincidence.

My setup

My entire network is wired with cat6 cables. My ISP provides a 1Gbps connection (effective speeds around 750-950 Mbps). For more detailed info about my setup, see the diagram below. The networking equipment is 1x Ubiquity USG -3P and 2x USG-8-60W.


Things that I have tried so far:

  • Rebooting all devices (networking equipment, totaldac, nucleus, …)
  • Using direct USB connection between totaldac and nucleus
  • Clearing Tidal cache on the nucleus (multiple times)
  • Switching out the router and switches with Linksys devices (unmanaged)

What surprises me is that for a given track it often stops around the same time, even after clearing the cache. If it really were a networking issue, I would expect it to be more randomly. With certain tracks I can almost always reproduce the problem, with other tracks (from the same album) it will work like a charm. And again, I’m clearing the cache for this to be sure there’s no cache corruption.

Do you use the apples as endpoints?

Hello @Nepherte,

Thanks for contacting us regarding this issue and for letting me know all the above information. If you are being presented with the TIDAL media is loading slowly message I would start with some network troubleshooting here, I have a few suggestions:

  • Let’s actually verify that the network connection is not dropping on that switch. Can you please connect your Macbook to the same switch that the Nucleus is on and then have a continuous ping test running in the background, see if there are any network timeouts when music stops playing?

  • You mention that you have a Synology DS713 connected to the same switch as the Nucleus. If you temporarily host your Roon Core on that machine, do you still experience the same issue?

  • You seem to be routing the network chain through multiple switches, if you connect just the Nucleus and the TotalDAC via USB to the primary router or the first switch immediately after the router, do you still experience this issue?

I look forward to hearing your findings.


Strictly as remotes. But for the sake of debugging, I’ll be using the Macbook Pro as the core and an endpoint to eliminate possible causes.

@noris: will get back to you when the issue presents itself again.

  • Sure thing. I can ping both wired from the second switch and wireless through the access point. That should help determine if there’s an issue higher up or at the end of the second switch.
  • I’ll probably run the core on the Macbook Pro instead of the Synology. I can easily wire it to the same switch.
  • The router and first switch are in a really confined / isolated space and it would not be possible to move things around. I may have a network cable long enough to go straight from the router to the nucleus.

That being said, I did replace all my networking gear already as a first test (see my original post). Only thing I haven’t tried is replacing the cables.

@Nepherte Bart try running a trace route to tidal…maybe you are in some weird routing due a network outage that the isp might have be inflicting on you. Did you reboot the modem too…maybe drop it off the air for about 10-qt mins.

Viewqwest I’m getting something like this but after 25+ hops I stopped.

So far no issues to report. Perhaps Murphie is involved here. I’ll chalk it up to an ISP or Tidal issue until further notice :slight_smile:

1 Like

Glad to hear that @Nepherte! If you experience any other issues regarding this topic don’t hesitate to reach out to me and we can re-open this thread.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @Nepherte,

Just opened this thread back up as per your request via private message. One other thing that I thought would be useful in checking here – is your Nucleus OS up to date? We have recently released a Nucleus firmware update and you can check to see if you have it on the newest version by navigating to Roon Settings -> About from one of your Roon Remotes.


The software is up to date. I did update the Nucleus (Roon OS B174) and the issue persisted even after the update.

Just took me 20 secs plus to load the tidal latest albums list. Seems to be playing ok for me tho now.

Also seen some posts on another local forum here that tidal has been struggling with delays playing and loading too…some roon users there too and Qobuz


The issues re-appeared on consecutive evenings, so I was able to do some further troubleshooting. For future reference, I’m always using the latest versions (Roon 1.6 B401 and Roon OS 1.0 B174).

I can mention that so far the issues only occurred in the evenings (somewhere between 21:00 and 22:00). And did so for a very short time (matter of a few minutes). After that it simply disappears.

Aside from the setup as described in the earlier diagram. I’ve tried a few alternative setups as to eliminate hardware and networking issues. From here on now, the setup is:

  • Roon (Core + Output) on Macbook Pro 13" hardwired directly to the router.
  • Roon (Core + Output) on Macbook Pro 13" wireless to the router.

I’ve used multiple routers to make sure the router is not to blame. The routers that were used are UniFi USG 3P, Linksys LRT214 and Linksys EA7500 AC1900. I think it’s safe to say it’s not the router.

I’ve used multiple Cores (Nucleus+, Macbook Pro), multiple Outputs (Nucleus+, Macbook Pro, UltraRendu) and DACs (Macbook Pro, Totaldac). I think it’s safe to say those are not at fault either.

When the Tidal playback issues occurred, I collected some information you requested:

  • Continuous ping to google.com (0.0% packet loss on 5000 packets)
  • Switched between various Core and Output devices (as described earlier)
  • Went straight from router to Core+Output (as described earlier)

Taking the above into account, I’m inclined to say that:

  • It’s not a local networking problem (ie. minimal network setup of 1 router, swapped router hardware, switches between cabled and wireless to eliminate faulty cable).
  • It’s not a audio hardware issue (ie. different combinations of Cores, Outputs and DACS)

It could still very well be the following:

  • Upstream networking issue (think along the lines of ISP or Tidal).
  • Software issue with Roon (definitely not meant as to blame you guys).

I can’t help but notice that even when Roon is having these Tidal playback issues, the official Tidal App has no such problems when playing at the very same time and from the very same devices using the very same tracks (using different logins made possible via Tidal Family subscription). So if it were an upstream networking issue, Tidal App seems to be more resilient to it. Perhaps a different buffering strategy? That being said, I remember having the native Tidal App go bad a few months ago as well, so it may very well be a coincidence.

Excerpt from the logs:

03/07 14:28:35 Debug: [prebuffer] sleeping in read -- this isn't good
03/07 14:28:37 Trace: [Nucleus] [Lossless, 16/44 TIDAL FLAC => 16/44] [PLAYING @ 0:05/3:58] Like That - Chase & Status / Moko
03/07 14:28:38 Info: [Nucleus] [zoneplayer] Open result (Queueing): Result[Status=Success]
03/07 14:28:38 Trace: [streamingmediafile] immediate read of http://ab-pr-ak.audio.tidal.com/88592622/ef3da3426e3a91f4cb6e5ebba3ca781a_26.flac at 393216 length=38370205
03/07 14:28:38 Info: [stats] 2359mb Virtual, 298mb Physical, 61mb Managed, 0 Handles, 73 Threads
03/07 14:28:38 Trace: [XMOS USB Audio 2.0] [raatclient] GOT [37] {"status":"Dropout","samples":13608}
03/07 14:28:39 Trace: [XMOS USB Audio 2.0] [raatclient] GOT [37] {"status":"Dropout","samples":22050}
03/07 14:28:39 Debug: [prebuffer] sleeping in read -- this isn't good
03/07 14:28:39 Trace: [XMOS USB Audio 2.0] [raatclient] GOT [37] {"status":"Dropout","samples":22050}
03/07 14:28:40 Trace: [XMOS USB Audio 2.0] [raatclient] GOT [37] {"status":"Dropout","samples":22050}
03/07 14:28:40 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/276 sec
03/07 14:28:40 Trace: [XMOS USB Audio 2.0] [raatclient] GOT [37] {"status":"Dropout","samples":22050}
03/07 14:28:41 Trace: [XMOS USB Audio 2.0] [raatclient] GOT [37] {"status":"Dropout","samples":22050}
03/07 14:28:41 Trace: [XMOS USB Audio 2.0] [raatclient] GOT [37] {"status":"Dropout","samples":22050}
03/07 14:28:41 Warn: [Nucleus] [zoneplayer/raat] Too many dropouts (>3s dropped out in the last 30s). Killing stream
03/07 14:28:41 Trace: [Nucleus] [zoneplayer/raat] too many dropouts. stopping stream
03/07 14:28:41 Trace: [Nucleus] [zoneplayer/raat] Endpoint XMOS USB Audio 2.0 State Changed: Playing => Prepared
03/07 14:28:41 Info: [Nucleus] [zoneplayer] advance didn't change the track. returning short read
03/07 14:28:41 Trace: [XMOS USB Audio 2.0] [raatclient] SENT [39]{"request":"end_stream"}
03/07 14:28:41 Warn: Track Stopped Due to Slow Media
03/07 14:28:41 Debug: [raat/tcpaudiosource] disconnecting
03/07 14:28:41 Info: [zone Nucleus] OnPlayFeedback StoppedEndOfMediaUnnatural
03/07 14:28:41 Debug: [zone Nucleus] _Advance
03/07 14:28:41 Info: [audio/env] [zoneplayer -> stream] All streams were disposed
03/07 14:28:41 Info: [audio/env] [zoneplayer -> stream -> endpoint] All streams were disposed
03/07 14:28:41 Trace: [XMOS USB Audio 2.0] [raatclient] GOT [37] {"status":"Ended"}

Those reports are indeed similar to mine, although some seem to have it with the native Tidal App as well, which is not something I can corroborate at this point. Maybe Tidal prioritizes the streams from their own app over non-native apps?

You’re probably doing a traceroute on tidal.com, which is not where they stream data from. Their api is hosted on api.tidalhifi.com and the actual streaming happens from e.g. ab-pr-ak.audio.tidal.com.

Might give that a try…I’ll be in Thailand next week with my core on a laptop so will make some observations there too.

I can now reproduce with the native Tidal app as well. So it looks like it’s an upstream problem.

Pretty much been streaming whole day without issue, but between 21:30 and 23:00 things went completely haywire (including the native app). Currently in touch with Tidal support.

Let’s hope it sorts itself out in the near future. That or I’ll go back to buying CDs.

1 Like

Hi @Nepherte,

Thank you for performing that extensive testing! This is an interesting conclusion, thank you for bringing it to my attention. I will also discuss your findings with the team, please let me know if you receive any new updates from TIDAL support regarding this issue.


Based on the sheer amount of posts reporting Tidal playback issues, I’m getting more and more convinced that their servers are simply not up to the task:

  • Pinging Tidal streaming endpoint, I get a 22% packet loss (on a total of 1000 packets).
  • Pinging google.com simultaneously gives me 0% packet loss (on a total of 1000 packets).
  • Speed test shows a download speed of 692.2 Mbps shortly after the ping test was finished.