Tidal playing same song

Hi Noris, I have created a video for you to see. How do I send it to you?

Hi @Dewald_van_Staden,

Can you please upload it to Dropbox / Google Drive and post a link here? Thanks!

Hi @Dewald_van_Staden,

Noris is currently out of town, but I’ll be able to help you our during that time. I’ve sent you a PM with some next steps.

Hi @Dewald_van_Staden,

Next, I’m hoping you can do the following:

  • Make a Backup of your current Roon Database
  • Close Roon on the Core
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Try playing TIDAL content and let us know if the same behavior occurs

Did everything as instructed. Still the same issue.

Thanks for giving that a try, @Dewald_van_Staden.

You can change the current Roon folder to something like Roon Test and the Roon_Old folder back to just Roon and you’ll be back on your existing database.

As for next steps, I’m going to bring this report to our meeting with the senior technical team tomorrow. I’ll be sure to reach out as soon as I have their feedback.

Thanks Dylan.

Hi @Dewald_van_Staden — I was reviewing the diagnostics report that Noris enabled in preparation for the meeting with the team, and I noticed that it looks like you have both Roon and RoonServer on the same machine.

When you cleared the cache, did you clear the cache in the Roon folder or RoonServer folder? Have you tried doing it for both?

Can you share a screenshot of Settings > General so I can verify whether or not you’re using RoonServer as the Core?

I had roonserver on the machine then this issue started. After troubleshooting and trying different solutions I uninstalled roonserver and installed roon to see if the issue might be with roonsserver. I run roon now. In any case I see no roonserver folder under %localappdata%

Thanks for confirming, @Dewald_van_Staden.

I’ll be sure to follow up once I’ve discussed with the team. In the meantime, if you have a different machine you could temporarily use as a Core, it would be good to know if the same behavior occurs for you on a different Core.

That is exactly what I am planning to try next. I will be using an old laptop. Will setup that up and see.

1 Like

Hi Dylan, I connected to a different pc on the network with roonserver running on it. I had to unauthorize the other machine, unfortunately I only have one subscription. I still have the same issue. The only constant in these systems now are my ipad and tidal. The new pc even runs a different library of locally stored music as well… I am running IpadOS 13.2 (I updated to the latest OS to see if this fixes the issue). Previously I ran IpadOS 13.1.3, where i had the issue from the start.

Thanks for giving this a try, @Dewald_van_Staden.

I spoke with our senior technical staff today about the issue. Looking at the diagnostics report, they see that we are making unique requests for each album you try to play, but we are always getting the same content back from TIDAL.

It’s possible that there is a firewall or caching issues somewhere along the line that is causing this problem. Since we didn’t experience this issue when we tested out your TIDAL account on our end, this also adds to that theory.

As a next step, the team has suggested that you try using a VPN on your Core machine to try to access TIDAL in Roon from a different region and see if that yields any changes. Can you give this a try and let us know if it helps?

I enabled my vpn on the core machine (roonserver installed) and it works! But what does this mean now? Can it be ISP related, my router or something else perhaps?

Hi @Dewald_van_Staden,

Okay, that’s a great data point – thanks for doing that testing.

While this means this isn’t a bug in Rooon, we want to make sure we help you get this resolved. Most likely, there is something in between Roon and TIDAL that is caching this request – it could be a corporate or national firewall, or something else on your network. It could also be something related to TIDAL servers, but after discussing this with our team, our engineers think that’s less likely.

In any event, switching to a VPN really shouldn’t have any effect on this issue – since it does, the next step is going to be figuring out what is causing these requests to be cached, since something on the network is preventing Roon from requesting the right track.

Hopefully that helps point you towards a next step, but let us know if you’re still stuck and we’ll see what we can do.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.